]> git.pld-linux.org Git - packages/cone.git/blame_incremental - cone.spec
- release 2 (by relup.sh)
[packages/cone.git] / cone.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # "make check"
4%bcond_with gnutls # GnuTLS instead of OpenSSL
5%bcond_with socks # (Courier) Socks support
6
7Summary: CONE - Console Newsreader and Emailer
8Summary(pl.UTF-8): CONE - tekstowy klient poczty i czytnik newsów
9Name: cone
10Version: 0.96.2
11Release: 2
12License: GPL v3 with OpenSSL exception
13Group: Applications/Mail
14Source0: http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
15# Source0-md5: ea8925d531b43fd8ee36b0363434b1b8
16Patch0: %{name}-maildir.patch
17Patch1: %{name}-curses.patch
18URL: http://www.courier-mta.org/cone/
19BuildRequires: aspell-devel
20BuildRequires: autoconf >= 2.59
21BuildRequires: automake
22%{?with_socks:BuildRequires: courier-sox-devel}
23BuildRequires: courier-unicode-devel >= 2.0
24BuildRequires: fam-devel
25# or gnupg2 --with-gpg2, will use the same at runtime
26BuildRequires: gnupg
27%{?with_gnutls:BuildRequires: gnutls-devel >= 3.0}
28%{?with_gnutls:BuildRequires: libgcrypt-devel}
29%{?with_gnutls:BuildRequires: libgpg-error-devel}
30BuildRequires: libidn-devel >= 0.0.0
31BuildRequires: libstdc++-devel
32BuildRequires: libtool >= 2:1.5
33BuildRequires: libxml2-devel >= 2.0
34BuildRequires: ncurses-devel >= 5
35BuildRequires: openldap-devel
36%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7d}
37BuildRequires: pcre-devel
38BuildRequires: perl-base
39BuildRequires: pkgconfig
40BuildRequires: procps
41BuildRequires: sysconftool
42BuildRequires: zlib-devel
43Requires: ca-certificates
44Suggests: gnupg
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
48CONE is a simple, text-based E-mail reader and writer, and a simple
49newsreader.
50
51%description -l pl.UTF-8
52CONE jest prostym, tekstowym klientem pocztowym, a także prostym
53czytnikiem newsów.
54
55%package devel
56Summary: Header files and static LibMAIL library
57Summary(pl.UTF-8): Pliki nagłówkowe i biblioteka statyczna LibMAIL
58Group: Development/Libraries
59Requires: courier-unicode-devel >= 2.0
60%{?with_gnutls:Requires: gnutls-devel >= 3.0}
61Requires: libidn-devel >= 0.0.0
62Requires: libstdc++-devel
63%{!?with_gnutls:Requires: openssl-devel >= 0.9.7d}
64Obsoletes: cone-static < 0.96
65
66%description devel
67This package includes the header files and static library for
68developing applications using LibMAIL - a high level, C++ OO library
69for mail clients.
70
71%description devel -l pl.UTF-8
72Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
73tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
74zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
75
76%package -n leaf
77Summary: Console text file editor
78Summary(pl.UTF-8): Konsolowy edytor plików tekstowych
79Group: Applications/Editors
80
81%description -n leaf
82Leaf is a simple console text file editor, with paragraph
83word-wrapping and spell checking. Leaf is based on the text editor in
84the Cone mail reader and composer.
85
86%description -n leaf -l pl.UTF-8
87Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
88wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
89używanym w czytniku poczty Cone.
90
91%prep
92%setup -q
93%patch0 -p1
94
95%build
96%{__libtoolize}
97for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
98 if [ -d "$d" ]; then
99 cd $d
100 %{__aclocal}
101 %{__autoconf}
102 if grep -q AC_CONFIG_HEADER configure.ac ; then
103 %{__autoheader}
104 fi
105 %{__automake}
106 cd -
107 fi
108done
109
110%configure \
111 SENDMAIL=/usr/lib/sendmail \
112 --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
113 --with-devel \
114 %{?with_gnutls:--with-gnutls}
115
116%{__make}
117
118%if %{with tests}
119%{__make} check
120%endif
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
127
128%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
129
130# move docs to more specific location
131install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
132%{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(644,root,root,755)
139%doc AUTHORS COPYING ChangeLog NEWS README
140%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
141%attr(755,root,root) %{_bindir}/cone
142%attr(755,root,root) %{_bindir}/mailtool
143%attr(755,root,root) %{_libexecdir}/cone
144%{_datadir}/cone
145%{_mandir}/man1/cone.1*
146%{_mandir}/man1/mailtool.1*
147%dir %{_docdir}/%{name}
148%{_docdir}/%{name}/FAQ.html
149%{_docdir}/%{name}/INSTALL.html
150%{_docdir}/%{name}/README.html
151%{_docdir}/%{name}/add.html
152%{_docdir}/%{name}/attributes.html
153%{_docdir}/%{name}/bk01-toc.html
154%{_docdir}/%{name}/cone*.html
155%{_docdir}/%{name}/conn.html
156%{_docdir}/%{name}/index.html
157%{_docdir}/%{name}/maillist.html
158%{_docdir}/%{name}/mailtool.html
159%{_docdir}/%{name}/manpage.css
160%{_docdir}/%{name}/moredocs.html
161%{_docdir}/%{name}/search.html
162%{_docdir}/%{name}/smap*.html
163%{_docdir}/%{name}/store.html
164
165%files devel
166%defattr(644,root,root,755)
167%{_libdir}/libmail.a
168%{_libdir}/libmail.la
169%{_includedir}/libmail
170%{_mandir}/man3/mail::*.3x*
171%dir %{_docdir}/%{name}
172%{_docdir}/%{name}/account-*.html
173%{_docdir}/%{name}/address.html
174%{_docdir}/%{name}/cppnamespace.html
175%{_docdir}/%{name}/emailaddress.html
176%{_docdir}/%{name}/envelope.html
177%{_docdir}/%{name}/folder-*.html
178%{_docdir}/%{name}/header-*.html
179%{_docdir}/%{name}/libmail*.html
180%{_docdir}/%{name}/mail-*.html
181%{_docdir}/%{name}/mimestruct.html
182%{_docdir}/%{name}/misc.html
183%{_docdir}/%{name}/native.html
184%{_docdir}/%{name}/synchronous.html
185
186%files -n leaf
187%defattr(644,root,root,755)
188%attr(755,root,root) %{_bindir}/leaf
189%{_mandir}/man1/leaf.1*
190%dir %{_docdir}/%{name}
191%{_docdir}/%{name}/leaf.html
This page took 0.095588 seconds and 4 git commands to generate.