]> git.pld-linux.org Git - packages/clementine.git/blame_incremental - clementine.spec
- release 5 (by relup.sh)
[packages/clementine.git] / clementine.spec
... / ...
CommitLineData
1# TODO:
2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3# - apply patches to libprojectM.spec and use
4# - sub-package for kde4 stuff (or nuke them):
5# /usr/share/kde4/services/clementine-feed.protocol
6# /usr/share/kde4/services/clementine-itms.protocol
7# /usr/share/kde4/services/clementine-itpc.protocol
8# /usr/share/kde4/services/clementine-zune.protocol
9#
10# Conditional build:
11%bcond_with static_projectm # with static projectM
12%bcond_with libspotify # build with system libspotify instead of downloading blob
13%bcond_with tests # build without tests
14
15%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
16%define sqlitever 3.14.0-2
17Summary: A music player and library organiser
18Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
19Name: clementine
20Version: 1.3.1
21Release: 5
22License: GPL v3 and GPL v2+
23Group: X11/Applications/Multimedia
24Source0: https://github.com/clementine-player/Clementine/releases/download/%{version}/%{name}-%{version}.tar.xz
25# Source0-md5: 18cc5f66aa5fbb2781198a65439bd38a
26Patch1: unbundle-po.patch
27Patch2: %{name}-udisks-headers.patch
28Patch3: %{name}-mygpo.patch
29URL: http://www.clementine-player.org/
30BuildRequires: QtCore-devel >= %{qtver}
31BuildRequires: QtDBus-devel >= %{qtver}
32BuildRequires: QtGui-devel >= %{qtver}
33BuildRequires: QtIOCompressor-devel >= 2.3
34BuildRequires: QtNetwork-devel >= %{qtver}
35BuildRequires: QtOpenGL-devel >= %{qtver}
36BuildRequires: QtSingleApplication-devel >= 2.6-4
37BuildRequires: QtSql-devel >= %{qtver}
38%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
39BuildRequires: QtXml-devel >= %{qtver}
40BuildRequires: boost-devel
41BuildRequires: cmake >= 2.6
42BuildRequires: cryptopp-devel >= 5.6.1-4
43BuildRequires: desktop-file-utils
44BuildRequires: gettext-tools
45%{?with_static_projectm:BuildRequires: glew-devel}
46BuildRequires: glib2-devel
47BuildRequires: gstreamer-devel
48BuildRequires: gstreamer-plugins-base-devel
49BuildRequires: gtest-devel
50BuildRequires: libcdio-devel
51BuildRequires: libchromaprint-devel
52BuildRequires: libechonest-devel
53BuildRequires: libgpod-devel >= 0.7.92
54BuildRequires: libimobiledevice-devel >= 1.1.5
55BuildRequires: liblastfm-devel >= 0.3.3
56BuildRequires: libmtp-devel >= 1.0
57BuildRequires: libmygpo-qt-devel >= 1.0.7
58BuildRequires: libplist-devel
59%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
60BuildRequires: libqxt-devel
61%{?with_libspotify:BuildRequires: libspotify-devel >= 12.1.45}
62BuildRequires: libusbmuxd-devel
63BuildRequires: libxml2-devel
64BuildRequires: pkgconfig
65BuildRequires: pkgconfig
66BuildRequires: protobuf-devel
67BuildRequires: qjson-devel
68BuildRequires: qt4-build >= %{qtver}
69BuildRequires: qt4-linguist
70BuildRequires: qt4-qmake
71BuildRequires: rpmbuild(find_lang) >= 1.38
72BuildRequires: rpmbuild(macros) >= 1.596
73BuildRequires: sed >= 4.0
74BuildRequires: sparsehash-devel
75BuildRequires: sqlite3-devel >= %{sqlitever}
76BuildRequires: taglib-devel >= 1.8
77BuildRequires: tar >= 1:1.22
78BuildRequires: xz
79Requires(post,postun): desktop-file-utils
80Requires(post,postun): gtk-update-icon-cache
81Requires(post,postun): hicolor-icon-theme
82BuildRequires: sqlite3 >= %{sqlitever}
83Requires: QtSingleApplication >= 2.6-4
84Requires: QtSql-sqlite3 >= %{qtver}
85Requires: gstreamer-audio-effects-base
86Requires: gstreamer-mad
87Suggests: gstreamer-flac
88# if we do not link, we use datafiles
89%{!?with_static_projectm:Requires: libprojectM}
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92# see libprojectM.spec for explanation
93%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
94
95%description
96Clementine is a modern music player and library organiser. It is
97largely a port of Amarok 1.4, with some features rewritten to take
98advantage of Qt4.
99
100%description -l hu.UTF-8
101Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
102az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
103a Qt4 előnyeit.
104
105%prep
106%setup -q
107%patch1 -p1
108%patch2 -p1
109#%patch3 -p1
110
111# cleanup vendor. keep only needed libraries.
112mv 3rdparty 3rdparty.dist
113vendor() {
114 local path dir
115 for path; do
116 dir=$(dirname $path)
117 test -d 3rdparty/$dir || mkdir -p 3rdparty/$dir
118 mv 3rdparty.dist/$path 3rdparty/$path
119 done
120}
121vendor sha2 qocoa
122vendor qsqlite
123%{?with_static_projectm:vendor libprojectm}
124# missing in pld
125vendor vreen
126# requires 1.0.9, but only 1.0.8 is released
127vendor libmygpo-qt
128
129# Don't build tests. They require gmock
130sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
131# remove -Wall
132sed -i -e 's/-Wall//' src/CMakeLists.txt
133
134%build
135install -d build
136install -d build/src/translations
137cd build
138# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~135
139CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
140%cmake \
141 -DBUILD_WERROR:BOOL=OFF \
142 -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
143 -DCMAKE_INCLUDE_PATH=%{_includedir}/qt4 \
144 -DBUNDLE_PROJECTM_PRESETS=OFF \
145 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
146 -DUSE_SYSTEM_QXT=ON \
147 -DUSE_SYSTEM_PROJECTM=ON \
148 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions \
149 ..
150%{__make}
151
152desktop-file-validate ../dist/%{name}.desktop
153
154%if %{with tests}
155%endif
156
157%install
158rm -rf $RPM_BUILD_ROOT
159%{__make} -C build install \
160 DESTDIR=$RPM_BUILD_ROOT
161
162%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/kde4/services
163
164# not in our glibc?
165rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
166rm -r $RPM_BUILD_ROOT%{_localedir}/he_IL
167rm -r $RPM_BUILD_ROOT%{_localedir}/mk_MK
168rm -r $RPM_BUILD_ROOT%{_localedir}/si_LK
169
170%find_lang %{name} --with-qm
171
172install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
173cp -p dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
174cp -p dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post
180%update_desktop_database_post
181%update_icon_cache hicolor
182
183%postun
184%update_desktop_database_postun
185%update_icon_cache hicolor
186
187%files -f %{name}.lang
188%defattr(644,root,root,755)
189%doc Changelog
190%attr(755,root,root) %{_bindir}/clementine
191%attr(755,root,root) %{_bindir}/clementine-tagreader
192%{_desktopdir}/clementine.desktop
193%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
194%{_iconsdir}/hicolor/*/apps/clementine-panel.png
195%{_iconsdir}/hicolor/*/apps/clementine.png
196%{_iconsdir}/hicolor/*/apps/clementine.svg
197%{_datadir}/appdata/clementine.appdata.xml
This page took 0.025584 seconds and 4 git commands to generate.