]> git.pld-linux.org Git - packages/clearsilver.git/blame_incremental - clearsilver.spec
- release 5
[packages/clearsilver.git] / clearsilver.spec
... / ...
CommitLineData
1Summary: ClearSilver HTML template system
2Summary(pl.UTF-8): ClearSilver - system szablonów HTML
3Name: clearsilver
4Version: 0.10.5
5Release: 5
6License: Apache License style
7Group: Development/Libraries
8Source0: http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
9# Source0-md5: b8c0c7fbe0ef5e06e0c935f134304d44
10Patch0: %{name}-pic.patch
11URL: http://www.clearsilver.net/
12BuildRequires: autoconf
13BuildRequires: automake
14BuildRequires: perl-ExtUtils-MakeMaker
15BuildRequires: perl-devel
16BuildRequires: python-devel
17BuildRequires: zlib-devel
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21ClearSilver is a fast, powerful, and language-neutral HTML template
22system. In both static content sites and dynamic HTML applications, it
23provides a separation between presentation code and application logic
24which makes working with your project easier.
25
26%description -l pl.UTF-8
27ClearSilver to szybki, potężny i niezależny od języka system szablonów
28HTML. Zarówno w statycznych stronach HTML jak i dynamicznych
29aplikacjach pomaga oddzielić kod prezentacyjny od logiki aplikacji, co
30ułatwia pracę nad projektem.
31
32%package devel
33Summary: ClearSilver development package
34Summary(pl.UTF-8): Pakiet programistyczny ClearSilver
35Group: Development/Libraries
36
37%description devel
38This package provides needed files to develop extension to
39ClearSilver.
40
41%description devel -l pl.UTF-8
42Ten pakiet dostarcza pliki potrzebne do tworzenia rozszerzeń dla
43ClearSilver.
44
45%package -n python-clearsilver
46Summary: Neotonic ClearSilver Python Module
47Summary(pl.UTF-8): Moduł Pythona Neotonic ClearSilver
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description -n python-clearsilver
52This package provides a Python interface to the ClearSilver CGI kit
53and templating system.
54
55%description -n python-clearsilver -l pl.UTF-8
56Ten pakiet dostarcza interfejs Pythona do zestawu CGI i systemu
57szablonów ClearSilver.
58
59%package -n perl-ClearSilver
60Summary: Neotonic ClearSilver Perl Module
61Summary(pl.UTF-8): Moduł Perla Neotonic ClearSilver
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description -n perl-ClearSilver
66This package provides a Perl interface to the ClearSilver templating
67system.
68
69%description -n perl-ClearSilver -l pl.UTF-8
70Ten pakiet dostarcza interfejs Perla do systemu szablonów ClearSilver.
71
72%package -n ruby-clearsilver
73Summary: Neotonic ClearSilver Ruby Module
74Summary(pl.UTF-8): Moduł Ruby'ego Neotonic ClearSilver
75Group: Development/Libraries
76Requires: %{name} = %{version}-%{release}
77
78%description -n ruby-clearsilver
79This package provides a ruby interface to the ClearSilver templating
80system.
81
82%description -n ruby-clearsilver -l pl.UTF-8
83Ten pakiet dostarcza interfejs języka Ruby do systemu szablonów
84ClearSilver.
85
86%prep
87%setup -q
88%patch0 -p1
89
90find . -type f -print0 | xargs -0 perl -pi -e "s!/usr/local/bin!/usr/bin!g"
91
92%build
93install /usr/share/automake/config.* .
94%{__aclocal}
95%{__autoconf}
96%configure \
97 --disable-csharp \
98 --disable-java \
99 --disable-ruby \
100 --enable-apache \
101 --enable-perl \
102 --with-python=%{__python}
103
104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT \
111 INSTALLDIRS=vendor
112
113%{__make} install -C python \
114 PYTHON_SITE=%{py_sitedir} \
115 DESTDIR=$RPM_BUILD_ROOT
116
117%{__make} install -C perl \
118 DESTDIR=$RPM_BUILD_ROOT \
119 INSTALLDIRS=vendor
120
121rm -rf $RPM_BUILD_ROOT%{perl_archlib} \
122 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*{,/*{,/*}}/.packlist
123
124# what an ass putting it to lib32 dir
125%if "%{_lib}" != "lib"
126rm $RPM_BUILD_ROOT%{_prefix}/lib/python%{py_ver}/site-packages/neo_cgi.so
127%endif
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%files
133%defattr(644,root,root,755)
134%doc CS_LICENSE INSTALL LICENSE README scripts/cs_lint.py contrib/cs-mode.el
135%attr(755,root,root) %{_bindir}/*
136
137%files devel
138%defattr(644,root,root,755)
139%{_libdir}/libneo_*.a
140%{_includedir}/ClearSilver
141%{_mandir}/man3/[!C]*.3*
142
143%files -n python-clearsilver
144%defattr(644,root,root,755)
145%doc README.python
146%attr(755,root,root) %{py_sitedir}/neo_cgi.so
147
148%files -n perl-ClearSilver
149%defattr(644,root,root,755)
150%{perl_vendorarch}/ClearSilver.pm
151%dir %{perl_vendorarch}/auto/ClearSilver
152%{perl_vendorarch}/auto/ClearSilver/ClearSilver.bs
153%attr(755,root,root) %{perl_vendorarch}/auto/ClearSilver/ClearSilver.so
154%{_mandir}/man3/ClearSilver.3pm*
155
156%if 0
157%files -n ruby
158%defattr(644,root,root,755)
159%{ruby_sitepath}/%{ruby_version}/neo.rb
160%attr(755,root,root) %{ruby_sitepath}/%{ruby_version}/%{ruby_arch}/hdf.so
161
162%files -n mod_ecs
163%defattr(644,root,root,755)
164%attr(755,root,root) %{apache_libexec}/mod_ecs.so
165%endif
This page took 0.074284 seconds and 4 git commands to generate.