]> git.pld-linux.org Git - packages/chromaprint.git/blame_incremental - chromaprint.spec
- updated to 1.4.2
[packages/chromaprint.git] / chromaprint.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ffmpeg # fpcalc build + libchromaprint using avfft
4%bcond_with fftw3 # libchromaprint using fftw3 instead of avfft
5#
6%if %{without ffmpeg}
7%define with_fftw3 1
8%endif
9Summary: Library implementing the AcoustID fingerprinting
10Summary(pl.UTF-8): Biblioteka implementująca odciski AcoustID
11Name: chromaprint
12Version: 1.4.2
13Release: 1
14License: LGPL v2.1+
15Group: Libraries
16Source0: https://bitbucket.org/acoustid/chromaprint/downloads/%{name}-%{version}.tar.gz
17# Source0-md5: 895c42ba6d769840a2e10e507ad9f14d
18URL: https://acoustid.org/chromaprint
19BuildRequires: cmake >= 2.8.12
20%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.6}
21%{?with_fftw3:BuildRequires: fftw3-devel >= 3}
22BuildRequires: libstdc++-devel
23BuildRequires: taglib-devel
24Requires: libchromaprint = %{version}-%{release}
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Chromaprint library is the core component of the AcoustID project.
29It's a client-side library that implements a custom algorithm for
30extracting fingerprints from raw audio sources.
31
32The library exposes a simple C API and the Python language binding is
33also available. The documentation for the C API can be found in the
34main header file.
35
36%description -l pl.UTF-8
37Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
38biblioteka kliencka implementująca własny algorytm wydobywania
39odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
40
41Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
42Pythona. Dokumentację dla API C można znaleźć w głównym pliku
43nagłówkowym.
44
45%package -n libchromaprint
46Summary: Library implementing the AcoustID fingerprinting
47Summary(pl.UTF-8): Biblioteka implementująca odciski AcoustID
48Group: Libraries
49
50%description -n libchromaprint
51Chromaprint library is the core component of the AcoustID project.
52It's a client-side library that implements a custom algorithm for
53extracting fingerprints from raw audio sources.
54
55The library exposes a simple C API and the Python language binding
56is also available. The documentation for the C API can be found in the
57main header file.
58
59%description -n libchromaprint -l pl.UTF-8
60Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
61biblioteka kliencka implementująca własny algorytm wydobywania
62odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
63
64Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
65Pythona. Dokumentację dla API C można znaleźć w głównym pliku
66nagłówkowym.
67
68%package -n libchromaprint-devel
69Summary: Headers for developing programs that will use libchromaprint
70Summary(pl.UTF-8): Pliki nagłówkowe do tworzenia programów wykorzystujących libchromaprint
71Group: Development/Libraries
72Requires: libchromaprint = %{version}-%{release}
73
74%description -n libchromaprint-devel
75This package contains the headers that programmers will need to
76develop applications which will use libchromaprint.
77
78%description -n libchromaprint-devel -l pl.UTF-8
79Ten pakiet zawiera pliki nagłówkowe potrzebne programistom do
80tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
81
82%prep
83%setup -q
84
85%build
86%cmake . \
87 %{?with_ffmpeg:-DBUILD_TOOLS=ON} \
88 %{!?with_fftw3:-DWITH_AVFFT=ON} \
89 %{?with_fftw3:-DWITH_FFTW3=ON}
90
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -n libchromaprint -p /sbin/ldconfig
102%postun -n libchromaprint -p /sbin/ldconfig
103
104%if %{with ffmpeg}
105%files
106%defattr(644,root,root,755)
107%attr(755,root,root) %{_bindir}/fpcalc
108%endif
109
110%files -n libchromaprint
111%defattr(644,root,root,755)
112%doc NEWS.txt README.md
113%attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
114%attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.1
115
116%files -n libchromaprint-devel
117%defattr(644,root,root,755)
118%attr(755,root,root) %{_libdir}/libchromaprint.so
119%{_includedir}/chromaprint.h
120%{_pkgconfigdir}/libchromaprint.pc
This page took 0.047907 seconds and 4 git commands to generate.