]> git.pld-linux.org Git - packages/cacti-plugin-weathermap.git/blame_incremental - cacti-plugin-weathermap.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cacti-plugin-weathermap.git] / cacti-plugin-weathermap.spec
... / ...
CommitLineData
1# TODO
2# - config file, patches, package for not cacti plugin
3# - system vera ttf fonts, jquery
4%define plugin weathermap
5%define php_min_version 5.2.0
6Summary: Plugin for Cacti - WeatherMap
7Summary(pl.UTF-8): Wtyczka do Cacti - WeatherMap (mapa pogody)
8Name: cacti-plugin-weathermap
9Version: 0.97a
10Release: 0.1
11License: GPL v2
12Group: Applications/WWW
13Source0: http://www.network-weathermap.com/files/php-%{plugin}-%{version}.zip
14# Source0-md5: 7eb70243fef163721423b3e87d7e84b4
15URL: http://www.network-weathermap.com/
16BuildRequires: rpm-perlprov
17BuildRequires: rpm-php-pearprov >= 4.4.2-11
18BuildRequires: rpmbuild(macros) >= 1.554
19BuildRequires: sed >= 4.0
20BuildRequires: unzip
21Requires: cacti
22Requires: php(core) >= %{php_min_version}
23Requires: php(date)
24Requires: php(gd)
25Requires: php(mysql)
26Requires: php(pcre)
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define cactidir /usr/share/cacti
31%define plugindir %{cactidir}/plugins/%{plugin}
32
33# provided by package itself
34%define _noautopear pear(HTML_ImageMap.class.php) pear(Weathermap.class.php) pear(editor-config.php) pear(editor.inc.php)
35
36# put it together for rpmbuild
37%define _noautoreq %{?_noautophp} %{?_noautopear}
38
39%description
40Weathermap plugin for Cacti is a network visualisation tool, to take
41data you already have and show you an overview of your network in map
42form.
43
44Support is built in for RRD, MRTG (RRD and old log-format), and
45tab-delimited text files. Other sources are via plugins or external
46scripts.
47
48%description -l pl.UTF-8
49Wtyczka Weathermap dla Cacti to narzędzie do wizualizacji sieci,
50pobierające już istniejące dane i tworzące widok sieci w postaci mapy.
51
52Ma wbudowaną obsługę plików RRD, MRTG (RRD i starego formatu logów)
53oraz tekstowych rozdzielonych tabulacjami. Inne źródła są dostępne
54przez wtyczki lub zewnętrzne skrypty.
55
56%prep
57%setup -qc
58
59%undos -f php,inc
60
61# fix php path
62%{__sed} -i -e '1s,#!.*bin/php,#!%{_bindir}/php,' %{plugin}/%{plugin}
63
64mv %{plugin}/editor-config.php{-dist,}
65
66# in docs
67mv %{plugin}/{CHANGES,COPYING,README} .
68mv %{plugin}/docs .
69
70# junk not neccessary for plugin run
71mv %{plugin}/random-bits .
72mv %{plugin}/net-data.txt .
73mv %{plugin}/convert-to-dsstats.php .
74rm -rf %{plugin}/output
75
76%install
77rm -rf $RPM_BUILD_ROOT
78install -d $RPM_BUILD_ROOT%{plugindir}/output
79cp -a %{plugin}/* $RPM_BUILD_ROOT%{plugindir}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
86%doc README CHANGES
87%{plugindir}
This page took 0.130119 seconds and 4 git commands to generate.