]> git.pld-linux.org Git - packages/bootparamd.git/blame_incremental - bootparamd.spec
- use ross include instead symlinks between man pages.
[packages/bootparamd.git] / bootparamd.spec
... / ...
CommitLineData
1Summary: A server process which provides boot information to diskless clients
2Name: bootparamd
3Version: 0.17
4Release: 1
5License: BSD
6Group: Networking/Daemons
7Group(pl): Sieciowe/Serwery
8Source0: ftp://ftp.linux.org.uk/pub/linux/Networking/netkit/netkit-%{name}-%{version}.tar.gz
9Source1: bootparamd.init
10Prereq: /sbin/chkconfig
11Requires: portmap
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15The bootparamd process provides bootparamd, a server process which
16provides the information needed by diskless clients in order for them
17to successfully boot. Bootparamd looks first in /etc/bootparams for an
18entry for that particular client; if a local bootparams file doesn't
19exist, it looks at the appropriate Network Information Service (NIS)
20map. Some network boot loaders (notably Sun's) rely on special boot
21server code on the server, in addition to the rarp and tftp servers.
22This bootparamd server process is compatible with SunOS bootparam
23clients and servers which need that boot server code.
24
25%prep
26%setup -q -n netkit-bootparamd-%{version}
27
28%build
29./configure --with-c-compiler=gcc
30%{__make} CFLAGS="$RPM_OPT_FLAGS"
31
32%install
33rm -rf $RPM_BUILD_ROOT
34install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8} \
35 $RPM_BUILD_ROOT/etc/rc.d/init.d
36
37%{__make} install \
38 INSTALLROOT=$RPM_BUILD_ROOT \
39 MANDIR=%{_mandir}
40
41install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootparamd
42
43gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man8/*
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%post
49/sbin/chkconfig --add bootparamd
50if [ -f /var/lock/subsys/rpc.bootparamd ]; then
51 /etc/rc.d/init.d/bootparamd restart 1>&2
52else
53 echo "Type \"/etc/rc.d/init.d/bootparamd start\" to start rpc.bootparamd server" 1>&2
54fi
55
56%postun
57if [ "$1" = "0" ]; then
58 if [ -f /var/lock/subsys/rpc.bootparamd ]; then
59 /etc/rc.d/init.d/bootparamd stop 1>&2
60 fi
61 /sbin/chkconfig --del bootparamd
62fi
63
64%files
65%defattr(644,root,root,755)
66%attr(754,root,root) /etc/rc.d/init.d/bootparamd
67%attr(755,root,root) %{_sbindir}/rpc.bootparamd
68%attr(755,root,root) %{_bindir}/callbootd
69%{_mandir}/man8/*
This page took 0.075094 seconds and 4 git commands to generate.