]> git.pld-linux.org Git - packages/bitbake.git/blame_incremental - bitbake.spec
- release 2
[packages/bitbake.git] / bitbake.spec
... / ...
CommitLineData
1Summary: BitBake build tool
2Summary(pl.UTF-8): BitBake - narzędzie do budowania
3Name: bitbake
4Version: 1.8.18
5Release: 2
6License: GPL
7Group: Development
8Source0: http://download.berlios.de/bitbake/%{name}-%{version}.tar.gz
9# Source0-md5: f772ca3121103ab3500c7f1609a96271
10URL: http://developer.berlios.de/projects/bitbake/
11BuildRequires: python-devel >= 1:2.5
12BuildRequires: rpm-pythonprov
13BuildRequires: sed >= 4.0
14%pyrequires_eq python
15Requires: bash
16Requires: python-modules
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21BitBake is a simple tool for the execution of tasks. It is derived
22from Portage, which is the package management system used by the
23Gentoo Linux distribution. It is most commonly used to build packages,
24as it can easily use its rudimentary inheritance to abstract common
25operations, such as fetching sources, unpacking them, patching them,
26compiling them, and so on. It is the basis of the OpenEmbedded
27project, which is being used for OpenZaurus, Familiar, and a number of
28other Linux distributions.
29
30%description -l pl.UTF-8
31BitBake to proste narzędzie do wykonywania zadań. Wywodzi się z
32Portage, które jest systemem zarządzania pakietami używanym w
33dystrybucji Linuksa Gentoo. Najczęściej jest używane do budowania
34pakietów, jako że może łatwo używać swojej elementarnej dziedziczności
35do abstrahowania wspólnych operacji, takich jak pobieranie źródeł,
36rozpakowywanie ich, łatanie, kompilowanie i tak dalej. Jest podstawą
37projektu OpenEmbedded, używanego przez projekty OpenZaurus, Familiar i
38wiele innych dystrybucji Linuksa.
39
40%prep
41%setup -q
42sed -i -e 's@#!/bin/sh[[:space:]]@#!/bin/bash @' \
43 -e 's@%s%ssh[[:space:]]@%s%sbash @' lib/bb/build.py
44
45%build
46python setup.py build
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT%{_sysconfdir}
51
52python setup.py install \
53 --prefix=%{_prefix} \
54 --root=$RPM_BUILD_ROOT
55
56mv $RPM_BUILD_ROOT%{_datadir}/%{name}/conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
57ln -s %{_sysconfdir}/%{name} $RPM_BUILD_ROOT%{_datadir}/%{name}/conf
58
59%clean
60rm -rf ${RPM_BUILD_ROOT}
61
62%files
63%defattr(644,root,root,755)
64%attr(755,root,root) %{_bindir}/*
65%{_sysconfdir}/%{name}
66%{_datadir}/%{name}
67%dir %{py_sitescriptdir}/bb
68%{py_sitescriptdir}/bb/*py[co]
69%dir %{py_sitescriptdir}/bb/fetch
70%{py_sitescriptdir}/bb/fetch/*py[co]
71%dir %{py_sitescriptdir}/bb/parse
72%{py_sitescriptdir}/bb/parse/*py[co]
73%dir %{py_sitescriptdir}/bb/parse/parse_py
74%{py_sitescriptdir}/bb/parse/parse_py/*py[co]
This page took 0.033307 seconds and 4 git commands to generate.