]> git.pld-linux.org Git - packages/bakefile.git/blame_incremental - bakefile.spec
- 1.x version note
[packages/bakefile.git] / bakefile.spec
... / ...
CommitLineData
1# NOTE: for 1.x versions see DEVEL branch; it's not compatible with 0.x, and (according to web site) still work in progress.
2Summary: Native makefiles generator
3Summary(pl.UTF-8): Generator natywnych plików typu Makefile
4Name: bakefile
5Version: 0.2.10
6Release: 1
7License: MIT
8Group: Development/Building
9#SourceDownload: https://github.com/vslavik/bakefile/releases
10Source0: https://github.com/vslavik/bakefile/releases/download/v%{version}/%{name}-%{version}.tar.gz
11# Source0-md5: f980cdd36268b5d2b23602d454bdf0a4
12Patch0: %{name}-empy.patch
13URL: http://bakefile.org/
14BuildRequires: autoconf >= 2.53
15BuildRequires: automake >= 1.6
16BuildRequires: libtool
17BuildRequires: python-devel >= 1:2.5
18BuildRequires: rpm-pythonprov
19%pyrequires_eq python-modules
20Requires: empy >= 3.1
21Requires: python-libxml2
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Bakefile is cross-platform, cross-compiler native makefiles generator.
26It takes compiler-independent description of build tasks as input and
27generate native makefile (autoconf's Makefile.in, Visual C++ project,
28bcc makefile etc.).
29
30%description -l pl.UTF-8
31Bakefile to generator natywnych plików typu Makefile dla wielu
32platform i kompilatorów. Przyjmuje na wejściu niezależny od
33kompilatora opis zadań budowania i tworzy natywny plik (Makefile.in
34dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
35
36%prep
37%setup -q
38%patch0 -p1
39
40%build
41%{__libtoolize}
42%{__aclocal} -I admin
43%{__autoconf}
44%{__automake}
45%configure
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50%{__make} install \
51 DESTDIR=$RPM_BUILD_ROOT
52
53# use system available modules
54%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,py25modules}
55
56%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
57find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.py' | grep -E -v '/bakefile(_gen)?\.py' | xargs %{__rm}
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc AUTHORS COPYING NEWS README THANKS doc/html
65%attr(755,root,root) %{_bindir}/bakefile
66%attr(755,root,root) %{_bindir}/bakefile_gen
67%attr(755,root,root) %{_bindir}/bakefilize
68%{_datadir}/%{name}
69%dir %{_libdir}/%{name}
70%{_libdir}/%{name}/*.py[oc]
71%attr(755,root,root) %{_libdir}/%{name}/_bkl_c.so
72%attr(755,root,root) %{_libdir}/%{name}/bakefile.py
73%attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
74%{_aclocaldir}/bakefile*.m4
75%{_mandir}/man1/bakefile.1*
76%{_mandir}/man1/bakefile_gen.1*
77%{_mandir}/man1/bakefilize.1*
This page took 0.030336 seconds and 4 git commands to generate.