]> git.pld-linux.org Git - packages/aircrack-ng.git/blame_incremental - aircrack-ng.spec
disable custom optimization level
[packages/aircrack-ng.git] / aircrack-ng.spec
... / ...
CommitLineData
1#
2# TODO:
3# - PLD it more
4# - sbin/bin - change to bin?
5# - finish ext_scripts bcond:
6# -- check python related BR and R
7# -- fix packaging python releated stuff
8# -- create subpackage for airoscript
9# -- fix directory for airoscript*.conf files
10# -- fix installation of airoscript desktop files
11#
12# Conditional build:
13%bcond_without sqlite # build without sqlite support
14%bcond_without experimental
15%bcond_with ext_scripts # build with extra scripts (NFY)
16%define lib_ver 1.7.0
17
18Summary: Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
19Summary(pl.UTF-8): Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
20Name: aircrack-ng
21Version: 1.7
22Release: 2
23License: GPL
24Group: Applications/Networking
25Source0: http://download.aircrack-ng.org/%{name}-%{version}.tar.gz
26# Source0-md5: a918ea7146f91d8c799fb770c38f4bec
27URL: http://www.aircrack-ng.org/
28BuildRequires: autoconf >= 2.52
29BuildRequires: automake >= 1:1.14
30BuildRequires: hwloc-devel
31BuildRequires: libgcrypt-devel >= 1.2.0
32BuildRequires: libnl-devel >= 1:3.2
33BuildRequires: libpcap-devel
34BuildRequires: libstdc++-devel >= 6:4.8.1
35BuildRequires: libtool
36BuildRequires: pcre-devel
37BuildRequires: pkgconfig
38BuildRequires: python3
39BuildRequires: rpmbuild(macros) >= 2.007
40%{?with_sqlite:BuildRequires: sqlite3-devel}
41BuildRequires: zlib-devel
42Requires: awk
43Requires: coreutils
44Requires: ethtool
45Requires: grep
46Requires: iproute2
47Requires: iw
48Requires: libnl >= 1:3.2
49Requires: pciutils
50Requires: usbutils
51Requires: util-linux
52Requires: virtual(module-tools)
53Suggests: wireless-tools
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56%description
57aircrack-ng is a set of tools for auditing wireless networks. It's an
58enhanced/reborn version of aircrack. It consists of airodump-ng (an
59802.11 packet capture program), aireplay-ng (an 802.11 packet
60injection program), aircrack (static WEP and WPA-PSK cracking),
61airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
62capture files (merge, convert, etc.).
63
64%description -l pl.UTF-8
65aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
66Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
67airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
68wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
69WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
70WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
71convert, etc.).
72
73%package devel
74Summary: Development files for %{name}
75Summary(pl.UTF-8): Pliki deweloperskie dla %{name}
76Group: Development/Libraries
77Requires: %{name} = %{version}
78
79%description devel
80Development files for %{name}.
81
82%description devel -l pl.UTF-8
83Pliki deweloperskie dla %{name}
84
85%prep
86%setup -q
87# Force python3 interpreter
88grep -r -l '#!/usr/bin/env python' scripts | xargs sed -i -e 's|#!/usr/bin/env python|#!%{__python3}|g'
89
90%build
91# GCC LTO objects must be "fat" to avoid assembly errors
92export CFLAGS="%{rpmcflags} -ffat-lto-objects -fcommon"
93
94%{__libtoolize}
95%{__aclocal} -I build/m4/stubs -I build/m4
96%{__autoconf}
97%{__autoheader}
98%{__automake}
99%configure \
100 PYTHON=%{__python3} \
101 ETHTOOL=/sbin/ethtool \
102 --disable-silent-rules \
103 --with-gcrypt \
104 --enable-libnl \
105 --with%{!?with_experimental:out}-experimental \
106 --with%{!?with_ext_scripts:out}-ext-scripts \
107 --without-opt \
108 --with-%{!?with_sqlite:out}-sqlite3 \
109
110%{__make}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
115
116%{__make} install \
117 DESTDIR=$RPM_BUILD_ROOT
118
119find $RPM_BUILD_ROOT -type f \( -name "*.la" -o -name "*.a" \) -delete -print
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
129%doc AUTHORS ChangeLog README test patches
130%attr(755,root,root) %{_bindir}/aircrack-ng
131%attr(755,root,root) %{_bindir}/airdecap-ng
132%attr(755,root,root) %{_bindir}/airdecloak-ng
133%{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
134%attr(755,root,root) %{_bindir}/ivstools
135%attr(755,root,root) %{_bindir}/kstats
136%attr(755,root,root) %{_bindir}/makeivs-ng
137%attr(755,root,root) %{_bindir}/packetforge-ng
138%attr(755,root,root) %{_bindir}/wpaclean
139%attr(755,root,root) %{_sbindir}/airbase-ng
140%attr(755,root,root) %{_sbindir}/aireplay-ng
141%attr(755,root,root) %{_sbindir}/airmon-ng
142%attr(755,root,root) %{_sbindir}/airodump-ng
143%attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
144%attr(755,root,root) %{_sbindir}/airventriloquist-ng
145%attr(755,root,root) %{_sbindir}/airserv-ng
146%attr(755,root,root) %{_sbindir}/airtun-ng
147%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-%{lib_ver}.so
148%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa.so
149%ifarch %{ix86} %{x8664} x32
150%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx-%{lib_ver}.so
151%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx2-%{lib_ver}.so
152%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx2.so
153%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx.so
154%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-sse2-%{lib_ver}.so
155%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-sse2.so
156%endif
157%ifarch %{arm_with_neon}
158%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-arm-neon-%{lib_ver}.so
159%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-arm-neon.so
160%endif
161%attr(755,root,root) %{_libdir}/libaircrack-osdep-%{lib_ver}.so
162%attr(755,root,root) %{_libdir}/libaircrack-osdep.so
163
164%{_mandir}/man1/aircrack-ng.1*
165%{_mandir}/man1/airdecap-ng.1*
166%{_mandir}/man1/airdecloak-ng.1*
167%{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
168%{_mandir}/man1/besside-ng-crawler.1*
169%{_mandir}/man1/ivstools.1*
170%{_mandir}/man1/kstats.1*
171%{_mandir}/man1/makeivs-ng.1*
172%{_mandir}/man1/packetforge-ng.1*
173%{_mandir}/man1/wpaclean.1*
174%{_mandir}/man8/airbase-ng.8*
175%{_mandir}/man8/aireplay-ng.8*
176%{_mandir}/man8/airventriloquist-ng.8*
177%{_mandir}/man8/airmon-ng.8*
178%{_mandir}/man8/airodump-ng-oui-update.8*
179%{_mandir}/man8/airodump-ng.8*
180%{_mandir}/man8/airserv-ng.8*
181%{_mandir}/man8/airtun-ng.8*
182
183%if %{with experimental}
184%attr(755,root,root) %{_bindir}/besside-ng-crawler
185%attr(755,root,root) %{_bindir}/buddy-ng
186%attr(755,root,root) %{_sbindir}/besside-ng
187%attr(755,root,root) %{_sbindir}/easside-ng
188%attr(755,root,root) %{_sbindir}/tkiptun-ng
189%attr(755,root,root) %{_sbindir}/wesside-ng
190%{_mandir}/man1/buddy-ng.1*
191%{_mandir}/man8/besside-ng.8*
192%{_mandir}/man8/easside-ng.8*
193%{_mandir}/man8/tkiptun-ng.8*
194%{_mandir}/man8/wesside-ng.8*
195%endif
196
197%files devel
198%defattr(644,root,root,755)
199%{_includedir}/%{name}
This page took 0.043552 seconds and 4 git commands to generate.