]> git.pld-linux.org Git - packages/zfs.git/blame - zfs.spec
- pl for python* packages
[packages/zfs.git] / zfs.spec
CommitLineData
06fbfb84
JB
1# TODO:
2# - PLDify init script
3# - unpackaged initramfs-tools support:
4# /usr/share/initramfs-tools/conf-hooks.d/zfs
5# /usr/share/initramfs-tools/hooks/zfs
6# /usr/share/initramfs-tools/scripts/zfs
bff0a8a1
JB
7#
8# Conditional build:
bff0a8a1
JB
9%bcond_without kernel # don't build kernel modules
10%bcond_without userspace # don't build userspace programs
6f114c88
JR
11%bcond_without python2 # CPython 2.x module
12%bcond_without python3 # CPython 3.x module
bff0a8a1
JB
13%bcond_with verbose # verbose build (V=1)
14#
3921af7f
JR
15# The goal here is to have main, userspace, package built once with
16# simple release number, and only rebuild kernel packages with kernel
17# version as part of release number, without the need to bump release
18# with every kernel change.
19%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
20%{error:kernel and userspace cannot be built at the same time on PLD builders}
21exit 1
22%endif
23
bff0a8a1
JB
24%if %{without userspace}
25# nothing to be placed to debuginfo package
26%define _enable_debug_packages 0
27%endif
3921af7f
JR
28
29%define _duplicate_files_terminate_build 0
30
540b3d9e 31%define _rc rc4
17881c04 32%define rel 0.%{_rc}.2
3921af7f 33%define pname zfs
bff0a8a1
JB
34Summary: Native Linux port of the ZFS filesystem
35Summary(pl.UTF-8): Natywny linuksowy port systemu plików ZFS
3921af7f 36Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
6a410e14 37Version: 0.8.0
3921af7f 38Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
0b82b0f8 39License: CDDL
bff0a8a1 40Group: Applications/System
0b82b0f8 41#Source0: https://github.com/zfsonlinux/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
6a410e14 42Source0: https://github.com/zfsonlinux/zfs/archive/zfs-%{version}-%{_rc}/%{pname}-%{version}-%{_rc}.tar.gz
540b3d9e 43# Source0-md5: 9630df590251ad13a347b10fd46c0922
0b82b0f8
JR
44Patch0: x32.patch
45Patch1: am.patch
280c4fca 46Patch2: highmem.patch
e3c62688 47Patch3: zfs-sh.patch
bff0a8a1
JB
48URL: http://zfsonlinux.org/
49BuildRequires: autoconf >= 2.50
50BuildRequires: automake
51BuildRequires: libtool
0b82b0f8 52BuildRequires: rpmbuild(macros) >= 1.714
2d67b9de
JR
53%if %{with kernel}
54%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
2d67b9de 55%endif
bff0a8a1 56%if %{with userspace}
e3c62688
JB
57# only for mmap_libaio test command
58#BuildRequires: libaio-devel
bff0a8a1
JB
59BuildRequires: libblkid-devel
60BuildRequires: libselinux-devel
e3c62688
JB
61# if xdr gets removed from glibc
62#BuildRequires: libtirpc-devel
bff0a8a1 63BuildRequires: libuuid-devel
e3c62688
JB
64BuildRequires: openssl-devel
65BuildRequires: pkgconfig
66BuildRequires: udev-devel
bff0a8a1 67BuildRequires: zlib-devel
6f114c88 68%if %{with python2}
e3c62688
JB
69BuildRequires: python-cffi
70BuildRequires: python-modules >= 1:2.6
0b82b0f8
JR
71BuildRequires: python-setuptools
72%endif
6f114c88 73%if %{with python3}
e3c62688
JB
74BuildRequires: python3-cffi
75BuildRequires: python3-modules >= 1:3.4
6f114c88
JR
76BuildRequires: python3-setuptools
77%endif
56fca1f9
JB
78%if %{with python2} || %{with python3}
79BuildRequires: rpm-pythonprov
80%endif
bff0a8a1
JB
81%endif
82Requires: %{pname}-libs = %{version}-%{release}
0b82b0f8 83Obsoletes: spl < 0.7.9-2
bff0a8a1
JB
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
8fa57ce6
JP
86%define dracutlibdir %{_prefix}/lib/dracut
87
bff0a8a1
JB
88%description
89ZFS is an advanced file system and volume manager which was originally
90developed for Solaris and is now maintained by the Illumos community.
91
92ZFS on Linux, which is also known as ZoL, is currently feature
93complete. It includes fully functional and stable SPA, DMU, ZVOL, and
94ZPL layers.
95
96%description -l pl.UTF-8
97ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
98stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
99
100ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
101pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
102SPA, DMU, ZVOL i ZPL.
103
104%package libs
105Summary: ZFS on Linux libraries
106Summary(pl.UTF-8): Biblioteki ZFS-a dla Linuksa
107License: CDDL
108Group: Libraries
8fa57ce6 109Requires(post,postun): /sbin/ldconfig
bff0a8a1
JB
110
111%description libs
112ZFS on Linux libraries.
113
114%description libs -l pl.UTF-8
115Biblioteki ZFS-a dla Linuksa.
116
117%package devel
118Summary: Header files for ZFS libraries
119Summary(pl.UTF-8): Pliki nagłówkowe bibliotek ZFS-a
120License: CDDL
121Group: Development/Libraries
122Requires: %{pname}-libs = %{version}-%{release}
123Requires: libselinux-devel
124Requires: libuuid-devel
125Requires: zlib-devel
126
127%description devel
128Header files for ZFS libraries.
129
130%description devel -l pl.UTF-8
131Pliki nagłówkowe bibliotek ZFS-a.
132
133%package static
134Summary: Static ZFS libraries
135Summary(pl.UTF-8): Statyczne biblioteki ZFS-a
136License: CDDL
137Group: Development/Libraries
138Requires: %{pname}-devel = %{version}-%{release}
139
140%description static
141Static ZFS libraries.
142
143%description static -l pl.UTF-8
144Statyczne biblioteki ZFS-a.
145
146%package -n dracut-zfs
147Summary: ZFS support for Dracut
148Summary(pl.UTF-8): Obsługa ZFS-a dla Dracuta
149Group: Applications/System
150Requires: %{pname} = %{version}-%{release}
151Requires: dracut
152
153%description -n dracut-zfs
154ZFS support for Dracut.
155
156%description -n dracut-zfs -l pl.UTF-8
157Obsługa ZFS-a dla Dracuta.
158
0b82b0f8 159%package -n python-pyzfs
56fca1f9
JB
160Summary: Python 2 wrapper for libzfs_core C library
161Summary(pl.UTF-8): Interfejs Pythona 2 do biblioteki C libzfs_core
0b82b0f8
JR
162License: Apache v2.0
163Group: Libraries/Python
164Requires: %{pname}-libs = %{version}-%{release}
165
166%description -n python-pyzfs
56fca1f9
JB
167Python 2 wrapper for libzfs_core C library.
168
169%description -n python-pyzfs -l pl.UTF-8
170Interfejs Pythona 2 do biblioteki C libzfs_core.
0b82b0f8 171
6f114c88 172%package -n python3-pyzfs
56fca1f9
JB
173Summary: Python 3 wrapper for libzfs_core C library
174Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki C libzfs_core
6f114c88
JR
175License: Apache v2.0
176Group: Libraries/Python
177Requires: %{pname}-libs = %{version}-%{release}
178
179%description -n python3-pyzfs
56fca1f9
JB
180Python 3 wrapper for libzfs_core C library.
181
182%description -n python3-pyzfs -l pl.UTF-8
183Interfejs Pythona 3 do biblioteki C libzfs_core.
6f114c88 184
3921af7f 185%package -n kernel-zfs-common-devel
bff0a8a1
JB
186Summary: ZFS Linux kernel headers
187Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa
bff0a8a1 188Group: Development/Building
0b82b0f8 189Obsoletes: kernel-spl-common-devel < 0.7.9-2
bff0a8a1 190
3921af7f
JR
191%description -n kernel-zfs-common-devel
192ZFS Linux kernel headers common for all PLD kernel versions.
193
194%description -n kernel-zfs-common-devel -l pl.UTF-8
195ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
196wersji jąder PLD.
197
198%define kernel_pkg()\
199%package -n kernel%{_alt_kernel}-zfs\
200Summary: ZFS Linux kernel modules\
201Summary(pl.UTF-8): ZFS - moduły jądra Linuksa\
202Release: %{rel}@%{_kernel_ver_str}\
203Group: Base/Kernel\
204Requires(post,postun): /sbin/depmod\
3921af7f
JR
205%requires_releq_kernel\
206Requires(postun): %releq_kernel\
3921af7f
JR
207\
208%description -n kernel%{_alt_kernel}-zfs\
209ZFS Linux kernel modules.\
210\
211%description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
212ZFS - moduły jądra Linuksa.\
213\
214%package -n kernel%{_alt_kernel}-zfs-devel\
215Summary: ZFS Linux kernel headers\
216Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa\
217Release: %{rel}@%{_kernel_ver_str}\
218Group: Development/Building\
3921af7f
JR
219Requires: kernel%{_alt_kernel}-headers\
220Requires: kernel-zfs-common-devel\
0b82b0f8 221Obsoletes: kernel-spl-devel < 0.7.9-2\
3921af7f
JR
222\
223%description -n kernel%{_alt_kernel}-zfs-devel\
224ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
225version %{_kernel_ver}.\
226\
227%description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
228ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
229pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
230\
231%files -n kernel%{_alt_kernel}-zfs\
232%defattr(644,root,root,755)\
0b82b0f8
JR
233%dir /lib/modules/%{_kernel_ver}/misc/lua\
234/lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
3921af7f
JR
235%dir /lib/modules/%{_kernel_ver}/misc/avl\
236/lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
67ee122d
JR
237%dir /lib/modules/%{_kernel_ver}/misc/icp\
238/lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
3921af7f
JR
239%dir /lib/modules/%{_kernel_ver}/misc/nvpair\
240/lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
0b82b0f8
JR
241%dir /lib/modules/%{_kernel_ver}/misc/spl\
242/lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
3921af7f
JR
243%dir /lib/modules/%{_kernel_ver}/misc/unicode\
244/lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
245%dir /lib/modules/%{_kernel_ver}/misc/zcommon\
246/lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
247%dir /lib/modules/%{_kernel_ver}/misc/zfs\
248/lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
3921af7f
JR
249\
250%files -n kernel%{_alt_kernel}-zfs-devel\
251%defattr(644,root,root,755)\
252/usr/src/zfs-%{version}/%{_kernel_ver}\
253\
254%post -n kernel%{_alt_kernel}-zfs\
255%depmod %{_kernel_ver}\
256\
257%postun -n kernel%{_alt_kernel}-zfs\
258%depmod %{_kernel_ver}\
259%{nil}
260
261%define build_kernel_pkg()\
262%configure \\\
263 --disable-silent-rules \\\
264 --with-config="kernel" \\\
f2042a9c
JR
265 --with-linux=%{_kernelsrcdir}\\\
266 --with-linux-obj=%{_kernelsrcdir}\
3921af7f
JR
267\
268%{__make} clean\
269%{__make} %{?with_verbose:V=1}\
270p=`pwd`\
271%{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
272%{nil}
273
2d67b9de 274%{?with_kernel:%{expand:%create_kernel_packages}}
bff0a8a1
JB
275
276%prep
6a410e14 277%setup -q -n %{pname}-zfs-%{version}-%{_rc}
bff0a8a1 278%patch0 -p1
97d46215 279%patch1 -p1
280c4fca 280%patch2 -p1
e3c62688 281%patch3 -p1
bff0a8a1
JB
282
283%build
284%{__libtoolize}
285%{__aclocal} -I config
286%{__autoconf}
287%{__autoheader}
288%{__automake}
2d67b9de 289%{?with_kernel:%{expand:%build_kernel_packages}}
3921af7f
JR
290
291%if %{with userspace}
bff0a8a1
JB
292%configure \
293 --disable-silent-rules \
3921af7f 294 --with-config="user" \
bff0a8a1 295 --with-linux=%{_kernelsrcdir} \
ec61a23e
JB
296 --with-systemdunitdir=%{systemdunitdir} \
297 --with-systemdpresetdir=/etc/systemd/system-preset \
eb047319
JR
298 --with-systemdmodulesloaddir=/etc/modules-load.d \
299 --with-systemdgeneratordir=/lib/systemd/system-generators \
bff0a8a1
JB
300 --with-udevdir=/lib/udev
301
302%{__make} \
303 %{?with_verbose:V=1}
0b82b0f8 304
6f114c88
JR
305%if %{with python2}
306cd contrib/pyzfs
307%py_build
308cd ../..
309%endif
310
311%if %{with python3}
0b82b0f8 312cd contrib/pyzfs
6f114c88 313%py3_build
0b82b0f8
JR
314cd ../..
315%endif
3921af7f 316%endif
bff0a8a1
JB
317
318%install
319rm -rf $RPM_BUILD_ROOT
320
3921af7f
JR
321%if %{with kernel}
322install -d $RPM_BUILD_ROOT
323cp -a installed/* $RPM_BUILD_ROOT
cd1ae8a3 324# Drop unneeded spl compat links
3a7a22e4 325%{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
3921af7f
JR
326%endif
327
328%if %{with userspace}
bff0a8a1
JB
329%{__make} install \
330 DESTDIR=$RPM_BUILD_ROOT \
3921af7f 331 DEFAULT_INIT_DIR=/etc/rc.d/init.d
58d00fd6 332
6f114c88 333%if %{with python2}
0b82b0f8
JR
334%{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
335cd contrib/pyzfs
336%py_install
337
338%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
339%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
340
341%py_postclean
342cd ../..
343%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
344%endif
345
6f114c88
JR
346%if %{with python3}
347%{__rm} -rf $RPM_BUILD_ROOT{%{py3_sitescriptdir},/usr/local/share/python3*}
348cd contrib/pyzfs
349%py3_install
350cd ../..
351%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
352%endif
353
58d00fd6
JR
354install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
355%{__mv} $RPM_BUILD_ROOT%{_npkgconfigdir}/* $RPM_BUILD_ROOT%{_pkgconfigdir}
5bf6436c 356
0b82b0f8
JR
357# Debian specific stuff
358%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
359
5bf6436c
JR
360# Package these? These are integration tests of the implementation.
361%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
362%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
363%{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
3921af7f 364%endif
bff0a8a1
JB
365
366%clean
367rm -rf $RPM_BUILD_ROOT
368
8fa57ce6
JP
369%post libs -p /sbin/ldconfig
370%postun libs -p /sbin/ldconfig
371
bff0a8a1
JB
372%if %{with userspace}
373%files
374%defattr(644,root,root,755)
e3c62688 375%doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
bff0a8a1 376%attr(755,root,root) /sbin/mount.zfs
6f114c88
JR
377%attr(755,root,root) %{_bindir}/arc_summary
378%attr(755,root,root) %{_bindir}/arcstat
379%attr(755,root,root) %{_bindir}/dbufstat
5bf6436c 380%attr(755,root,root) %{_bindir}/zgenhostid
bff0a8a1
JB
381%attr(755,root,root) %{_sbindir}/fsck.zfs
382%attr(755,root,root) %{_sbindir}/zdb
ec61a23e 383%attr(755,root,root) %{_sbindir}/zed
bff0a8a1
JB
384%attr(755,root,root) %{_sbindir}/zfs
385%attr(755,root,root) %{_sbindir}/zhack
386%attr(755,root,root) %{_sbindir}/zinject
bff0a8a1
JB
387%attr(755,root,root) %{_sbindir}/zpool
388%attr(755,root,root) %{_sbindir}/zstreamdump
389%attr(755,root,root) %{_sbindir}/ztest
390%dir %{_sysconfdir}/zfs
391# package *.example as %doc? (they cannot act as default configuration)
392%{_sysconfdir}/zfs/vdev_id.conf.*.example
ec61a23e
JB
393%dir %{_sysconfdir}/zfs/zed.d
394%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
395%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
5bf6436c
JR
396%dir %{_sysconfdir}/zfs/zpool.d
397%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
58d00fd6
JR
398%attr(754,root,root) /etc/rc.d/init.d/zfs-import
399%attr(754,root,root) /etc/rc.d/init.d/zfs-mount
400%attr(754,root,root) /etc/rc.d/init.d/zfs-share
401%attr(754,root,root) /etc/rc.d/init.d/zfs-zed
402%config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
403/etc/zfs/zfs-functions
e8614c59 404%config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
ec61a23e 405/etc/systemd/system-preset/50-zfs.preset
eb047319 406/lib/systemd/system-generators/zfs-mount-generator
ec61a23e 407%{systemdunitdir}/zfs.target
2e642361 408%{systemdunitdir}/zfs-import.target
ec61a23e
JB
409%{systemdunitdir}/zfs-import-cache.service
410%{systemdunitdir}/zfs-import-scan.service
411%{systemdunitdir}/zfs-mount.service
412%{systemdunitdir}/zfs-share.service
97dbbf93 413%{systemdunitdir}/zfs-zed.service
bff0a8a1
JB
414%attr(755,root,root) /lib/udev/vdev_id
415%attr(755,root,root) /lib/udev/zvol_id
416/lib/udev/rules.d/60-zvol.rules
417/lib/udev/rules.d/69-vdev.rules
418/lib/udev/rules.d/90-zfs.rules
2e642361
JR
419%dir %{_libexecdir}/zfs
420%dir %{_libexecdir}/zfs/zed.d
421%attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
422%dir %{_libexecdir}/zfs/zpool.d
423%attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
bff0a8a1
JB
424%dir %{_datadir}/zfs
425%attr(755,root,root) %{_datadir}/zfs/*.sh
bff0a8a1 426%{_mandir}/man1/zhack.1*
bff0a8a1 427%{_mandir}/man1/ztest.1*
0b82b0f8 428%{_mandir}/man5/spl-module-parameters.5*
bff0a8a1 429%{_mandir}/man5/vdev_id.conf.5*
58d00fd6 430%{_mandir}/man5/zfs-events.5*
ec61a23e 431%{_mandir}/man5/zfs-module-parameters.5*
bff0a8a1
JB
432%{_mandir}/man5/zpool-features.5*
433%{_mandir}/man8/fsck.zfs.8*
434%{_mandir}/man8/mount.zfs.8*
435%{_mandir}/man8/vdev_id.8*
436%{_mandir}/man8/zdb.8*
ec61a23e 437%{_mandir}/man8/zed.8*
bff0a8a1 438%{_mandir}/man8/zfs.8*
0b82b0f8
JR
439%{_mandir}/man8/zfs-mount-generator.8*
440%{_mandir}/man8/zfs-program.8*
5bf6436c 441%{_mandir}/man8/zgenhostid.8*
bff0a8a1
JB
442%{_mandir}/man8/zinject.8*
443%{_mandir}/man8/zpool.8*
444%{_mandir}/man8/zstreamdump.8*
445
446%files libs
447%defattr(644,root,root,755)
448%attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
449%attr(755,root,root) %ghost %{_libdir}/libnvpair.so.1
450%attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
451%attr(755,root,root) %ghost %{_libdir}/libuutil.so.1
452%attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
ec61a23e
JB
453%attr(755,root,root) %ghost %{_libdir}/libzfs.so.2
454%attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
455%attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.1
bff0a8a1 456%attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
ec61a23e 457%attr(755,root,root) %ghost %{_libdir}/libzpool.so.2
bff0a8a1
JB
458
459%files devel
460%defattr(644,root,root,755)
461%attr(755,root,root) %{_libdir}/libnvpair.so
462%attr(755,root,root) %{_libdir}/libuutil.so
463%attr(755,root,root) %{_libdir}/libzfs.so
ec61a23e 464%attr(755,root,root) %{_libdir}/libzfs_core.so
bff0a8a1
JB
465%attr(755,root,root) %{_libdir}/libzpool.so
466%{_libdir}/libnvpair.la
467%{_libdir}/libuutil.la
468%{_libdir}/libzfs.la
ec61a23e 469%{_libdir}/libzfs_core.la
bff0a8a1
JB
470%{_libdir}/libzpool.la
471%{_includedir}/libspl
472%{_includedir}/libzfs
58d00fd6
JR
473%{_pkgconfigdir}/libzfs.pc
474%{_pkgconfigdir}/libzfs_core.pc
bff0a8a1
JB
475
476%files static
477%defattr(644,root,root,755)
478%{_libdir}/libnvpair.a
479%{_libdir}/libuutil.a
480%{_libdir}/libzfs.a
ec61a23e 481%{_libdir}/libzfs_core.a
bff0a8a1
JB
482%{_libdir}/libzpool.a
483
484%files -n dracut-zfs
485%defattr(644,root,root,755)
58d00fd6 486%doc contrib/dracut/README.dracut.markdown
5bf6436c
JR
487%dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
488%attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
8fa57ce6 489%dir %{dracutlibdir}/modules.d/90zfs
58d00fd6 490%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
8fa57ce6
JP
491%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
492%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
493%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
540b3d9e 494%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
5bf6436c 495%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
58d00fd6 496%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
0b82b0f8 497%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
5bf6436c 498%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
0b82b0f8 499
6f114c88 500%if %{with python2}
0b82b0f8
JR
501%files -n python-pyzfs
502%defattr(644,root,root,755)
503%doc contrib/pyzfs/README
504%{py_sitescriptdir}/libzfs_core
505%{py_sitescriptdir}/pyzfs-*-py*.egg-info
506%endif
6f114c88
JR
507
508%if %{with python3}
509%files -n python3-pyzfs
510%defattr(644,root,root,755)
511%doc contrib/pyzfs/README
512%{py3_sitescriptdir}/libzfs_core
513%{py3_sitescriptdir}/pyzfs-*-py*.egg-info
514%endif
bff0a8a1
JB
515%endif
516
517%if %{with kernel}
3921af7f 518%files -n kernel-zfs-common-devel
bff0a8a1 519%defattr(644,root,root,755)
e11b2ec8 520%dir /usr/src/zfs-%{version}
3921af7f 521/usr/src/zfs-%{version}/include
0b82b0f8
JR
522/usr/src/zfs-%{version}/zfs.release
523/usr/src/zfs-%{version}/zfs_config.h
bff0a8a1 524%endif
This page took 0.162501 seconds and 4 git commands to generate.