]> git.pld-linux.org Git - packages/yarn.git/blame - yarn.spec
up to 0.23.2
[packages/yarn.git] / yarn.spec
CommitLineData
b3fffc6d
ER
1Summary: Fast, reliable, and secure node dependency management"
2Name: yarn
48ff7003 3Version: 0.23.2
b3fffc6d
ER
4Release: 1
5License: BSD
6Group: Development/Tools
7Source0: https://github.com/yarnpkg/yarn/releases/download/v%{version}/%{name}-v%{version}.tar.gz
48ff7003 8# Source0-md5: 8c40f98256c9f14234e6afb04af910b0
b3fffc6d
ER
9URL: https://yarnpkg.com/
10BuildRequires: rpmbuild(macros) >= 1.634
11BuildRequires: sed >= 4.0
12Requires: nodejs >= 4.0
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Fast, reliable, and secure dependency management. Yarn: Fast,
18reliable, and secure dependency management.
19
20Fast: Yarn caches every package it downloads so it never needs to
21again. It also parallelizes operations to maximize resource
22utilization so install times are faster than ever.
23
24Reliable: Using a detailed, but concise, lockfile format, and a
25deterministic algorithm for installs, Yarn is able to guarantee that
26an install that worked on one system will work exactly the same way on
27any other system.
28
29Secure: Yarn uses checksums to verify the integrity of every installed
30package before its code is executed.
31
32%prep
33%setup -qc
34mv dist/* .
35
36%{__rm} bin/node-gyp-bin/node-gyp.cmd
37%{__rm} bin/yarn.cmd
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT{%{nodejs_libdir}/%{name},%{_bindir}}
42
43cp -a lib lib-legacy bin node_modules package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{name}
44ln -s %{nodejs_libdir}/%{name}/bin/%{name}.js $RPM_BUILD_ROOT%{_bindir}/%{name}
45ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/yarnpkg
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
52%doc README.md LICENSE
53%attr(755,root,root) %{_bindir}/yarn
54%attr(755,root,root) %{_bindir}/yarnpkg
55%defattr(-,root,root,-)
56%{nodejs_libdir}/%{name}
This page took 0.066685 seconds and 4 git commands to generate.