]> git.pld-linux.org Git - packages/xz.git/blame - xz.spec
- tabs in preamble
[packages/xz.git] / xz.spec
CommitLineData
82d22baf 1Summary: LZMA Encoder/Decoder
34fad00c 2Summary(pl.UTF-8): Koder/Dekoder LZMA
82d22baf 3Name: lzma
1e6080d5 4Version: 4.43
997fc3c1 5Release: 5
d952e0bf 6License: CPL/LGPL
82d22baf 7Group: Applications/Archiving
1e6080d5
JB
8Source0: http://dl.sourceforge.net/sevenzip/%{name}443.tar.bz2
9# Source0-md5: c4e1b467184c7cffd4371c74df2baf0f
82d22baf 10Patch0: %{name}-quiet.patch
90fc2073 11Patch1: %{name}427_zlib.patch
1010510a 12Patch2: %{name}-shared.patch
08ce92c0 13Patch3: %{name}-lzmalib.patch
82d22baf 14URL: http://www.7-zip.org/sdk.html
a2b5ff78 15BuildRequires: gcc >= 5:3.4.0
6e34e97f 16BuildRequires: libstdc++-devel
1010510a 17# does not need -libs, due apps being not linked with shared lib
82d22baf 18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21LZMA is default and general compression method of 7z format in 7-Zip
22program. LZMA provides high compression ratio and very fast
23decompression, so it is very suitable for embedded applications. For
24example, it can be used for ROM (firmware) compressing.
25
26LZMA features:
27
28- Compressing speed: 500 KB/s on 1 GHz CPU
29- Decompressing speed:
30 - 8-12 MB/s on 1 GHz Intel Pentium 3 or AMD Athlon.
31 - 500-1000 KB/s on 100 MHz ARM, MIPS, PowerPC or other simple RISC
32 CPU.
2f88d337 33- Small memory requirements for decompressing: 8-32 KB + dictionary
34 size
82d22baf 35- Small code size for decompressing: 2-8 KB (depending from speed
36 optimizations)
37
fb275d27
JR
38%description -l pl.UTF-8
39LZMA jest domyślnym i ogólnym algorytmem kompresji formatu 7z
40stosowanego przez 7-Zip. LZMA zapewnia wysoki stopień kompresji i
41bardzo szybką dekompresję, więc nadaje się do zastosowań osadzonych.
42Przykładowo, może być użyty do kompresji ROM-u (firmware'u).
82d22baf 43
44Cechy LZMA:
45
fb275d27
JR
46- Szybkość kompresowania: 500 KB/s na 1 GHz procesorze,
47- Szybkość dekompresowania:
82d22baf 48 - 8-12 MB/s na 1 GHz Pentium 3 lub Athlonie,
49 - 500-1000 KB/s na 100 MHz procesorach ARM, MIPS, PowerPC lub innych
50 prostych RISC-ach,
fb275d27
JR
51- Mała ilość pamięci potrzebna do dekompresowania: 8-32 KB + rozmiar
52 słownika,
53- Mały rozmiar kodu dekompresującego: 2-8 KB (w zależności od opcji
82d22baf 54 optymalizacji).
55
1010510a
ER
56%package libs
57Summary: LZMA shared library
34fad00c 58Summary(pl.UTF-8): Biblioteka współdzielona LZMA
1010510a
ER
59Group: Libraries
60
61%description libs
84d12552
JB
62LZMA shared library.
63
fb275d27
JR
64%description libs -l pl.UTF-8
65Biblioteka współdzielona LZMA.
1010510a 66
90fc2073 67%package devel
84d12552 68Summary: Header file for LZMA library
34fad00c 69Summary(pl.UTF-8): Plik nagłówkowy biblioteki LZMA
d9b6428a 70Group: Development/Libraries
1010510a 71Requires: %{name}-libs = %{version}-%{release}
90fc2073 72
73%description devel
84d12552 74Header file for LZMA library.
6e34e97f 75
fb275d27
JR
76%description devel -l pl.UTF-8
77Plik nagłówkowy biblioteki LZMA.
90fc2073 78
1010510a
ER
79%package static
80Summary: LZMA static library
34fad00c 81Summary(pl.UTF-8): Biblioteka statyczna LZMA
1010510a 82Group: Development/Libraries
5d8a866c 83Requires: %{name}-devel = %{version}-%{release}
1010510a
ER
84
85%description static
84d12552
JB
86LZMA static library.
87
fb275d27 88%description static -l pl.UTF-8
84d12552 89Biblioteka statyczna LZMA.
1010510a 90
82d22baf 91%prep
92%setup -q -c
93%patch0 -p1
90fc2073 94%patch1 -p1
1010510a 95%patch2 -p1
08ce92c0 96%patch3 -p1
82d22baf 97
98%build
33d5a1b3 99cd C/7zip/Compress/LZMA_Alone
058a27e7 100%{__make} -f makefile.gcc \
82d22baf 101 CXX="%{__cxx}" \
058a27e7 102 CXX_C="%{__cc}" \
c0e0358d 103 CFLAGS="%{rpmcflags} -fprofile-generate -c -I ../../.." \
9c0de09c 104 LDFLAGS="%{rpmldflags} -fprofile-generate" \
d160d0a9 105 LIB="-lm -lgcov"
a2b5ff78 106
107cat ../LZMA/* > test1
108cat lzma *.o > test2
9c0de09c 109tar cf test3 ../../../../*
110./lzma e test1 test4
111./lzma e test2 test5
112./lzma e test3 test6
113./lzma d test4 test7
114./lzma d test5 test8
115./lzma d test6 test9
116cmp test1 test7
117cmp test2 test8
118cmp test3 test9
a2b5ff78 119
708ea2b6 120%{__make} -f makefile.gcc clean
a2b5ff78 121
708ea2b6 122%{__make} -f makefile.gcc \
a2b5ff78 123 CXX="%{__cxx}" \
708ea2b6 124 CXX_C="%{__cc}" \
c0e0358d 125 CFLAGS="%{rpmcflags} -fprofile-use -c -I ../../.." \
d160d0a9 126 LDFLAGS="%{rpmldflags}"
82d22baf 127
90fc2073 128cd ../LZMA_Lib
708ea2b6 129%{__make} -f makefile \
130 CXX="%{__cxx}" \
7fe3b687 131 CFLAGS="%{rpmcflags} -c -fpic"
90fc2073 132
82d22baf 133%install
134rm -rf $RPM_BUILD_ROOT
08ce92c0 135install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
82d22baf 136
33d5a1b3 137install C/7zip/Compress/LZMA_Alone/lzma $RPM_BUILD_ROOT%{_bindir}
997fc3c1 138install C/7zip/Compress/LZMA_Lib/lzmalib.h $RPM_BUILD_ROOT%{_includedir}
33d5a1b3 139install C/7zip/Compress/LZMA_Lib/liblzma.a $RPM_BUILD_ROOT%{_libdir}
1010510a
ER
140install C/7zip/Compress/LZMA_Lib/liblzma.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
141ln -s $(cd C/7zip/Compress/LZMA_Lib; echo liblzma.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/liblzma.so
82d22baf 142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
1010510a
ER
146%post libs -p /sbin/ldconfig
147%postun libs -p /sbin/ldconfig
148
82d22baf 149%files
150%defattr(644,root,root,755)
151%doc history.txt lzma.txt
152%attr(755,root,root) %{_bindir}/*
90fc2073 153
1010510a
ER
154%files libs
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_libdir}/liblzma.so.*.*
157
90fc2073 158%files devel
159%defattr(644,root,root,755)
84d12552 160%attr(755,root,root) %{_libdir}/liblzma.so
08ce92c0 161%{_includedir}/lzmalib.h
1010510a
ER
162
163%files static
164%defattr(644,root,root,755)
90fc2073 165%{_libdir}/liblzma.a
This page took 0.049444 seconds and 4 git commands to generate.