]> git.pld-linux.org Git - packages/xmonad.git/blame - xmonad.spec
- new
[packages/xmonad.git] / xmonad.spec
CommitLineData
95aecafe
JP
1Summary: Tiling window manager
2Name: xmonad
3Version: 0.11
4Release: 0.1
5License: BSD
6Group: X11/Window Managers
7Source0: http://hackage.haskell.org/packages/archive/%{name}/%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: 5ac9dc1dae5e85dcbdfb9f70cbe312c1
9Source1: %{name}.desktop
10URL: http://www.xmonad.org
11BuildRequires: ghc >= 6.12.3
12BuildRequires: ghc-mtl
13BuildRequires: ghc-unix
14BuildRequires: ghc-utf8-string
15BuildRequires: ghc-X11 >= 1.6
16BuildRequires: rpmbuild(macros) >= 1.608
17%requires_eq ghc
18Requires: ghc-mtl
19Requires: ghc-unix
20Requires: ghc-utf8-string
21Requires: ghc-X11 >= 1.6
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24# debuginfo is not useful for ghc
25%define _enable_debug_packages 0
26%define _xdeskdir %{_datadir}/xsessions
27
28%description
29xmonad is a tiling window manager for X. Windows are arranged
30automatically to tile the screen without gaps or overlap, maximising
31screen use. All features of the window manager are accessible from the
32keyboard: a mouse is strictly optional. xmonad is written and
33extensible in Haskell. Custom layout algorithms, and other extensions,
34may be written by the user in config files. Layouts are applied
35dynamically, and different layouts may be used on each workspace.
36Xinerama is fully supported, allowing windows to be tiled on several
37screens.
38
39%package doc
40Summary: HTML documentation for %{name}
41Summary(pl.UTF-8): Dokumentacja w formacie HTML dla %{name}
42Group: Documentation
43
44%description doc
45HTML documentation for %{name}.
46
47%description doc -l pl.UTF-8
48Dokumentacja w formacie HTML dla %{name}.
49
50%prep
51%setup -q
52
53%build
54runhaskell Setup.lhs configure -v2 \
55 --prefix=%{_prefix} \
56 --libdir=%{_libdir} \
57 --libexecdir=%{_libexecdir} \
58 --docdir=%{_docdir}/%{name}-%{version}
59
60runhaskell Setup.lhs build
61runhaskell Setup.lhs haddock --executables
62
63%install
64rm -rf $RPM_BUILD_ROOT
65install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
66
67runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
68
69install -d $RPM_BUILD_ROOT{%{_deskdir},%{_xdeskdir}}
70install %{SOURCE1} $RPM_BUILD_ROOT%{_xdeskdir}/%{name}.desktop
71
72# work around automatic haddock docs installation
73rm -rf %{name}-%{version}-doc
74cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
75%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
76
77%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}/man
78%{__rmdir} $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}
79install -d $RPM_BUILD_ROOT%{_mandir}/man1
80install man/xmonad.1 $RPM_BUILD_ROOT%{_mandir}/man1
81
82runhaskell Setup.lhs register \
83 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{name}.conf
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post
89%ghc_pkg_recache
90
91%postun
92%ghc_pkg_recache
93
94%files
95%defattr(644,root,root,755)
96%doc man/xmonad.hs
97%attr(755,root,root) %{_bindir}/xmonad
98%{_libdir}/%{ghcdir}/package.conf.d/%{name}.conf
99%{_libdir}/%{ghcdir}/%{name}-%{version}
100%{_mandir}/man1/xmonad.1*
101%{_xdeskdir}/%{name}.desktop
102
103%files doc
104%defattr(644,root,root,755)
105%doc %{name}-%{version}-doc/*
This page took 0.091339 seconds and 4 git commands to generate.