]> git.pld-linux.org Git - packages/xapian-bindings.git/blame - xapian-bindings.spec
- based on src.from suse buildfactory
[packages/xapian-bindings.git] / xapian-bindings.spec
CommitLineData
9af7ec76
ER
1# Conditional build:
2%bcond_with csharp # do not build C# bindings
3%bcond_without php # do not build PHP bindings
4%bcond_without python # do not build Python bindings
5%bcond_without ruby # do not build Ruby bindings
6%bcond_without tcl # do not build TCL bindings
7#
8Summary: Bindings for Xapian
9Name: xapian-bindings
10Version: 1.0.4
11Release: 0.1
12License: GPL
13Group: Development/Languages
14URL: http://www.xapian.org/
15Source0: http://www.oligarchy.co.uk/xapian/%{version}/%{name}-%{version}.tar.gz
16# Source0-md5: d572e0bec4c4c26f26224e1253c4aa8f
17# jdk??
18BuildRequires: jdk
19%{?with_csharp:BuildRequires: mono-devel}
20%{?with_php:BuildRequires: php-devel >= 3:5.0.0}
21BuildRequires: pkgconfig
22%{?with_python:BuildRequires: python-devel}
23BuildRequires: rpmbuild(macros) >= 1.344
24%{?with_ruby:BuildRequires: ruby-devel}
25%{?with_tcl:BuildRequires: tcl-devel}
26BuildRequires: xapian-core-devel = %{version}
27Requires: xapian-core-libs = %{version}
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Xapian is an Open Source Probabilistic Information Retrieval Library.
32It offers a highly adaptable toolkit that allows developers to easily
33add advanced indexing and search facilities to applications.
34
35%package -n python-xapian
36Summary: Files needed for developing Python scripts which use Xapian
37Group: Development/Languages/Python
38Requires: %{name} = %{version}-%{release}
39%pyrequires_eq python-modules
40
41%description -n python-xapian
42Xapian is an Open Source Probabilistic Information Retrieval
43framework. It offers a highly adaptable toolkit that allows developers
44to easily add advanced indexing and search facilities to applications.
45This package provides the files needed for developing Python scripts
46which use Xapian.
47
48%package -n php-xapian
49Summary: Files needed for developing PHP scripts which use Xapian
50Group: Networking/Daemons
51Requires: %{name} = %{version}-%{release}
52%{?requires_php_extension}
53Requires: php-common >= 4:5.0.4
54
55%description -n php-xapian
56Xapian is an Open Source Probabilistic Information Retrieval
57framework. It offers a highly adaptable toolkit that allows developers
58to easily add advanced indexing and search facilities to applications.
59This package provides the files needed for developing PHP scripts
60which use Xapian.
61
62%package -n ruby-xapian
63Summary: Files needed for developing Ruby scripts which use Xapian
64Group: Development/Languages
65Requires: %{name} = %{version}-%{release}
66Requires: ruby
67
68%description -n ruby-xapian
69Xapian is an Open Source Probabilistic Information Retrieval
70framework. It offers a highly adaptable toolkit that allows developers
71to easily add advanced indexing and search facilities to applications.
72This package provides the files needed for developing Ruby scripts
73which use Xapian.
74
75%package -n tcl-xapian
76Summary: Files needed for developing TCL scripts which use Xapian
77Group: Development/Languages/Tcl
78Requires: %{name} = %{version}-%{release}
79Requires: tcl
80
81%description -n tcl-xapian
82Xapian is an Open Source Probabilistic Information Retrieval
83framework. It offers a highly adaptable toolkit that allows developers
84to easily add advanced indexing and search facilities to applications.
85This package provides the files needed for developing TCL scripts
86which use Xapian.
87
88%package -n csharp-xapian
89Summary: Files needed for developing C# applications which use Xapian
90Group: Development/Languages
91Requires: %{name} = %{version}-%{release}
92Requires: mono-core
93
94%description -n csharp-xapian
95Xapian is an Open Source Probabilistic Information Retrieval
96framework. It offers a highly adaptable toolkit that allows developers
97to easily add advanced indexing and search facilities to applications.
98This package provides the files needed for developing C# applications
99which use Xapian.
100
101%prep
102%setup -q
103
104%build
105%configure \
106 --with-swig \
107 %{?with_python:--with-python} \
108 %{?with_php:--with-php} \
109 %{?with_ruby:--with-ruby} \
110 %{?with_tcl:--with-tcl} \
111 %{?with_csharp:--with-csharp}
112%{__make}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116%{__make} install \
117 DESTDIR=$RPM_BUILD_ROOT
118
119rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
120
121for binding in %{?with_csharp:csharp} %{?with_php:php} %{?with_python:python} %{?with_ruby:ruby} %{?with_tcl:tcl8}; do
122 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$binding
123 cp -a $binding/docs/{index.html,examples} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$binding
124done
125
126%py_postclean
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%files
132%defattr(644,root,root,755)
133%doc AUTHORS ChangeLog HACKING NEWS README TODO
134%dir %{_examplesdir}/%{name}-%{version}
135
136%if %{with python}
137%files -n python-xapian
138%defattr(644,root,root,755)
139%{py_sitedir}/_xapian.so
140%{py_sitedir}/xapian.py[co]
141%{_examplesdir}/%{name}-%{version}/python
142%endif
143
144%if %{with php}
145%files -n php-xapian
146%defattr(644,root,root,755)
147%{php_extensiondir}/xapian.so
148%{php_data_dir}5/xapian.php
149%{_examplesdir}/%{name}-%{version}/php
150%endif
151
152%if %{with ruby}
153%files -n ruby-xapian
154%defattr(644,root,root,755)
155%attr(755,root,root) %{ruby_sitearchdir}/_xapian.so
156%{ruby_sitelibdir}/xapian.rb
157
158%{_examplesdir}/%{name}-%{version}/ruby
159%endif
160
161%if %{with tcl}
162%files -n tcl-xapian
163%defattr(644,root,root,755)
164%dir %{_libdir}/xapian%{version}
165%{_libdir}/xapian%{version}/pkgIndex.tcl
166%attr(755,root,root) %{_libdir}/xapian%{version}/xapian.so
167%{_examplesdir}/%{name}-%{version}/tcl8
168%endif
169
170%if %{with csharp}
171%files -n csharp-xapian
172%defattr(644,root,root,755)
173%{_libdir}/XapianSharp.la
174%{_libdir}/XapianSharp.so
175%dir %{_libdir}/mono
176%{_libdir}/mono/XapianSharp
177%dir %{_libdir}/mono/gac
178%{_libdir}/mono/gac/XapianSharp
179%{_examplesdir}/%{name}-%{version}/csharp
180%endif
This page took 0.12183 seconds and 4 git commands to generate.