]> git.pld-linux.org Git - packages/wordpress.git/blame - wordpress.spec
- 2.7.1
[packages/wordpress.git] / wordpress.spec
CommitLineData
45cc6939 1# TODO
3ab985b1 2# - put config files to %{_sysconfdir}!
ec33fe30 3Summary: Personal publishing system
fbfe2ed5 4Summary(pl.UTF-8): Osobisty system publikacji
ec33fe30 5Name: wordpress
685b64b8 6Version: 2.7.1
0e2315f3 7Release: 1
ec33fe30 8License: GPL
9Group: Applications/Publishing
0d294a02 10Source0: http://wordpress.org/wordpress-%{version}.tar.gz
685b64b8 11# Source0-md5: 3f1e1607e5ce1328c305e0192ff3352a
54d512d5 12Source1: wp-secure.sh
13Source2: wp-setup.sh
14Source3: wp-setup.txt
20ae9c53 15Source4: %{name}.conf
59d447d5 16Source5: %{name}-lighttpd.conf
e4c00b6d 17Source6: http://kubazwolinski.com/downloads/pl_PL.po
18# Source6-md5: 4ac57f4d9664195abf8fbce2da2fa87d
19Source7: http://kubazwolinski.com/downloads/pl_PL.mo
20# Source7-md5: 99fb334fab82f78c4b8c5cb22360959a
ec33fe30 21URL: http://wordpress.org/
087631da
ER
22Requires: php(gettext)
23Requires: php(mysql)
24Requires: php(pcre)
25Requires: php(xml)
26Requires: php(xmlrpc)
3ab985b1 27Requires: webapps
087631da 28Requires: webserver(php) >= 5.0
edeb68e0 29BuildArch: noarch
ec33fe30 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
3ab985b1
ER
32%define _appdir %{_datadir}/%{name}
33%define _webapps /etc/webapps
34%define _webapp %{name}
35%define _sysconfdir %{_webapps}/%{_webapp}
ec33fe30 36
37%description
38WordPress is a state-of-the-art semantic personal publishing platform
39with a focus on aesthetics, web standards, and usability. WordPress
40was born out of a desire for an elegant, well-architectured personal
41publishing system (also called blog or weblog) built on PHP and MySQL
42and licensed under the GPL. It is the official successor of
43b2/cafelog. WordPress is fresh software, but its roots and development
44go back to 2001.
45
0677b3c7
JR
46%description -l pl.UTF-8
47WordPress jest technologicznie dopracowaną, semantyczną, osobistą
48platformą do publikacji kładącą nacisk na standardy WWW oraz
49użyteczność. WordPress został stworzony w wyniku potrzeby
ec33fe30 50eleganckiego, dobrze zaprojektowanego, osobistego systemu publikacji
0677b3c7
JR
51(nazywanego również blogiem czy weblogiem). Jest to system oparty o
52PHP i MySQL oraz na licencji GPL. Jest oficjalnym następcą b2/cafelog.
53WordPress jest nowym oprogramowaniem, ale jego korzenie i rozwój
54sięgają 2001 roku.
ec33fe30 55
56%prep
57%setup -q -n %{name}
54d512d5 58cp %{SOURCE1} %{SOURCE2} %{SOURCE3} .
3ab985b1 59rm -f license.txt
ec33fe30 60
61%install
62rm -rf $RPM_BUILD_ROOT
f20d6350 63install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_sysconfdir},%{_appdir}/wp-content/languages}
ec33fe30 64
3ab985b1
ER
65cp -R * $RPM_BUILD_ROOT%{_appdir}
66rm -f $RPM_BUILD_ROOT%{_appdir}/readme.html
67rm -f $RPM_BUILD_ROOT%{_appdir}/wp-setup.txt
68ln -sf %{_appdir}/wp-setup.sh $RPM_BUILD_ROOT%{_bindir}/wp-setup
69ln -sf %{_appdir}/wp-secure.sh $RPM_BUILD_ROOT%{_bindir}/wp-secure
4b140d58 70
3ab985b1
ER
71install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
72install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
ca1cad3e 73install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
f20d6350
TP
74install %{SOURCE6} $RPM_BUILD_ROOT%{_appdir}/wp-content/languages/pl_PL.po
75install %{SOURCE7} $RPM_BUILD_ROOT%{_appdir}/wp-content/languages/pl_PL.mo
20ae9c53 76
edeb68e0
JB
77%clean
78rm -rf $RPM_BUILD_ROOT
79
ec33fe30 80%post
3ab985b1 81if [ ! -f %{_appdir}/wp-config.php ]; then
59d447d5 82 install -oroot -ghttp -m640 %{_appdir}/wp-config-sample.php %{_appdir}/wp-config.php
3ab985b1
ER
83
84 %banner -e %{name} <<-EOF
85 To finish your configuration DO NOT FORGET to:
86
87 1) Create some MySQL database owned by some user
88 2) Edit the file: %{_appdir}/wp-config.php
89 3) Run a browser and visit: http://`hostname`/wordpress/wp-admin/install.php
90EOF
20ae9c53 91fi
3ab985b1 92
b973cc00 93%triggerin -- apache1 < 1.3.37-3, apache1-base
3ab985b1
ER
94%webapp_register apache %{_webapp}
95
ca1cad3e
RT
96%triggerin -- lighttpd
97%webapp_register lighttpd %{_webapp}
98
b973cc00 99%triggerun -- apache1 < 1.3.37-3, apache1-base
3ab985b1
ER
100%webapp_unregister apache %{_webapp}
101
cda44e30 102%triggerin -- apache < 2.2.0, apache-base
3ab985b1
ER
103%webapp_register httpd %{_webapp}
104
cda44e30 105%triggerun -- apache < 2.2.0, apache-base
3ab985b1
ER
106%webapp_unregister httpd %{_webapp}
107
ca1cad3e
RT
108%triggerun -- lighttpd
109%webapp_unregister lighttpd %{_webapp}
110
ec33fe30 111%files
843f1ee3 112%defattr(644,root,root,755)
113%doc readme.html wp-setup.txt
3ab985b1
ER
114%dir %attr(750,root,http) %{_sysconfdir}
115%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
116%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
ca1cad3e 117%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
3ab985b1
ER
118
119%dir %{_appdir}
120%dir %attr(750,root,http) %{_appdir}/wp-content
121%dir %attr(750,root,http) %{_appdir}/wp-content/plugins
122%dir %attr(750,root,http) %{_appdir}/wp-content/themes
123%dir %attr(750,root,http) %{_appdir}/wp-content/themes/classic
124%dir %attr(750,root,http) %{_appdir}/wp-content/themes/default
75e54d88 125%dir %attr(750,root,http) %{_appdir}/wp-content/themes/default/images
3ab985b1 126%attr(640,root,http) %{_appdir}/wp-content/plugins/*.php
df73685e 127%attr(640,root,http) %{_appdir}/wp-content/plugins/akismet
3ab985b1
ER
128%attr(640,root,http) %{_appdir}/wp-content/themes/classic/*
129%attr(640,root,http) %{_appdir}/wp-content/themes/default/*.php
130%attr(640,root,http) %{_appdir}/wp-content/themes/default/*.css
131%attr(640,root,http) %{_appdir}/wp-content/themes/default/images/*
ca1cad3e 132%{_appdir}/wp-content/index.php
f20d6350 133%{_appdir}/wp-content/languages
ca1cad3e 134%{_appdir}/wp-content/themes/default/screenshot.png
3ab985b1 135%{_appdir}/wp-admin
3ab985b1
ER
136%{_appdir}/wp-includes
137%{_appdir}/*.php
138%{_appdir}/wp-secure.sh
139%{_appdir}/wp-setup.sh
022de391 140%attr(755,root,root) %{_bindir}/wp-secure
141%attr(755,root,root) %{_bindir}/wp-setup
This page took 0.192068 seconds and 4 git commands to generate.