]> git.pld-linux.org Git - projects/template-specs.git/blame - webapp.spec
updated
[projects/template-specs.git] / webapp.spec
CommitLineData
ff60f2d3 1Summary: Package that uses webapps configuration
ce39d734 2Summary(pl.UTF-8): Pakiet używający konfiguracji aplikacji WWW
ff60f2d3 3Name: template-webapp
0c6969fd 4Version: 0.3
7f007c8b 5Release: 0.3
5ba5cc7a 6License: GPL
1b5d0c9a 7Group: Applications/WWW
1ddef0d1
ER
8#Source0: %{name}-%{version}.tar.gz
9# Source0-md5: -
51422de5
ER
10Source1: apache.conf
11Source2: lighttpd.conf
1ddef0d1 12#URL: -
b53f8131 13BuildRequires: rpmbuild(macros) >= 1.268
ff60f2d3 14Requires: webapps
bc8ecf1d 15# see packages/webapps/webapps.README for description and complete listing
b65061da
ER
16#Requires: webserver(access)
17#Requires: webserver(alias)
18#Requires: webserver(auth)
ff3ba9b3 19#Requires: webserver(cgi)
367a5ad4 20#Requires: webserver(indexfile)
c7e3b118 21#Requires: webserver(php)
584d77a2 22#Requires: webserver(rewrite)
69fb8d33 23#Requires: webserver(setenv)
9407df51
ER
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
ff60f2d3 27%define _webapps /etc/webapps
c1b7608a 28%define _webapp %{name}
ff60f2d3 29%define _sysconfdir %{_webapps}/%{_webapp}
e4a4f082 30#%define _appdir %{_datadir}/%{_webapp}
87b72dfa 31
38caece8
ER
32# in case _sysconfdir is not in webapps dir, run this replace pattern
33# before copy-pasting to your spec: :%s#%{_sysconfdir}#%{_webapps}/%{_webapp}#g
34
9407df51 35%description
d9acef23
ER
36This .spec is for demonstrating triggers used for linking webapp
37configuration to webserver config dir.
9407df51 38
9be49f18
JR
39%description -l pl.UTF-8
40Ten plik .spec służy do pokazania triggerów służących do podłączania
cbe1381a 41konfiguracji aplikacji WWW do katalogu konfiguracyjnego serwera WWW.
832823fd 42
9407df51 43%prep
c27fb8a9
ER
44%setup -q
45
66ac8cb1 46cat > apache.conf <<'EOF'
98da39be
ER
47Alias /%{name} %{_appdir}
48<Directory %{_appdir}>
c27fb8a9
ER
49 Allow from all
50</Directory>
ff60f2d3 51EOF
9407df51 52
324cf851
ER
53cat > lighttpd.conf <<'EOF'
54alias.url += (
55 "/%{name}" => "%{_appdir}",
56)
57EOF
58
9407df51
ER
59%install
60rm -rf $RPM_BUILD_ROOT
61install -d $RPM_BUILD_ROOT%{_sysconfdir}
f36a6fcb 62install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
498b0e06 63
7f007c8b
ER
64cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
65cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
66cp -p lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
c1b7608a 67
d22a0298
ER
68mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/apache.conf
69mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/lighttpd.conf
7f007c8b 70cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
d22a0298 71
7f007c8b
ER
72cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
73cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
74cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
d22a0298 75
ff60f2d3 76# %webapp_* macros usage extracted from /usr/lib/rpm/macros.build:
4f853f24
ER
77#
78# Usage:
ff60f2d3
ER
79# %%webapp_register HTTPD WEBAPP
80# %%webapp_unregister HTTPD WEBAPP
4f853f24 81
a5bcddf5 82%triggerin -- apache1 < 1.3.37-3, apache1-base
ff60f2d3 83%webapp_register apache %{_webapp}
9407df51 84
a5bcddf5 85%triggerun -- apache1 < 1.3.37-3, apache1-base
ff60f2d3 86%webapp_unregister apache %{_webapp}
9407df51 87
86e3a52e 88%triggerin -- apache < 2.2.0, apache-base
ff60f2d3 89%webapp_register httpd %{_webapp}
9407df51 90
86e3a52e 91%triggerun -- apache < 2.2.0, apache-base
ff60f2d3
ER
92%webapp_unregister httpd %{_webapp}
93
94%triggerin -- lighttpd
95%webapp_register lighttpd %{_webapp}
96
97%triggerun -- lighttpd
98%webapp_unregister lighttpd %{_webapp}
e2b18c9c 99
74ca4545
ER
100%clean
101rm -rf $RPM_BUILD_ROOT
102
e2b18c9c
ER
103%files
104%defattr(644,root,root,755)
38caece8
ER
105%dir %attr(750,root,http) %{_sysconfdir}
106%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
107%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
108%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
109%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
f36a6fcb 110%{_appdir}
This page took 0.067548 seconds and 4 git commands to generate.