]> git.pld-linux.org Git - packages/wayland.git/blame - wayland.spec
- docs *are* installed in Th (when apidocs build is enabled, so clean conditionally)
[packages/wayland.git] / wayland.spec
CommitLineData
cea843df
JB
1#
2# Conditional build:
ceb71059 3%bcond_without apidocs # don't build API documentation
cea843df
JB
4%bcond_without static_libs # don't build static libraries
5#
6Summary: Wayland - protocol for a compositor to talk to its clients
7Summary(pl.UTF-8): Wayland - protokół między serwerem składającym a klientami
8Name: wayland
6040c303 9Version: 1.0.6
c875f161 10Release: 2
cea843df
JB
11License: MIT
12Group: Libraries
13Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
6040c303 14# Source0-md5: 936a2590aea69fa3c0cf234d54b9137c
ceb71059 15Patch0: %{name}-publican.patch
a0e72c2c 16Patch1: %{name}-man.patch
cea843df 17URL: http://wayland.freedesktop.org/
ceb71059
JB
18BuildRequires: autoconf >= 2.64
19BuildRequires: automake >= 1:1.11
50b02986 20BuildRequires: docbook-style-xsl
ceb71059 21BuildRequires: doxygen
cea843df
JB
22BuildRequires: expat-devel
23BuildRequires: libffi-devel
ceb71059
JB
24BuildRequires: libtool >= 2:2.2
25BuildRequires: libxslt-progs
cea843df
JB
26BuildRequires: pkgconfig
27BuildRequires: pkgconfig(libffi)
ceb71059 28%{?with_apidocs:BuildRequires: publican >= 3}
cea843df
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Wayland is a project to define a protocol for a compositor to talk to
33its clients as well as a library implementation of the protocol. The
34compositor can be a standalone display server running on Linux kernel
35modesetting and evdev input devices, an X application, or a Wayland
36client itself. The clients can be traditional applications, X servers
37(rootless or fullscreen) or other display servers.
38
39%description -l pl.UTF-8
40Wayland to projekt definiujący protokół między serwerem składającym a
41klientami, a także biblioteki implementujące ten protokół. Serwer
42składający może być samodzielnym serwerem wyświetlającym działającym
43na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
44aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
45aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
46wyświetlające.
47
48%package devel
49Summary: Header files for Wayland libraries
50Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Wayland
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: libffi-devel
54
55%description devel
56Header files for Wayland libraries.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe bibliotek Wayland.
60
61%package static
62Summary: Static Wayland libraries
63Summary(pl.UTF-8): Statyczne biblioteki Wayland
64Group: Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66
67%description static
68Static Wayland libraries.
69
70%description static -l pl.UTF-8
71Statyczne biblioteki Wayland.
72
ceb71059
JB
73%package apidocs
74Summary: Wayland API and protocol documentation
75Summary(pl.UTF-8): Dokumentacja API biblioteki oraz protokołu Wayland
76Group: Documentation
77
78%description apidocs
79Wayland API and protocol documentation.
80
81%description apidocs -l pl.UTF-8
82Dokumentacja API biblioteki oraz protokołu Wayland.
83
cea843df
JB
84%prep
85%setup -q
86
ceb71059
JB
87# this file is required by publican 3.0; publican patch adds it in en-US dir
88test ! -f doc/Wayland/en_US/Revision_History.xml
89
90%patch0 -p1
a0e72c2c
JB
91%patch1 -p1
92
93# force regeneration (.so link is broken, double man3/)
94%{__rm} doc/man/*.3
ceb71059 95
cea843df 96%build
ceb71059
JB
97%{__libtoolize}
98%{__aclocal} -I m4
99%{__autoconf}
100%{__autoheader}
101%{__automake}
cea843df
JB
102%configure \
103 --disable-silent-rules \
104 %{!?with_static_libs:--disable-static}
a0e72c2c 105
cea843df
JB
106%{__make}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
114# obsoleted by pkg-config
115%{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
00c5e567
JB
116%if %{with apidocs}
117# packaged as %doc in -devel
118%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
119%endif
cea843df
JB
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
cc8accbe 129%doc COPYING README TODO
cea843df
JB
130%attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
131%attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
cc8accbe
JB
132%attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
133%attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
cea843df
JB
134%attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
136
137%files devel
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_bindir}/wayland-scanner
140%attr(755,root,root) %{_libdir}/libwayland-client.so
cc8accbe 141%attr(755,root,root) %{_libdir}/libwayland-cursor.so
cea843df
JB
142%attr(755,root,root) %{_libdir}/libwayland-server.so
143%{_includedir}/wayland-*.h
144%{_pkgconfigdir}/wayland-client.pc
cc8accbe 145%{_pkgconfigdir}/wayland-cursor.pc
cea843df
JB
146%{_pkgconfigdir}/wayland-server.pc
147%{_aclocaldir}/wayland-scanner.m4
148%{_aclocaldir}/wayland-scanner.mk
ceb71059
JB
149%{_mandir}/man3/wl_display_connect.3*
150%{_mandir}/man3/wl_display_connect_to_fd*
cea843df
JB
151
152%if %{with static_libs}
153%files static
154%defattr(644,root,root,755)
155%{_libdir}/libwayland-client.a
cc8accbe 156%{_libdir}/libwayland-cursor.a
cea843df
JB
157%{_libdir}/libwayland-server.a
158%endif
ceb71059
JB
159
160%if %{with apidocs}
161%files apidocs
162%defattr(644,root,root,755)
163%doc doc/Wayland/Wayland/en-US/html/*
164%endif
This page took 0.106201 seconds and 4 git commands to generate.