]> git.pld-linux.org Git - packages/waf.git/blame - waf.spec
- new
[packages/waf.git] / waf.spec
CommitLineData
a4eae65c
ER
1Summary: The Waf build system
2Name: waf
3Version: 1.0.1
4Release: 0.2
5License: BSD
6Group: Development/Building
7Source0: http://freehackers.org/~tnagy/%{name}-%{version}.tar.bz2
8# Source0-md5: bc33d144ee927caec6279e0bf4b174ab
9URL: http://freehackers.org/~tnagy/bksys.html
10BuildRequires: python
11BuildRequires: sed >= 4.0
12BuildArch: noarch
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%define _libdir %{_prefix}/lib
16
17%description
18Waf is a general-purpose build system which was modelled from Scons.
19Though it comes last in the arena of the build systems, we believe
20that Waf is a vastly superior alternative to its competitors
21(Autotools, Scons, Cmake, Ant, etc) for building software,
22
23%prep
24%setup -q
25
26%build
27./waf-light --make-waf
28%{__sed} -i -e '1s,#!.*python,#!%{__python},' waf
29
30%install
31rm -rf $RPM_BUILD_ROOT
32./waf \
33 --prefix $RPM_BUILD_ROOT%{_prefix} \
34 --destdir $RPM_BUILD_ROOT \
35 --install
36
37%py_comp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
38%py_ocomp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
39%py_postclean %{_libdir}/%{name}-%{version}
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(644,root,root,755)
46%doc README TODO
47%attr(755,root,root) %{_bindir}/waf
48%dir %{_libdir}/%{name}-%{version}
49%dir %{_libdir}/%{name}-%{version}/wafadmin
50%{_libdir}/%{name}-%{version}/wafadmin/*.py[co]
51%dir %{_libdir}/%{name}-%{version}/wafadmin/Tools
52%{_libdir}/%{name}-%{version}/wafadmin/Tools/*.py[co]
This page took 0.086226 seconds and 4 git commands to generate.