]> git.pld-linux.org Git - packages/virt-manager.git/blame - virt-manager.spec
- parent dirs
[packages/virt-manager.git] / virt-manager.spec
CommitLineData
8eb0adf0
SP
1
2Summary: Virtual Machine Manager
3Name: virt-manager
4Version: 0.6.0
5Release: 0.1
6License: GPL v2+
7Group: Applications/Emulators
8URL: http://virt-manager.et.redhat.com/
9Source0: http://virt-manager.et.redhat.com/download/sources/virt-manager/%{name}-%{version}.tar.gz
10# Source0-md5: fd0acd111f180a0766b08d5f42cf5468
11Patch0: %{name}-python.patch
12BuildRequires: atk-devel
13BuildRequires: cairo-devel
14BuildRequires: gettext
15BuildRequires: glib2-devel
16#BuildRequires: gtk2-devel
17BuildRequires: intltool
18BuildRequires: pango-devel
19BuildRequires: python-devel >= 2.14
20BuildRequires: python-pygobject-devel >= 2.14
21BuildRequires: python-pygtk-devel >= 2.14
22BuildRequires: scrollkeeper
23
24# These two are just the oldest version tested
8eb0adf0 25Requires: pygtk2 >= 1.99.12-6
16442c1b 26Requires: python-gnome-gconf >= 1.99.11-7
8eb0adf0 27# Absolutely require this version or newer
b225787c 28Requires: python-libvirt >= 0.4.5
8eb0adf0 29# Definitely does not work with earlier due to python API changes
16442c1b 30Requires: python-dbus >= 0.61
8eb0adf0
SP
31# Might work with earlier, but this is what we've tested
32Requires: gnome-keyring >= 0.4.9
33# Minimum we've tested with
34# Although if you don't have this, comment it out and the app
35# will work just fine - keyring functionality will simply be
36# disabled
16442c1b
SP
37Requires: python-gnome-desktop-keyring >= 2.15.4
38Requires: python-gnome-vfs >= 2.15.4
8eb0adf0
SP
39# Minimum we've tested with
40# Required for loading the glade UI
41# Required for our graphics which are currently SVG format
42# Required to install Xen & QEMU guests
16442c1b
SP
43Requires: python-gnome-desktop-librsvg >= 2.14
44Requires: python-libxml2 >= 2.6.23
45Requires: python-pygtk-glade >= 2.12
8eb0adf0
SP
46Requires: python-virtinst >= 0.400.0
47# Earlier vte had broken python binding module
48Requires: vte >= 0.12.2
49# For online help
50Requires: scrollkeeper
51# For console widget
16442c1b 52Requires: python-gtk-vnc >= 0.3.4
8eb0adf0
SP
53# For local authentication against PolicyKit
54Requires: PolicyKit-gnome
55
56ExclusiveArch: %{ix86} x86_64 ia64
57
58Requires(post): GConf2
59Requires(pre): GConf2
60Requires(preun): GConf2
61
62%description
63Virtual Machine Manager provides a graphical tool for administering
64virtual machines for KVM, Xen, and QEmu. Start, stop, add or remove
65virtual devices, connect to a graphical or serial console, and see
66resource usage statistics for existing VMs on local or remote
67machines. Uses libvirt as the backend management API.
68
69%prep
70%setup -q
71%patch0 -p1
72
73%build
74%configure
75%{__make}
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80%{__make} install DESTDIR=$RPM_BUILD_ROOT
81rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.a
82rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.la
83%find_lang %{name}
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%pre
89if [ "$1" -gt 1 ]; then
90 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
91 gconftool-2 --makefile-uninstall-rule \
92 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
93fi
94
95%post
96export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
97gconftool-2 --makefile-install-rule \
98 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
99
100update-desktop-database %{_desktopdir}
101
102if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q -o %{_datadir}/omf/%{name}; fi
103
104%postun
105update-desktop-database %{_desktopdir}
106
107if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q; fi
108
109%preun
110if [ "$1" -eq 0 ]; then
111 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
112 gconftool-2 --makefile-uninstall-rule \
113 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
114fi
115
116%files -f %{name}.lang
117%defattr(644,root,root,755)
118%doc README COPYING COPYING-DOCS AUTHORS ChangeLog NEWS
119%{_sysconfdir}/gconf/schemas/%{name}.schemas
120%attr(755,root,root) %{_bindir}/%{name}
121%{_libexecdir}/%{name}-launch
b225787c 122%dir %{_libdir}/%{name}
8eb0adf0
SP
123%{_libdir}/%{name}/*
124
b225787c 125%dir %{_datadir}/%{name}
8eb0adf0 126%{_datadir}/%{name}/*.glade
b225787c 127%dir %{_datadir}/%{name}/pixmaps
8eb0adf0
SP
128%{_datadir}/%{name}/pixmaps/*.png
129%{_datadir}/%{name}/pixmaps/*.svg
130
131%{_datadir}/%{name}/*.py
132#%{_datadir}/%{name}/*.pyc
133#%{_datadir}/%{name}/*.pyo
134
b225787c 135%dir %{_datadir}/%{name}/virtManager
8eb0adf0
SP
136%{_datadir}/%{name}/virtManager/*.py
137#%{_datadir}/%{name}/virtManager/*.pyc
138#%{_datadir}/%{name}/virtManager/*.pyo
139
b225787c
SP
140%dir %{_datadir}/omf/%{name}
141%dir %{_datadir}/gnome/help
8eb0adf0
SP
142
143%{_desktopdir}/%{name}.desktop
144%{_datadir}/dbus-1/services/%{name}.service
145
146%{_mandir}/man1/%{name}.1*
This page took 0.049327 seconds and 4 git commands to generate.