]> git.pld-linux.org Git - packages/virt-manager.git/blame - virt-manager.spec
- added more Requires
[packages/virt-manager.git] / virt-manager.spec
CommitLineData
8eb0adf0
SP
1
2Summary: Virtual Machine Manager
3Name: virt-manager
4Version: 0.6.0
5Release: 0.1
6License: GPL v2+
7Group: Applications/Emulators
8URL: http://virt-manager.et.redhat.com/
9Source0: http://virt-manager.et.redhat.com/download/sources/virt-manager/%{name}-%{version}.tar.gz
10# Source0-md5: fd0acd111f180a0766b08d5f42cf5468
11Patch0: %{name}-python.patch
12BuildRequires: atk-devel
13BuildRequires: cairo-devel
14BuildRequires: gettext
15BuildRequires: glib2-devel
16#BuildRequires: gtk2-devel
17BuildRequires: intltool
18BuildRequires: pango-devel
19BuildRequires: python-devel >= 2.14
20BuildRequires: python-pygobject-devel >= 2.14
21BuildRequires: python-pygtk-devel >= 2.14
22BuildRequires: scrollkeeper
23
24# These two are just the oldest version tested
16442c1b 25Requires: python-gnome-gconf >= 1.99.11-7
0f49eac5 26Requires: python-pygtk-gtk >= 1.99.12-6
8eb0adf0 27# Absolutely require this version or newer
b225787c 28Requires: python-libvirt >= 0.4.5
8eb0adf0 29# Definitely does not work with earlier due to python API changes
16442c1b 30Requires: python-dbus >= 0.61
8eb0adf0
SP
31# Might work with earlier, but this is what we've tested
32Requires: gnome-keyring >= 0.4.9
33# Minimum we've tested with
34# Although if you don't have this, comment it out and the app
35# will work just fine - keyring functionality will simply be
36# disabled
16442c1b
SP
37Requires: python-gnome-desktop-keyring >= 2.15.4
38Requires: python-gnome-vfs >= 2.15.4
8eb0adf0
SP
39# Minimum we've tested with
40# Required for loading the glade UI
41# Required for our graphics which are currently SVG format
42# Required to install Xen & QEMU guests
16442c1b
SP
43Requires: python-gnome-desktop-librsvg >= 2.14
44Requires: python-libxml2 >= 2.6.23
45Requires: python-pygtk-glade >= 2.12
8eb0adf0
SP
46Requires: python-virtinst >= 0.400.0
47# Earlier vte had broken python binding module
48Requires: vte >= 0.12.2
49# For online help
50Requires: scrollkeeper
51# For console widget
16442c1b 52Requires: python-gtk-vnc >= 0.3.4
8eb0adf0
SP
53# For local authentication against PolicyKit
54Requires: PolicyKit-gnome
55
0f49eac5
SP
56Requires: python-urlgrabber
57Requires: python-vte
58
8eb0adf0
SP
59ExclusiveArch: %{ix86} x86_64 ia64
60
61Requires(post): GConf2
62Requires(pre): GConf2
63Requires(preun): GConf2
64
65%description
66Virtual Machine Manager provides a graphical tool for administering
67virtual machines for KVM, Xen, and QEmu. Start, stop, add or remove
68virtual devices, connect to a graphical or serial console, and see
69resource usage statistics for existing VMs on local or remote
70machines. Uses libvirt as the backend management API.
71
72%prep
73%setup -q
74%patch0 -p1
75
76%build
77%configure
78%{__make}
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83%{__make} install DESTDIR=$RPM_BUILD_ROOT
84rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.a
85rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.la
86%find_lang %{name}
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%pre
92if [ "$1" -gt 1 ]; then
93 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94 gconftool-2 --makefile-uninstall-rule \
95 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
96fi
97
98%post
99export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
100gconftool-2 --makefile-install-rule \
101 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
102
103update-desktop-database %{_desktopdir}
104
105if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q -o %{_datadir}/omf/%{name}; fi
106
107%postun
108update-desktop-database %{_desktopdir}
109
110if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q; fi
111
112%preun
113if [ "$1" -eq 0 ]; then
114 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
115 gconftool-2 --makefile-uninstall-rule \
116 %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
117fi
118
119%files -f %{name}.lang
120%defattr(644,root,root,755)
121%doc README COPYING COPYING-DOCS AUTHORS ChangeLog NEWS
122%{_sysconfdir}/gconf/schemas/%{name}.schemas
123%attr(755,root,root) %{_bindir}/%{name}
124%{_libexecdir}/%{name}-launch
b225787c 125%dir %{_libdir}/%{name}
8eb0adf0
SP
126%{_libdir}/%{name}/*
127
b225787c 128%dir %{_datadir}/%{name}
8eb0adf0 129%{_datadir}/%{name}/*.glade
b225787c 130%dir %{_datadir}/%{name}/pixmaps
8eb0adf0
SP
131%{_datadir}/%{name}/pixmaps/*.png
132%{_datadir}/%{name}/pixmaps/*.svg
133
134%{_datadir}/%{name}/*.py
135#%{_datadir}/%{name}/*.pyc
136#%{_datadir}/%{name}/*.pyo
137
b225787c 138%dir %{_datadir}/%{name}/virtManager
8eb0adf0
SP
139%{_datadir}/%{name}/virtManager/*.py
140#%{_datadir}/%{name}/virtManager/*.pyc
141#%{_datadir}/%{name}/virtManager/*.pyo
142
b225787c
SP
143%dir %{_datadir}/omf/%{name}
144%dir %{_datadir}/gnome/help
8eb0adf0
SP
145
146%{_desktopdir}/%{name}.desktop
147%{_datadir}/dbus-1/services/%{name}.service
148
149%{_mandir}/man1/%{name}.1*
This page took 0.057794 seconds and 4 git commands to generate.