]> git.pld-linux.org Git - packages/vde2.git/blame - vde2.spec
- switch to python3
[packages/vde2.git] / vde2.spec
CommitLineData
f7fdb76e 1Summary: VDE2: Virtual Distributed Ethernet
2Summary(pl.UTF-8): VDE2: wirtualny rozproszony ethernet
3Name: vde2
5312b291 4Version: 2.3.2
d32f71a6 5Release: 7
5312b291 6License: LGPL v2.1+ (libvdeplug), BSD (slirpvde), GPL v2+ (the rest)
f7fdb76e 7Group: Networking/Utilities
5312b291
JB
8Source0: http://downloads.sourceforge.net/vde/%{name}-%{version}.tar.bz2
9# Source0-md5: 46fbc5f97f03dc517aa3b2c9d9ea6628
491a8be5 10Patch0: %{name}-pathmax.patch
ebb249ef 11Patch1: %{name}-format.patch
d1657b48 12Patch2: %{name}-openssl-1.1.patch
d32f71a6 13Patch3: python3.patch
f7fdb76e 14URL: http://sourceforge.net/projects/vde/
5312b291 15BuildRequires: autoconf >= 2.59
f7fdb76e 16BuildRequires: automake
5312b291 17BuildRequires: libpcap-devel
f7fdb76e 18BuildRequires: libtool
5312b291 19BuildRequires: openssl-devel
d32f71a6 20BuildRequires: python3-devel
5312b291
JB
21BuildRequires: rpm-pythonprov
22BuildRequires: rpmbuild(macros) >= 1.219
23Requires: %{name}-libs = %{version}-%{release}
24Obsoletes: vde < 2
f7fdb76e 25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
5312b291
JB
27# expects "prompt" symbol from user
28%define skip_post_check_so libvdehist.*
29
f7fdb76e 30%description
31VDE2: Virtual Distributed Ethernet. It creates the abstraction of a
32virtual ethernet: a single vde can be accessed by virtual and real
33computers.
34
35%description -l pl.UTF-8
36VDE2: wirtualny rozproszony ethernet. Narzędzie to tworzy abstrakcyjny
37wirtualny ethernet - pojedynczy vde może być dostępny z wirtualnych
38jak i rzeczywistych komputerów.
39
5312b291
JB
40%package libs
41Summary: VDE2 libraries
42Summary(pl.UTF-8): Biblioteki VDE2
43Group: Libraries
44Conflicts: vde2 < 2.3.2
45
46%description libs
47VDE2 libraries.
48
49%description libs -l pl.UTF-8
50Biblioteki VDE2.
51
f7fdb76e 52%package devel
5312b291
JB
53Summary: Header files for VDE2 libraries
54Summary(pl.UTF-8): Pliki nagłówkowe bibliotek VDE2
f7fdb76e 55Group: Development/Libraries
5312b291 56Requires: %{name}-libs = %{version}-%{release}
f7fdb76e 57
58%description devel
5312b291 59Header files for VDE2 libraries.
f7fdb76e 60
61%description devel -l pl.UTF-8
5312b291 62Pliki nagłówkowe bibliotek VDE2.
f7fdb76e 63
64%package static
65Summary: Static VDE2 library
66Summary(pl.UTF-8): Statyczna biblioteka VDE2
67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71Static VDE2 library.
72
73%description static -l pl.UTF-8
74Statyczna biblioteka VDE2.
75
5312b291
JB
76%package -n python-vde2
77Summary: Python interface to VDE2
78Summary(pl.UTF-8): Pythonowy interfejs do VDE2
79Group: Libraries/Python
80Requires: %{name}-libs = %{version}-%{release}
81
82%description -n python-vde2
83Python interface to VDE2.
84
85%description -n python-vde2 -l pl.UTF-8
86Pythonowy interfejs do VDE2.
87
f7fdb76e 88%prep
89%setup -q
491a8be5 90%patch0 -p1
ebb249ef 91%patch1 -p1
d1657b48 92%patch2 -p1
d32f71a6 93%patch3 -p1
f7fdb76e 94
95%build
96%{__libtoolize}
97%{__aclocal}
98%{__autoconf}
5312b291 99%{__autoheader}
f7fdb76e 100%{__automake}
5312b291
JB
101%configure \
102 --disable-silent-rules \
103 --enable-kernel-switch
f7fdb76e 104
ebb249ef 105%{__make} -j1 \
d32f71a6 106 pythondir=%{py3_sitedir}
f7fdb76e 107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111%{__make} install \
5312b291 112 DESTDIR=$RPM_BUILD_ROOT \
d32f71a6 113 pythondir=%{py3_sitedir}
f7fdb76e 114
5312b291
JB
115# loadable modules
116%{__rm} $RPM_BUILD_ROOT%{_libdir}/vde2/libvdetap.{la,a}
117%{__rm} $RPM_BUILD_ROOT%{_libdir}/vde2/vde_l3/*.la
d32f71a6 118%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/vdeplug_python.la
5312b291 119# libs .la kept - no Requires/Libs.private
f7fdb76e 120
5312b291
JB
121cp -p src/slirpvde/README README.slirpvde
122
d32f71a6
MK
123%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
124%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
b738e09c 125
f7fdb76e 126%clean
127rm -rf $RPM_BUILD_ROOT
128
5312b291
JB
129%post libs -p /sbin/ldconfig
130%postun libs -p /sbin/ldconfig
f7fdb76e 131
132%files
133%defattr(644,root,root,755)
5312b291 134%doc COPYING.slirpvde Changelog README README.slirpvde
e8a4594f 135%dir %{_sysconfdir}/vde2
e8a4594f 136%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vde2/vdecmd
5312b291 137%dir %{_sysconfdir}/vde2/libvdemgmt
e8a4594f 138%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vde2/libvdemgmt/asyncrecv.rc
139%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vde2/libvdemgmt/closemachine.rc
140%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vde2/libvdemgmt/openmachine.rc
141%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vde2/libvdemgmt/sendcmd.rc
5312b291
JB
142%attr(755,root,root) %{_bindir}/dpipe
143%attr(755,root,root) %{_bindir}/kvde_switch
144%attr(755,root,root) %{_bindir}/slirpvde
145%attr(755,root,root) %{_bindir}/unixcmd
146%attr(755,root,root) %{_bindir}/unixterm
147%attr(755,root,root) %{_bindir}/vde_autolink
148%attr(755,root,root) %{_bindir}/vde_cryptcab
149%attr(755,root,root) %{_bindir}/vde_l3
150%attr(755,root,root) %{_bindir}/vde_over_ns
151%attr(755,root,root) %{_bindir}/vde_pcapplug
152%attr(755,root,root) %{_bindir}/vde_plug
153%attr(755,root,root) %{_bindir}/vde_plug2tap
154%attr(755,root,root) %{_bindir}/vde_switch
155%attr(755,root,root) %{_bindir}/vdecmd
156%attr(755,root,root) %{_bindir}/vdekvm
157%attr(755,root,root) %{_bindir}/vdeq
158%attr(755,root,root) %{_bindir}/vdeqemu
159%attr(755,root,root) %{_bindir}/vdeterm
160%attr(755,root,root) %{_bindir}/wirefilter
161%attr(755,root,root) %{_sbindir}/vde_tunctl
d1657b48 162%attr(755,root,root) %{_libexecdir}/vdetap
45dacef7 163%dir %{_libdir}/vde2
f7fdb76e 164%attr(755,root,root) %{_libdir}/vde2/libvdetap.so
5312b291
JB
165%dir %{_libdir}/vde2/vde_l3
166%attr(755,root,root) %{_libdir}/vde2/vde_l3/bfifo.so
167%attr(755,root,root) %{_libdir}/vde2/vde_l3/pfifo.so
168%attr(755,root,root) %{_libdir}/vde2/vde_l3/tbf.so
169%{_mandir}/man1/dpipe.1*
170%{_mandir}/man1/slirpvde.1*
171%{_mandir}/man1/unixcmd.1*
172%{_mandir}/man1/unixterm.1*
173%{_mandir}/man1/vde_autolink.1*
174%{_mandir}/man1/vde_cryptcab.1*
175%{_mandir}/man1/vde_l3.1*
176%{_mandir}/man1/vde_over_ns.1*
177%{_mandir}/man1/vde_pcapplug.1*
178%{_mandir}/man1/vde_plug.1*
179%{_mandir}/man1/vde_plug2tap.1*
180%{_mandir}/man1/vde_switch.1*
181%{_mandir}/man1/vdecmd.1*
182%{_mandir}/man1/vdekvm.1*
183%{_mandir}/man1/vdeq.1*
184%{_mandir}/man1/vdeqemu.1*
185%{_mandir}/man1/vdetaplib.1*
186%{_mandir}/man1/vdeterm.1*
187%{_mandir}/man1/wirefilter.1*
188%{_mandir}/man8/vde_tunctl.8*
189
190%files libs
191%defattr(644,root,root,755)
192%attr(755,root,root) %{_libdir}/libvdehist.so.*.*.*
193%attr(755,root,root) %ghost %{_libdir}/libvdehist.so.0
194%attr(755,root,root) %{_libdir}/libvdemgmt.so.*.*.*
195%attr(755,root,root) %ghost %{_libdir}/libvdemgmt.so.0
196%attr(755,root,root) %{_libdir}/libvdeplug.so.*.*.*
197%attr(755,root,root) %ghost %{_libdir}/libvdeplug.so.3
198%attr(755,root,root) %{_libdir}/libvdesnmp.so.*.*.*
199%attr(755,root,root) %ghost %{_libdir}/libvdesnmp.so.0
f7fdb76e 200
201%files devel
202%defattr(644,root,root,755)
5312b291
JB
203%attr(755,root,root) %{_libdir}/libvdehist.so
204%attr(755,root,root) %{_libdir}/libvdemgmt.so
205%attr(755,root,root) %{_libdir}/libvdeplug.so
206%attr(755,root,root) %{_libdir}/libvdesnmp.so
207%{_libdir}/libvdehist.la
208%{_libdir}/libvdemgmt.la
209%{_libdir}/libvdeplug.la
210%{_libdir}/libvdesnmp.la
211%{_includedir}/libvdehist.h
212%{_includedir}/libvdemgmt.h
213%{_includedir}/libvdeplug.h
214%{_includedir}/libvdeplug_dyn.h
215%{_includedir}/libvdesnmp.h
216%{_pkgconfigdir}/vdehist.pc
217%{_pkgconfigdir}/vdemgmt.pc
218%{_pkgconfigdir}/vdeplug.pc
219%{_pkgconfigdir}/vdesnmp.pc
f7fdb76e 220
221%files static
222%defattr(644,root,root,755)
5312b291
JB
223%{_libdir}/libvdehist.a
224%{_libdir}/libvdemgmt.a
225%{_libdir}/libvdeplug.a
226%{_libdir}/libvdesnmp.a
227
228%files -n python-vde2
229%defattr(644,root,root,755)
d32f71a6
MK
230%attr(755,root,root) %{py3_sitedir}/vdeplug_python.so
231%{py3_sitedir}/VdePlug.py
232%{py3_sitedir}/__pycache__/VdePlug.cpython-*.py[co]
This page took 0.554972 seconds and 4 git commands to generate.