]> git.pld-linux.org Git - packages/transcode.git/blame - transcode.spec
- converted to UTF-8
[packages/transcode.git] / transcode.spec
CommitLineData
9c77b8c1 1# TODO:
b5d29c62 2# - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
9c77b8c1 3# - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
bc273673 4# - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
b5d29c62 5# - pvm3 needs recompiled with -fPIC, then it can be used here
173bf2e8 6#
3a5a33fc 7# Conditional build:
b5d29c62 8%bcond_without avifile # disable avifile module
18be77ee 9%bcond_without gtk # disable GTK+ dependent stuff
10%bcond_without im # disable imagemagick module
11%bcond_without libmpeg2 # disable libmpeg2 support
b5d29c62 12%bcond_without libmpeg3 # disable libmpeg3 support
18be77ee 13%bcond_without lzo # disable lzo support
14%bcond_without mjpeg # disable mjpegtools support
15%bcond_without sdl # disable SDL support
b5d29c62
JB
16%bcond_with jpegmmx # jpeg-mmx
17%bcond_with pvm3 # pvm3
18
19# no jpeg-mmx there (doesn't compile)
20%ifnarch i586 i686 athlon
21%undefine with_jpegmmx
22%endif
23# pvm3 needs recompiled with -fPIC
24%ifarch %{x8664} alpha
25%undefine with_pvm3
26%endif
3a5a33fc 27#
1aabd80a 28Summary: Video stream converter
31b7198d 29Summary(pl.UTF-8): Konwerter strumieni video
692e6cca 30Name: transcode
b5d29c62 31Version: 1.0.2
e4bcdb9a 32Release: 2
692e6cca 33License: GPL
34Group: Applications
466c9e81 35Source0: http://www.jakemsr.com/transcode/%{name}-%{version}.tar.gz
b5d29c62 36# Source0-md5: e353c0ab7e927a8672528e05a9ae960b
a083a3eb
AM
37Patch0: %{name}-ac.patch
38Patch1: %{name}-lzo2.patch
39Patch2: %{name}-bigdir.patch
b22bf938 40Patch3: %{name}-mpeg3.patch
ba2e284e 41Patch4: %{name}-libx86_64.patch
e4bcdb9a 42Patch5: %{name}-ffmpeg.patch
466c9e81 43URL: http://www.transcoding.org/
a081df10 44%{?with_im:BuildRequires: ImageMagick-devel >= 5.4.3}
bc273673 45%{?with_sdl:BuildRequires: SDL-devel >= 1.1.6}
09355889 46BuildRequires: a52dec-libs-devel
985963d8
JB
47BuildRequires: autoconf
48BuildRequires: automake >= 1.3
b5d29c62
JB
49%{?with_avifile:BuildRequires: avifile-devel > 3:0.7.43-1}
50BuildRequires: ffmpeg-devel >= 0.4.9-0.pre1
bc273673 51BuildRequires: freetype-devel >= 2.1.2
a081df10 52%{?with_gtk:BuildRequires: gtk+-devel}
b5d29c62 53%{?with_jpegmmx:BuildRequires: jpeg-mmx}
bc273673 54BuildRequires: lame-libs-devel >= 3.89
18be77ee 55BuildRequires: libdv-devel >= 0.104-3
692e6cca 56BuildRequires: libdvdread-devel
09e58a63 57BuildRequires: libfame-devel
bc273673 58BuildRequires: libjpeg-devel
a081df10 59%{?with_libmpeg3:BuildRequires: libmpeg3-devel}
e6c0f64a 60BuildRequires: libogg-devel
ffe2ce89 61BuildRequires: libpng-devel
18be77ee 62%{?with_quicktime:BuildRequires: libquicktime-devel}
ffe2ce89 63BuildRequires: libstdc++-devel
bc273673 64BuildRequires: libtheora-devel
985963d8 65BuildRequires: libtool >= 2:1.5
0da60c37
JB
66BuildRequires: libvorbis-devel
67BuildRequires: libxml2-devel
34030055 68%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
18be77ee 69%{?with_mjpeg:BuildRequires: mjpegtools-devel}
70%{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
bc273673
JB
71%ifarch %{ix86}
72BuildRequires: nasm >= 0.98.34
73%endif
ffe2ce89 74BuildRequires: pkgconfig
b5d29c62 75%{?with_pvm3:BuildRequires: pvm-devel}
ace5874a
JB
76BuildRequires: xorg-lib-libXaw-devel
77BuildRequires: xorg-lib-libXpm-devel
dc2b7f6d 78BuildRequires: xvid-devel
692e6cca 79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
985963d8
JB
81%define specflags -fomit-frame-pointer
82
692e6cca 83%description
1aabd80a 84Linux Video Stream Processing Tool.
692e6cca 85
31b7198d
JR
86%description -l pl.UTF-8
87Linuksowe narzędzie do obróbki strumieni video.
692e6cca 88
bc273673 89%package avilib
e14e2a25 90Summary: library to handle avi files from transcode
31b7198d 91Summary(pl.UTF-8): biblioteka do obróbki plików avi pochodząca z transcode
e14e2a25 92Group: Development/Libraries
93
d583e249 94%description avilib
3a5a33fc 95Avilib is part of transcode made accessible for other programs that
bc273673 96require it. So far I know of one such program - ogmtools.
e14e2a25 97
31b7198d
JR
98%description avilib -l pl.UTF-8
99Avifile jest częścią programu transcode udostępnioną dla innych
100programów, które jej wymagają. Jak na razie znam jeden taki program -
3a5a33fc 101ogmtools.
e14e2a25 102
692e6cca 103%prep
985963d8 104%setup -q
a083a3eb
AM
105%patch0 -p1
106%patch1 -p1
107%patch2 -p0
b22bf938 108%patch3 -p0
ba2e284e 109%patch4 -p0
e4bcdb9a 110%patch5 -p1
692e6cca 111
112%build
985963d8
JB
113%{__libtoolize}
114%{__aclocal}
115%{__autoconf}
116%{__autoheader}
117%{__automake}
faec1ee4
JB
118# ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
119# or divx4linux itself (make bcond_with if you want it)
09355889 120%configure \
faec1ee4
JB
121 ac_cv_header_decore_h=no \
122 ac_cv_header_encore2_h=no \
bc273673
JB
123%ifarch ppc
124 --disable-altivec \
125%endif
b5d29c62
JB
126%ifarch %{ix86} %{x8664}
127 --enable-mmx \
128 --enable-3dnow \
129 --enable-sse \
130 --enable-sse2 \
131%endif
bc273673
JB
132%ifarch %{ix86}
133%ifarch i386 i486 i586 \
134 --disable-cmov-extension \
135%else
136 --enable-cmov-extension \
137%endif
138%endif
b5d29c62
JB
139 --disable-bktr \
140 --disable-bsdav \
141 --disable-sunau \
142 --enable-a52 \
143 --enable-a52-default-decoder \
144 --enable-freetype2 \
57e2a6af 145 --%{!?with_gtk:dis}%{?with_gtk:en}able-gtk \
b5d29c62
JB
146 --enable-ibp \
147 --enable-iconv \
148 --enable-imagemagick \
149 --enable-lame \
150 --enable-libavcodec \
151 --enable-libdv \
152 --enable-libdvdread \
153 --enable-libfame \
154 --enable-libjpeg \
18be77ee 155 --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
156 --%{!?with_libmpeg3:dis}%{?with_libmpeg3:en}able-libmpeg3 \
b5d29c62 157 --enable-libpostproc \
18be77ee 158 --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
b5d29c62 159 --enable-libxml2 \
18be77ee 160 --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
d23cb4e2 161 --with-lzo-includes=%{_includedir}/lzo \
18be77ee 162 --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
b5d29c62
JB
163 --enable-netstream \
164 --enable-ogg \
165 --enable-oss \
166 --enable-sdl \
167 --enable-statbuffer \
168 --enable-theora \
169 --enable-v4l \
170 --enable-vorbis \
171 --enable-xio \
172 --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
173 --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
174 --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
175 --with-libpostproc-includes=%{_includedir}/postproc \
ba2e284e 176 --with-x
09355889 177
cd90eb56 178%{__make}
692e6cca 179
180%install
181rm -rf $RPM_BUILD_ROOT
182
3a5a33fc
JB
183%{__make} install \
184 DESTDIR=$RPM_BUILD_ROOT
692e6cca 185
0da60c37 186install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
b5d29c62
JB
187
188# duplicate
189rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
e14e2a25 190
692e6cca 191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%files
195%defattr(644,root,root,755)
09e58a63 196%doc README ChangeLog docs/README* docs/*.txt docs/html
d4ac41e3 197%attr(755,root,root) %{_bindir}/*
b5d29c62 198# TODO: split it into subpackages export-*, import-* and filter-*
0da60c37 199%dir %{_libdir}/%{name}
2bd0284a 200%attr(755,root,root) %{_libdir}/%{name}/*.so*
31c81665 201%attr(755,root,root) %{_libdir}/%{name}/*.awk
d1ee695d 202%{_libdir}/%{name}/*.la
fff0c36c 203%{_libdir}/%{name}/*.conf
e6c0f64a 204%{_libdir}/%{name}/*.cfg
0da60c37 205%{_mandir}/man1/*
e14e2a25 206
207%files avilib
90b6d870 208%defattr(644,root,root,755)
e14e2a25 209%doc avilib/README.avilib
0da60c37 210%{_includedir}/avilib.h
This page took 0.070462 seconds and 4 git commands to generate.