]> git.pld-linux.org Git - projects/template-specs.git/blame - trac-plugin.spec
- no tests packaging
[projects/template-specs.git] / trac-plugin.spec
CommitLineData
6a550c29 1%define trac_ver 0.12
7129cf30
ER
2%define plugin PLUGIN_NAME
3Summary: PLUGIN_NAME Plugin for Trac
4Name: trac-plugin-%{plugin}
5Version: 0.1
6Release: 0.1
ba0f112f 7License: BSD-like / GPL / ...
7129cf30 8Group: Applications/WWW
e2315260 9Source0: http://trac-hacks.org/changeset/latest/tracsqlhelperscript?old_path=/&format=zip#/%{plugin}-%{version}.zip
7129cf30
ER
10# Source0-md5: 9f706e733d205d4467ce6534772cb505
11URL: http://trac-hacks.org/wiki/PLUGIN_NAME
12BuildRequires: python-devel
6a550c29 13Requires: trac >= %{trac_ver}
7129cf30
ER
14BuildArch: noarch
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18
19%prep
20%setup -q -n %{plugin}plugin
e08d63d6 21%setup -q -n trac%{plugin}plugin
ba0f112f
ER
22%setup -qc
23mv %{plugin}plugin/%{trac_ver}/* .
e7b6e3a0 24mv %{trac_ver}/* .
7129cf30
ER
25
26%build
7129cf30
ER
27%{__python} setup.py build
28%{__python} setup.py egg_info
29
ba0f112f
ER
30ver=$(awk '$1 == "Version:" {print $2}' *.egg-info/PKG-INFO)
31test "$ver" = %{version}
32
7129cf30
ER
33%install
34rm -rf $RPM_BUILD_ROOT
7129cf30
ER
35%{__python} setup.py install \
36 --single-version-externally-managed \
37 --optimize 2 \
38 --root=$RPM_BUILD_ROOT
39
40%py_postclean
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%post
e08d63d6 46# XXX: try to figure out from .egg-info / __init__py at build time
e7b6e3a0 47#trac-enableplugin "%{plugin}.Trac%{plugin}Module"
7129cf30
ER
48
49%files
50%defattr(644,root,root,755)
51%{py_sitescriptdir}/trac%{plugin}
52%{py_sitescriptdir}/*-*.egg-info
This page took 0.04312 seconds and 4 git commands to generate.