]> git.pld-linux.org Git - projects/template-specs.git/blame - template.spec
- preamble fix
[projects/template-specs.git] / template.spec
CommitLineData
52ff2772 1#
66c7fa65
ER
2# Conditional build:
3%bcond_with tests # build with tests
4%bcond_without tests # build without tests
52ff2772 5#
e8b9df06 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
5e539df2
ER
8Name: template
9Version: _
c1981b58 10Release: 0.1
72aa6361 11License: - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
4b97f9d0 12Group: Applications
f1b2d418 13Source0: %{name}-%{version}.tar.gz
023a0cc4 14# Source0-md5: -
4b97f9d0 15#Source1: -
023a0cc4 16# Source1-md5: -
49683e54 17#Patch0: %{name}-DESTDIR.patch
e8b9df06 18URL: -
c0c12927
ER
19%if %{with initscript}
20BuildRequires: rpmbuild(macros) >= 1.228
c0c12927 21Requires(post,preun): /sbin/chkconfig
b411d35c 22Requires: rc-scripts
c0c12927 23%endif
5e539df2 24#BuildRequires: -
6d0e4f88 25#BuildRequires: autoconf
fdeb11aa 26#BuildRequires: automake
bd5b2cfe 27#BuildRequires: intltool
6d0e4f88 28#BuildRequires: libtool
5e539df2 29#Requires(postun): -
4b97f9d0
ER
30#Requires(pre,post): -
31#Requires(preun): -
4b97f9d0 32#Requires: -
44d5bb3a 33#Provides: -
c0c12927
ER
34#Provides: group(foo)
35#Provides: user(foo)
4b97f9d0
ER
36#Obsoletes: -
37#Conflicts: -
c1981b58 38#BuildArch: noarch
5e539df2 39#ExclusiveArch: %{ix86}
e8b9df06
SZ
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43
9be49f18 44%description -l pl.UTF-8
e8b9df06 45
352b3a3c
TP
46%package subpackage
47Summary: -
ce39d734 48Summary(pl.UTF-8): -
352b3a3c 49Group: -
352b3a3c
TP
50
51%description subpackage
52
9be49f18 53%description subpackage -l pl.UTF-8
352b3a3c 54
5261abf9
ER
55%package libs
56Summary: -
ce39d734 57Summary(pl.UTF-8): -
5261abf9
ER
58Group: Libraries
59
60%description libs
61
9be49f18 62%description libs -l pl.UTF-8
5261abf9 63
88a5dbe9 64%package devel
c934cc1b 65Summary: Header files for ... library
ce39d734 66Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ...
88a5dbe9 67Group: Development/Libraries
9a2e1218 68# if base package contains shared library for which these headers are
49683e54 69#Requires: %{name} = %{version}-%{release}
9a2e1218
JB
70# if -libs package contains shared library for which these headers are
71#Requires: %{name}-libs = %{version}-%{release}
88a5dbe9
ER
72
73%description devel
9a2e1218 74Header files for ... library.
c934cc1b 75
9be49f18
JR
76%description devel -l pl.UTF-8
77Pliki nagłówkowe biblioteki ....
88a5dbe9
ER
78
79%package static
80Summary: Static ... library
ce39d734 81Summary(pl.UTF-8): Statyczna biblioteka ...
88a5dbe9 82Group: Development/Libraries
c0c12927 83Requires: %{name}-devel = %{version}-%{release}
88a5dbe9
ER
84
85%description static
86Static ... library.
c0c12927 87
9be49f18 88%description static -l pl.UTF-8
c934cc1b
JB
89Statyczna biblioteka ....
90
e8b9df06 91%prep
c0c12927
ER
92%setup -q
93#%setup -q -c -T
94#%setup -q -n %{name}
10428dcb 95#%setup -q -n %{name}-%{version}.orig -a 1
4b97f9d0 96#%patch0 -p1
e8b9df06 97
c0c12927 98# undos the source
5309e6bb 99#find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
c0c12927
ER
100
101# remove CVS control files
102#find -name CVS -print0 | xargs -0 rm -rf
103
c2bc0219
ER
104# you'll need this if you cp -a complete dir in source
105# cleanup backups after patching
53eee976 106find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
c2bc0219 107
e8b9df06 108%build
c42a30cf
JB
109# if ac/am/* rebuilding is necessary, do it in this order and add
110# appropriate BuildRequires
bd5b2cfe 111#%%{__intltoolize}
37416b6e 112#%%{__gettextize}
8f37ba72 113#%%{__libtoolize}
37416b6e 114#%%{__aclocal}
115#%%{__autoconf}
116#%%{__autoheader}
117#%%{__automake}
f5f1d924 118# if not running libtool or automake, but config.sub is too old:
de41dae9 119#cp -f /usr/share/automake/config.sub .
19bf1c4b 120%configure
e8b9df06
SZ
121%{__make}
122
c0c12927
ER
123#%{__make} \
124# CFLAGS="%{rpmcflags}" \
125# LDFLAGS="%{rpmldflags}"
126
e8b9df06
SZ
127%install
128rm -rf $RPM_BUILD_ROOT
d43856e1
JB
129# create directories if necessary
130#install -d $RPM_BUILD_ROOT
b411d35c
ER
131%if %{with initscript}
132install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
133%endif
c0c12927 134#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
e8b9df06 135
a984843b
SP
136%{__make} install \
137 DESTDIR=$RPM_BUILD_ROOT
e8b9df06 138
f5bb3874
JB
139%clean
140rm -rf $RPM_BUILD_ROOT
141
e8b9df06 142%pre
ba57de51
ER
143%groupadd -g xxx %{name}
144%useradd -u xxx -d /var/lib/%{name} -g %{name} -c "XXX User" %{name}
e8b9df06 145
e8b9df06
SZ
146%post
147
b187ef53
JB
148%preun
149
e8b9df06 150%postun
ba57de51
ER
151if [ "$1" = "0" ]; then
152 %userremove %{name}
153 %groupremove %{name}
154fi
c0c12927
ER
155
156%if %{with ldconfig}
157%post -p /sbin/ldconfig
158%postun -p /sbin/ldconfig
159%endif
160
161%if %{with initscript}
162%post init
163/sbin/chkconfig --add %{name}
164%service %{name} restart
165
166%preun init
167if [ "$1" = "0" ]; then
168 %service -q %{name} stop
169 /sbin/chkconfig --del %{name}
170fi
171%endif
e8b9df06 172
e8b9df06
SZ
173%files
174%defattr(644,root,root,755)
5dda8307 175%doc AUTHORS CREDITS CHANGES ChangeLog NEWS README THANKS TODO
cec32492 176
5e539df2 177%if 0
11877175
ER
178# if _sysconfdir != /etc:
179#%%dir %{_sysconfdir}
9c3f0ed0 180%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
0b279ca0 181%attr(755,root,root) %{_bindir}/*
182%{_datadir}/%{name}
5e539df2 183%endif
f1b2d418 184
d1184c8c 185# initscript and its config
5e539df2 186%if %{with initscript}
2482ba2c 187%attr(754,root,root) /etc/rc.d/init.d/%{name}
9c3f0ed0 188%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
5e539df2 189%endif
2482ba2c 190
c0c12927
ER
191#%{_examplesdir}/%{name}-%{version}
192
49683e54 193%if %{with subpackage}
f1b2d418
TP
194%files subpackage
195%defattr(644,root,root,755)
5e539df2
ER
196#%doc extras/*.gz
197#%{_datadir}/%{name}-ext
49683e54 198%endif
This page took 0.112977 seconds and 4 git commands to generate.