]> git.pld-linux.org Git - packages/syncthing.git/blame - syncthing.spec
package all bin, manuals
[packages/syncthing.git] / syncthing.spec
CommitLineData
bbf5053a
ER
1#
2# Conditional build:
3%bcond_with tests # build with tests
4%bcond_without tests # build without tests
5
6Summary: Open Source Continuous File Synchronization
7Name: syncthing
8Version: 0.13.7
9Release: 0.1
10License: MPL-2.0
11Group: Applications/Networking
12Source0: https://github.com/syncthing/syncthing/archive/v%{version}/%{name}-%{version}.tar.gz
13# Source0-md5: 9a94fa95428d4191f61eed834a8161be
14URL: https://syncthing.net/
15BuildRequires: golang >= 1.3.1
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _enable_debug_packages 0
19%define gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
20%define gopath %{_libdir}/golang
21%define import_path github.com/syncthing/syncthing
22
23%description
24Syncthing replaces proprietary sync and cloud services with something
25open, trustworthy and decentralized. Your data is your data alone and
26you deserve to choose where it is stored, if it is shared with some
27third party and how it's transmitted over the Internet.
28
29%prep
30%setup -q
31
32GOPATH=$(pwd)/src
33install -d $(dirname $GOPATH/%{import_path})
34ln -s ../../.. $GOPATH/%{import_path}
35ln -s .. vendor/src
36
37%build
38export GOPATH=$(pwd)
39cd src/%{import_path}
40go run build.go -version "v%{version}" -no-upgrade
41
42%install
43rm -rf $RPM_BUILD_ROOT
39a738b8
ER
44install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man{1,5,7}}
45install -p bin/* $RPM_BUILD_ROOT%{_bindir}
46cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
47cp -p man/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
48cp -p man/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
bbf5053a
ER
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc README.md AUTHORS CONTRIBUTING.md
39a738b8
ER
56%attr(755,root,root) %{_bindir}/discosrv
57%attr(755,root,root) %{_bindir}/relaysrv
58%attr(755,root,root) %{_bindir}/stbench
59%attr(755,root,root) %{_bindir}/stcompdirs
60%attr(755,root,root) %{_bindir}/stdisco
61%attr(755,root,root) %{_bindir}/stevents
62%attr(755,root,root) %{_bindir}/stfileinfo
63%attr(755,root,root) %{_bindir}/stfinddevice
64%attr(755,root,root) %{_bindir}/stgenfiles
65%attr(755,root,root) %{_bindir}/stindex
66%attr(755,root,root) %{_bindir}/stsigtool
67%attr(755,root,root) %{_bindir}/stvanity
68%attr(755,root,root) %{_bindir}/stwatchfile
bbf5053a 69%attr(755,root,root) %{_bindir}/syncthing
39a738b8
ER
70%attr(755,root,root) %{_bindir}/testutil
71%{_mandir}/man1/syncthing.1*
72%{_mandir}/man5/syncthing-config.5*
73%{_mandir}/man5/syncthing-stignore.5*
74%{_mandir}/man7/syncthing-bep.7*
75%{_mandir}/man7/syncthing-device-ids.7*
76%{_mandir}/man7/syncthing-event-api.7*
77%{_mandir}/man7/syncthing-faq.7*
78%{_mandir}/man7/syncthing-globaldisco.7*
79%{_mandir}/man7/syncthing-localdisco.7*
80%{_mandir}/man7/syncthing-networking.7*
81%{_mandir}/man7/syncthing-relay.7*
82%{_mandir}/man7/syncthing-rest-api.7*
83%{_mandir}/man7/syncthing-security.7*
84%{_mandir}/man7/syncthing-versioning.7*
This page took 1.686918 seconds and 4 git commands to generate.