]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- more BR, serializer bcond
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
5# * The CLucene-based full-text search index library
6#
7# Conditional build:
8%bcond_without serializer # with raptor serializer. need to figure out proper BR
9#
2fc92623 10%define _snap rc2
d2ae4b17 11%define rel 2
8667f3ab
JB
12Summary: Soprano - Qt wrapper API to librdf
13Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 14Name: soprano
2fc92623 15Version: 1.99
d2ae4b17 16Release: 0.%{_snap}.%{rel}
5b9e452e 17License: GPL v2
195f432c 18Group: X11/Applications
2fc92623
RT
19Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}-%{_snap}.tar.bz2
20# Source0-md5: 78ae22f085e5e9eb06ee7cda23ecfa0f
5a8ef18c 21URL: http://sourceforge.net/projects/soprano
a2b662ab 22BuildRequires: QtDBus-devel
dbea7b1e
ER
23BuildRequires: QtNetwork-devel
24BuildRequires: QtTest-devel
195f432c 25BuildRequires: autoconf
26BuildRequires: automake
dbea7b1e 27BuildRequires: clucene-core-devel
195f432c 28BuildRequires: cmake
dbea7b1e 29BuildRequires: libraptor-devel
5b9e452e
JB
30BuildRequires: qt4-build >= 4.3.3-3
31BuildRequires: qt4-qmake >= 4.3.3-3
dbea7b1e
ER
32BuildRequires: rasqal-devel
33BuildRequires: redland-devel >= 1.0.6
a234d6d7 34BuildRequires: rpmbuild(macros) >= 1.293
195f432c 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
8667f3ab
JB
38Soprano (formally known as QRDF) is a library which provides a Qt
39wrapper API to different RDF storage solutions. It features named
40graphs (contexts) and has a modular plug-in structure which allows to
41use different RDF storage implementations.
195f432c 42
8667f3ab
JB
43%description -l pl.UTF-8
44Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
45wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
46nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
47pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 48
49%package devel
50Summary: Header files for soprano
51Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56Header files for soprano.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe dla soprano.
60
61%prep
2fc92623 62%setup -q -n %{name}-%{version}-%{_snap}
195f432c 63
64%build
65install -d build
66cd build
67%cmake \
68 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
0b2cd574 69 -DCMAKE_VERBOSE_MAKEFILE=1 \
5b9e452e 70 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 71%if "%{_lib}" == "lib64"
72 -DLIB_SUFFIX=64 \
73%endif
0b2cd574 74 ..
195f432c 75
76%{__make}
77
78%install
79rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
80
81%{__make} -C build install \
195f432c 82 DESTDIR=$RPM_BUILD_ROOT
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(644,root,root,755)
2fc92623
RT
92%attr(755,root,root) %{_bindir}/sopranocmd
93%attr(755,root,root) %{_bindir}/sopranod
0b2cd574 94%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 95%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 96%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 97%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 98%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 99%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
5b9e452e 100%dir %{_libdir}/soprano
0b2cd574 101%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
102%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
103%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
104%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
dbea7b1e 105%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 106%{_datadir}/soprano
2fc92623
RT
107%dir %{_datadir}/dbus-1/interfaces
108%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
109%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
110%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
111%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
112%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
113
195f432c 114%files devel
115%defattr(644,root,root,755)
0b2cd574 116%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
117%attr(755,root,root) %{_libdir}/libsopranoserver.so
118%attr(755,root,root) %{_libdir}/libsopranoclient.so
195f432c 119%dir %{_includedir}/soprano
120%{_includedir}/soprano/*.h
2fc92623 121%{_includedir}/Soprano
5b9e452e 122%{_pkgconfigdir}/soprano.pc
This page took 0.076051 seconds and 4 git commands to generate.