]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- adjusted to new macro
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
e8d4b674 9%bcond_without virtuoso # with virtuosobackend
c7018ab4 10
c94ef90d 11%define qtbrver 4.7.1
e8d4b674 12%define snap svn1042011
855ec3f8 13
8667f3ab
JB
14Summary: Soprano - Qt wrapper API to librdf
15Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 16Name: soprano
c94ef90d 17Version: 2.5.63
0835c44e 18Release: 1
5b9e452e 19License: GPL v2
195f432c 20Group: X11/Applications
ae3009f4 21Source0: http://downloads.sourceforge.net/sourceforge/soprano/%{name}-%{version}.tar.bz2
c94ef90d 22# Source0-md5: bef6147f1245cd99aa9ad1a37f7d48ac
e8d4b674 23#Source0: %{name}-%{version}-%{snap}.tar.gz
5a8ef18c 24URL: http://sourceforge.net/projects/soprano
855ec3f8 25BuildRequires: QtCore-devel >= %{qtbrver}
26BuildRequires: QtDBus-devel >= %{qtbrver}
2ba17820 27BuildRequires: QtGui-devel >= %{qtbrver}
855ec3f8 28BuildRequires: QtNetwork-devel >= %{qtbrver}
2b1fcc2c 29BuildRequires: clucene-core-devel >= 0.9.16a-2
214d4c81 30BuildRequires: cmake >= 2.8.0
84df784d 31%{?with_sesame2:BuildRequires: libgcj-devel}
81788912 32%{?with_serializer:BuildRequires: libraptor-devel}
855ec3f8 33BuildRequires: qt4-build >= %{qtbrver}
34BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e
ER
35BuildRequires: rasqal-devel
36BuildRequires: redland-devel >= 1.0.6
d2faa209 37BuildRequires: rpmbuild(macros) >= 1.600
2ba17820 38BuildRequires: xorg-lib-libX11-devel
39BuildRequires: xorg-lib-libXext-devel
e8d4b674 40%if %{with virtuoso}
41BuildRequires: libiodbc-devel
42Requires: virtuoso >= 6.1.0
43%endif
195f432c 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
8667f3ab
JB
47Soprano (formally known as QRDF) is a library which provides a Qt
48wrapper API to different RDF storage solutions. It features named
49graphs (contexts) and has a modular plug-in structure which allows to
50use different RDF storage implementations.
195f432c 51
8667f3ab 52%description -l pl.UTF-8
2ba17820 53Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
54wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
55nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
56pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 57
58%package devel
59Summary: Header files for soprano
60Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description devel
65Header files for soprano.
66
67%description devel -l pl.UTF-8
68Pliki nagłówkowe dla soprano.
69
70%prep
a4a085c3 71%setup -q
435be701 72# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 73#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 74# cleanup.
84df784d 75#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 76
77%build
78install -d build
79cd build
84df784d 80# add this to get verbose output
81# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 82%cmake \
84df784d 83 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
84 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
78ba8e2d 85%if "%{pld_release}" == "ti"
214d4c81 86 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-11/libjvm.so \
78ba8e2d 87%else
88 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-11/libjvm.so \
89%endif
84df784d 90 ../
195f432c 91
92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
96
97%{__make} -C build install \
195f432c 98 DESTDIR=$RPM_BUILD_ROOT
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(644,root,root,755)
2fc92623
RT
108%attr(755,root,root) %{_bindir}/sopranocmd
109%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 110%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 111%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 112%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 113%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 114%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 115%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 116%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
117%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
118%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 119%dir %{_libdir}/soprano
0b2cd574 120%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
121%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
122%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
123%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
c4571e50 124%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
125%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
e8d4b674 126%{?with_virtuoso:%attr(755,root,root) %{_libdir}/soprano/libsoprano_virtuosobackend.so}
5b9e452e 127%{_datadir}/soprano
2fc92623
RT
128%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
129%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
130%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
131%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
132%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
133
195f432c 134%files devel
135%defattr(644,root,root,755)
0b2cd574 136%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
137%attr(755,root,root) %{_libdir}/libsopranoserver.so
138%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 139%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 140%dir %{_includedir}/soprano
141%{_includedir}/soprano/*.h
2fc92623 142%{_includedir}/Soprano
5b9e452e 143%{_pkgconfigdir}/soprano.pc
0835c44e
AM
144%{_pkgconfigdir}/sopranoserver.pc
145%{_pkgconfigdir}/sopranoclient.pc
146%{_pkgconfigdir}/sopranoindex.pc
This page took 0.244408 seconds and 4 git commands to generate.