]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- up to svn799072
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
c7018ab4 9
855ec3f8 10%define qtbrver 4.4.0
b8b187e8 11%define _rev svn799072
855ec3f8 12
8667f3ab
JB
13Summary: Soprano - Qt wrapper API to librdf
14Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 15Name: soprano
b8b187e8 16Version: 2.0.98
17Release: 0.%{_rev}.1
5b9e452e 18License: GPL v2
195f432c 19Group: X11/Applications
3dd5cf66 20#Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
b8b187e8 21Source0: %{name}-%{version}-%{_rev}.tar.gz
22# Source0-md5: 86113aba1c27d7106de427cb87bcd0c5
5a8ef18c 23URL: http://sourceforge.net/projects/soprano
855ec3f8 24BuildRequires: QtCore-devel >= %{qtbrver}
25BuildRequires: QtDBus-devel >= %{qtbrver}
26BuildRequires: QtNetwork-devel >= %{qtbrver}
27BuildRequires: QtTest-devel >= %{qtbrver}
195f432c 28BuildRequires: autoconf
29BuildRequires: automake
2b1fcc2c 30BuildRequires: clucene-core-devel >= 0.9.16a-2
195f432c 31BuildRequires: cmake
81788912 32%if %{with sesame2}
33BuildRequires: java-sun >= 1.6
34BuildRequires: java-sun-jre >= 1.6
35%endif
36%{?with_serializer:BuildRequires: libraptor-devel}
855ec3f8 37BuildRequires: qt4-build >= %{qtbrver}
38BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e
ER
39BuildRequires: rasqal-devel
40BuildRequires: redland-devel >= 1.0.6
a234d6d7 41BuildRequires: rpmbuild(macros) >= 1.293
195f432c 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
8667f3ab
JB
45Soprano (formally known as QRDF) is a library which provides a Qt
46wrapper API to different RDF storage solutions. It features named
47graphs (contexts) and has a modular plug-in structure which allows to
48use different RDF storage implementations.
195f432c 49
8667f3ab
JB
50%description -l pl.UTF-8
51Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
52wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
53nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
54pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 55
56%package devel
57Summary: Header files for soprano
58Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61
62%description devel
63Header files for soprano.
64
65%description devel -l pl.UTF-8
66Pliki nagłówkowe dla soprano.
67
68%prep
b8b187e8 69%setup -q -n %{name}-%{version}-%{_rev}
195f432c 70
71%build
72install -d build
73cd build
74%cmake \
75 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
0b2cd574 76 -DCMAKE_VERBOSE_MAKEFILE=1 \
5b9e452e 77 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 78%if "%{_lib}" == "lib64"
79 -DLIB_SUFFIX=64 \
81788912 80 -DJAVA_JVM_LIBRARY=/usr/lib64/jvm/java/jre/lib/amd64/server/libjvm.so \
81 -DJAVA_INCLUDE_PATH=/usr/lib64/jvm/java/include/ \
82%else
83 -DJAVA_JVM_LIBRARY=/usr/lib/jvm/java/jre/lib/i386/server/libjvm.so \
84 -DJAVA_INCLUDE_PATH=/usr/lib/jvm/java/include/ \
195f432c 85%endif
0b2cd574 86 ..
195f432c 87
88%{__make}
89
90%install
91rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
92
93%{__make} -C build install \
195f432c 94 DESTDIR=$RPM_BUILD_ROOT
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100%postun -p /sbin/ldconfig
101
102%files
103%defattr(644,root,root,755)
2fc92623
RT
104%attr(755,root,root) %{_bindir}/sopranocmd
105%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 106%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 107%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 108%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 109%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 110%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 111%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 112%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
113%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
114%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 115%dir %{_libdir}/soprano
0b2cd574 116%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
117%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
118%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
119%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
81788912 120%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
dbea7b1e 121%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 122%{_datadir}/soprano
2fc92623
RT
123%dir %{_datadir}/dbus-1/interfaces
124%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
125%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
126%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
127%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
128%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
129
195f432c 130%files devel
131%defattr(644,root,root,755)
0b2cd574 132%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
133%attr(755,root,root) %{_libdir}/libsopranoserver.so
134%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 135%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 136%dir %{_includedir}/soprano
137%{_includedir}/soprano/*.h
2fc92623 138%{_includedir}/Soprano
5b9e452e 139%{_pkgconfigdir}/soprano.pc
This page took 0.053556 seconds and 4 git commands to generate.