]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- 2.1.64
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
c7018ab4 9
84df784d 10%define qtbrver 4.4.3
855ec3f8 11
8667f3ab
JB
12Summary: Soprano - Qt wrapper API to librdf
13Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 14Name: soprano
84df784d 15Version: 2.1.64
764392dd 16Release: 1
5b9e452e 17License: GPL v2
195f432c 18Group: X11/Applications
16082c87 19Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
84df784d 20# Source0-md5: f62267c1f904450ab0e9d8cab30d252b
5a8ef18c 21URL: http://sourceforge.net/projects/soprano
855ec3f8 22BuildRequires: QtCore-devel >= %{qtbrver}
23BuildRequires: QtDBus-devel >= %{qtbrver}
24BuildRequires: QtNetwork-devel >= %{qtbrver}
25BuildRequires: QtTest-devel >= %{qtbrver}
2b1fcc2c 26BuildRequires: clucene-core-devel >= 0.9.16a-2
84df784d 27BuildRequires: cmake >= 2.6.2
28%{?with_sesame2:BuildRequires: libgcj-devel}
81788912 29%{?with_serializer:BuildRequires: libraptor-devel}
855ec3f8 30BuildRequires: qt4-build >= %{qtbrver}
31BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e
ER
32BuildRequires: rasqal-devel
33BuildRequires: redland-devel >= 1.0.6
84df784d 34BuildRequires: rpmbuild(macros) >= 1.453
195f432c 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
8667f3ab
JB
38Soprano (formally known as QRDF) is a library which provides a Qt
39wrapper API to different RDF storage solutions. It features named
40graphs (contexts) and has a modular plug-in structure which allows to
41use different RDF storage implementations.
195f432c 42
8667f3ab 43%description -l pl.UTF-8
84df784d 44Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca
45API wrappera Qt do różnych rozwiązań przechowywania danych RDF.
46Obsługuje nazwane grafy (konteksty) i ma strukturę modularnych
47wtyczek, co pozwala na używanie różnych implementacji
48przechowywania danych RDF.
195f432c 49
50%package devel
51Summary: Header files for soprano
52Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description devel
57Header files for soprano.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe dla soprano.
61
62%prep
a4a085c3 63%setup -q
435be701 64# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 65#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 66# cleanup.
84df784d 67#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 68
69%build
70install -d build
71cd build
84df784d 72# add this to get verbose output
73# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 74%cmake \
75 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
5b9e452e 76 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 77%if "%{_lib}" == "lib64"
78 -DLIB_SUFFIX=64 \
79%endif
84df784d 80 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
81 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
82 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-9/libjvm.so \
83 ../
195f432c 84
85%{__make}
86
87%install
88rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
89
90%{__make} -C build install \
195f432c 91 DESTDIR=$RPM_BUILD_ROOT
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(644,root,root,755)
2fc92623
RT
101%attr(755,root,root) %{_bindir}/sopranocmd
102%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 103%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 104%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 105%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 106%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 107%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 108%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 109%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
110%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
111%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 112%dir %{_libdir}/soprano
0b2cd574 113%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
114%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
115%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
116%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
84df784d 117%attr(755,root,root) %{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
118%attr(755,root,root) %{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 119%{_datadir}/soprano
2fc92623
RT
120%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
121%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
122%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
123%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
124%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
125
195f432c 126%files devel
127%defattr(644,root,root,755)
0b2cd574 128%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
129%attr(755,root,root) %{_libdir}/libsopranoserver.so
130%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 131%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 132%dir %{_includedir}/soprano
133%{_includedir}/soprano/*.h
2fc92623 134%{_includedir}/Soprano
5b9e452e 135%{_pkgconfigdir}/soprano.pc
This page took 0.150137 seconds and 4 git commands to generate.