]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- add patch0
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
c7018ab4 8
8667f3ab
JB
9Summary: Soprano - Qt wrapper API to librdf
10Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 11Name: soprano
7b085424 12Version: 2.0.3
13Release: 1
c7018ab4 14#Release: 0.%{_snap}.%{rel}
5b9e452e 15License: GPL v2
195f432c 16Group: X11/Applications
c7018ab4 17Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
7b085424 18# Source0-md5: 3f33799c6ebd03048621057d268fb62f
5dd338c5 19Patch0: %{name}-qt44.patch
5a8ef18c 20URL: http://sourceforge.net/projects/soprano
ab49304e 21BuildRequires: QtCore-devel
a2b662ab 22BuildRequires: QtDBus-devel
dbea7b1e
ER
23BuildRequires: QtNetwork-devel
24BuildRequires: QtTest-devel
195f432c 25BuildRequires: autoconf
26BuildRequires: automake
2b1fcc2c 27BuildRequires: clucene-core-devel >= 0.9.16a-2
195f432c 28BuildRequires: cmake
dbea7b1e 29BuildRequires: libraptor-devel
5b9e452e
JB
30BuildRequires: qt4-build >= 4.3.3-3
31BuildRequires: qt4-qmake >= 4.3.3-3
dbea7b1e
ER
32BuildRequires: rasqal-devel
33BuildRequires: redland-devel >= 1.0.6
a234d6d7 34BuildRequires: rpmbuild(macros) >= 1.293
195f432c 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
8667f3ab
JB
38Soprano (formally known as QRDF) is a library which provides a Qt
39wrapper API to different RDF storage solutions. It features named
40graphs (contexts) and has a modular plug-in structure which allows to
41use different RDF storage implementations.
195f432c 42
8667f3ab
JB
43%description -l pl.UTF-8
44Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
45wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
46nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
47pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 48
49%package devel
50Summary: Header files for soprano
51Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56Header files for soprano.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe dla soprano.
60
61%prep
c7018ab4 62%setup -q
5dd338c5 63%patch0 -p0
195f432c 64
65%build
66install -d build
67cd build
68%cmake \
69 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
0b2cd574 70 -DCMAKE_VERBOSE_MAKEFILE=1 \
5b9e452e 71 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 72%if "%{_lib}" == "lib64"
73 -DLIB_SUFFIX=64 \
74%endif
0b2cd574 75 ..
195f432c 76
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
81
82%{__make} -C build install \
195f432c 83 DESTDIR=$RPM_BUILD_ROOT
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(644,root,root,755)
2fc92623
RT
93%attr(755,root,root) %{_bindir}/sopranocmd
94%attr(755,root,root) %{_bindir}/sopranod
0b2cd574 95%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 96%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 97%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 98%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 99%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 100%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
101%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
102%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 103%dir %{_libdir}/soprano
0b2cd574 104%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
105%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
106%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
107%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
f7130588 108%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so
dbea7b1e 109%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 110%{_datadir}/soprano
2fc92623
RT
111%dir %{_datadir}/dbus-1/interfaces
112%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
113%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
114%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
115%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
116%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
117
195f432c 118%files devel
119%defattr(644,root,root,755)
0b2cd574 120%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
121%attr(755,root,root) %{_libdir}/libsopranoserver.so
122%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 123%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 124%dir %{_includedir}/soprano
125%{_includedir}/soprano/*.h
2fc92623 126%{_includedir}/Soprano
5b9e452e 127%{_pkgconfigdir}/soprano.pc
This page took 0.090029 seconds and 4 git commands to generate.