]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- useless BRs
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
c7018ab4 9
855ec3f8 10%define qtbrver 4.4.0
11
8667f3ab
JB
12Summary: Soprano - Qt wrapper API to librdf
13Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 14Name: soprano
b8b187e8 15Version: 2.0.98
435be701 16Release: 2
5b9e452e 17License: GPL v2
195f432c 18Group: X11/Applications
16082c87
BZ
19Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
20# Source0-md5: fcaf461dded797445264d809df3257b5
5a8ef18c 21URL: http://sourceforge.net/projects/soprano
855ec3f8 22BuildRequires: QtCore-devel >= %{qtbrver}
23BuildRequires: QtDBus-devel >= %{qtbrver}
24BuildRequires: QtNetwork-devel >= %{qtbrver}
25BuildRequires: QtTest-devel >= %{qtbrver}
2b1fcc2c 26BuildRequires: clucene-core-devel >= 0.9.16a-2
195f432c 27BuildRequires: cmake
81788912 28%if %{with sesame2}
435be701 29BuildRequires: libgcj-devel
81788912 30%endif
31%{?with_serializer:BuildRequires: libraptor-devel}
855ec3f8 32BuildRequires: qt4-build >= %{qtbrver}
33BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e
ER
34BuildRequires: rasqal-devel
35BuildRequires: redland-devel >= 1.0.6
a234d6d7 36BuildRequires: rpmbuild(macros) >= 1.293
195f432c 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
8667f3ab
JB
40Soprano (formally known as QRDF) is a library which provides a Qt
41wrapper API to different RDF storage solutions. It features named
42graphs (contexts) and has a modular plug-in structure which allows to
43use different RDF storage implementations.
195f432c 44
8667f3ab
JB
45%description -l pl.UTF-8
46Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
47wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
48nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
49pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 50
51%package devel
52Summary: Header files for soprano
53Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58Header files for soprano.
59
60%description devel -l pl.UTF-8
61Pliki nagłówkowe dla soprano.
62
63%prep
a4a085c3 64%setup -q
435be701
PS
65# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
66sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
67# cleanup.
68sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 69
70%build
71install -d build
72cd build
73%cmake \
74 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
0b2cd574 75 -DCMAKE_VERBOSE_MAKEFILE=1 \
5b9e452e 76 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 77%if "%{_lib}" == "lib64"
78 -DLIB_SUFFIX=64 \
79%endif
435be701
PS
80 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%(%{__cc} -dumpversion)/include \
81 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%(%{__cc} -dumpversion)/libjvm.so \
0b2cd574 82 ..
195f432c 83
84%{__make}
85
86%install
87rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
88
89%{__make} -C build install \
195f432c 90 DESTDIR=$RPM_BUILD_ROOT
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96%postun -p /sbin/ldconfig
97
98%files
99%defattr(644,root,root,755)
2fc92623
RT
100%attr(755,root,root) %{_bindir}/sopranocmd
101%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 102%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 103%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 104%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 105%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 106%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 107%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 108%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
109%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
110%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 111%dir %{_libdir}/soprano
0b2cd574 112%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
113%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
114%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
115%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
81788912 116%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
dbea7b1e 117%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 118%{_datadir}/soprano
2fc92623
RT
119%dir %{_datadir}/dbus-1/interfaces
120%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
121%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
122%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
123%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
124%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
125
195f432c 126%files devel
127%defattr(644,root,root,755)
0b2cd574 128%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
129%attr(755,root,root) %{_libdir}/libsopranoserver.so
130%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 131%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 132%dir %{_includedir}/soprano
133%{_includedir}/soprano/*.h
2fc92623 134%{_includedir}/Soprano
5b9e452e 135%{_pkgconfigdir}/soprano.pc
This page took 0.154615 seconds and 4 git commands to generate.