]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- BR: QtGui-devel, xorg-lib-libX11-devel, xorg-lib-libXext-devel
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
e8d4b674 9%bcond_without virtuoso # with virtuosobackend
c7018ab4 10
e8d4b674 11%define qtbrver 4.6.1
12%define snap svn1042011
855ec3f8 13
8667f3ab
JB
14Summary: Soprano - Qt wrapper API to librdf
15Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 16Name: soprano
e8d4b674 17Version: 2.4.0.1
ae3009f4 18Release: 1
5b9e452e 19License: GPL v2
195f432c 20Group: X11/Applications
ae3009f4 21Source0: http://downloads.sourceforge.net/sourceforge/soprano/%{name}-%{version}.tar.bz2
e8d4b674 22# Source0-md5: 6175a3b342a77a7adc6f157cf4968f6d
23#Source0: %{name}-%{version}-%{snap}.tar.gz
5a8ef18c 24URL: http://sourceforge.net/projects/soprano
855ec3f8 25BuildRequires: QtCore-devel >= %{qtbrver}
26BuildRequires: QtDBus-devel >= %{qtbrver}
2ba17820 27BuildRequires: QtGui-devel >= %{qtbrver}
855ec3f8 28BuildRequires: QtNetwork-devel >= %{qtbrver}
2b1fcc2c 29BuildRequires: clucene-core-devel >= 0.9.16a-2
84df784d 30BuildRequires: cmake >= 2.6.2
31%{?with_sesame2:BuildRequires: libgcj-devel}
81788912 32%{?with_serializer:BuildRequires: libraptor-devel}
855ec3f8 33BuildRequires: qt4-build >= %{qtbrver}
34BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e
ER
35BuildRequires: rasqal-devel
36BuildRequires: redland-devel >= 1.0.6
84df784d 37BuildRequires: rpmbuild(macros) >= 1.453
2ba17820 38BuildRequires: xorg-lib-libX11-devel
39BuildRequires: xorg-lib-libXext-devel
e8d4b674 40%if %{with virtuoso}
41BuildRequires: libiodbc-devel
42Requires: virtuoso >= 6.1.0
43%endif
195f432c 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
8667f3ab
JB
47Soprano (formally known as QRDF) is a library which provides a Qt
48wrapper API to different RDF storage solutions. It features named
49graphs (contexts) and has a modular plug-in structure which allows to
50use different RDF storage implementations.
195f432c 51
8667f3ab 52%description -l pl.UTF-8
2ba17820 53Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
54wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
55nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
56pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 57
58%package devel
59Summary: Header files for soprano
60Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description devel
65Header files for soprano.
66
67%description devel -l pl.UTF-8
68Pliki nagłówkowe dla soprano.
69
70%prep
a4a085c3 71%setup -q
435be701 72# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 73#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 74# cleanup.
84df784d 75#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 76
77%build
78install -d build
79cd build
84df784d 80# add this to get verbose output
81# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 82%cmake \
83 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
5b9e452e 84 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 85%if "%{_lib}" == "lib64"
86 -DLIB_SUFFIX=64 \
87%endif
84df784d 88 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
89 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
2ba17820 90%if "%{pld_release}" == "ti"
ad66f649 91 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-9/libjvm.so \
ae3009f4 92%else
d9b07975 93 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-10/libjvm.so \
ae3009f4 94%endif
84df784d 95 ../
195f432c 96
97%{__make}
98
99%install
100rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
101
102%{__make} -C build install \
195f432c 103 DESTDIR=$RPM_BUILD_ROOT
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%files
112%defattr(644,root,root,755)
2fc92623
RT
113%attr(755,root,root) %{_bindir}/sopranocmd
114%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 115%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 116%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 117%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 118%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 119%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 120%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 121%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
122%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 124%dir %{_libdir}/soprano
0b2cd574 125%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
126%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
127%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
128%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
c4571e50 129%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
130%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
e8d4b674 131%{?with_virtuoso:%attr(755,root,root) %{_libdir}/soprano/libsoprano_virtuosobackend.so}
5b9e452e 132%{_datadir}/soprano
2fc92623
RT
133%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
134%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
135%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
136%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
137%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
138
195f432c 139%files devel
140%defattr(644,root,root,755)
0b2cd574 141%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
142%attr(755,root,root) %{_libdir}/libsopranoserver.so
143%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 144%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 145%dir %{_includedir}/soprano
146%{_includedir}/soprano/*.h
2fc92623 147%{_includedir}/Soprano
5b9e452e 148%{_pkgconfigdir}/soprano.pc
This page took 0.078584 seconds and 4 git commands to generate.