]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- reverted bogus BRs
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
c7018ab4 8
8667f3ab
JB
9Summary: Soprano - Qt wrapper API to librdf
10Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 11Name: soprano
c7018ab4 12Version: 2.0.0
3d311b00 13Release: 2
c7018ab4 14#Release: 0.%{_snap}.%{rel}
5b9e452e 15License: GPL v2
195f432c 16Group: X11/Applications
c7018ab4
SP
17Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
18# Source0-md5: 597d83ac793fff2ddbd628eb05d31624
5a8ef18c 19URL: http://sourceforge.net/projects/soprano
a2b662ab 20BuildRequires: QtDBus-devel
dbea7b1e
ER
21BuildRequires: QtNetwork-devel
22BuildRequires: QtTest-devel
195f432c 23BuildRequires: autoconf
24BuildRequires: automake
2b1fcc2c 25BuildRequires: clucene-core-devel >= 0.9.16a-2
195f432c 26BuildRequires: cmake
dbea7b1e 27BuildRequires: libraptor-devel
5b9e452e
JB
28BuildRequires: qt4-build >= 4.3.3-3
29BuildRequires: qt4-qmake >= 4.3.3-3
dbea7b1e
ER
30BuildRequires: rasqal-devel
31BuildRequires: redland-devel >= 1.0.6
a234d6d7 32BuildRequires: rpmbuild(macros) >= 1.293
195f432c 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
8667f3ab
JB
36Soprano (formally known as QRDF) is a library which provides a Qt
37wrapper API to different RDF storage solutions. It features named
38graphs (contexts) and has a modular plug-in structure which allows to
39use different RDF storage implementations.
195f432c 40
8667f3ab
JB
41%description -l pl.UTF-8
42Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
43wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
44nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
45pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 46
47%package devel
48Summary: Header files for soprano
49Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description devel
54Header files for soprano.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe dla soprano.
58
59%prep
c7018ab4 60%setup -q
195f432c 61
62%build
63install -d build
64cd build
65%cmake \
66 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
0b2cd574 67 -DCMAKE_VERBOSE_MAKEFILE=1 \
5b9e452e 68 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 69%if "%{_lib}" == "lib64"
70 -DLIB_SUFFIX=64 \
71%endif
0b2cd574 72 ..
195f432c 73
74%{__make}
75
76%install
77rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
78
79%{__make} -C build install \
195f432c 80 DESTDIR=$RPM_BUILD_ROOT
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -p /sbin/ldconfig
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(644,root,root,755)
2fc92623
RT
90%attr(755,root,root) %{_bindir}/sopranocmd
91%attr(755,root,root) %{_bindir}/sopranod
0b2cd574 92%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 93%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 94%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 95%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 96%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 97%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
98%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
99%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 100%dir %{_libdir}/soprano
0b2cd574 101%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
102%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
103%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
104%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
dbea7b1e 105%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 106%{_datadir}/soprano
2fc92623
RT
107%dir %{_datadir}/dbus-1/interfaces
108%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
109%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
110%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
111%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
112%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
113
195f432c 114%files devel
115%defattr(644,root,root,755)
0b2cd574 116%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
117%attr(755,root,root) %{_libdir}/libsopranoserver.so
118%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 119%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 120%dir %{_includedir}/soprano
121%{_includedir}/soprano/*.h
2fc92623 122%{_includedir}/Soprano
5b9e452e 123%{_pkgconfigdir}/soprano.pc
This page took 0.044838 seconds and 4 git commands to generate.