]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- obsolete
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
c7018ab4 8
8667f3ab
JB
9Summary: Soprano - Qt wrapper API to librdf
10Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 11Name: soprano
3dd5cf66 12Version: 2.0.97
13Release: 0.svn79103.1
5b9e452e 14License: GPL v2
195f432c 15Group: X11/Applications
3dd5cf66 16#Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
17Source0: %{name}-%{version}.tar.gz
18# Source0-md5: decd129682d1cfaacc0033ba47ba7467
5a8ef18c 19URL: http://sourceforge.net/projects/soprano
ab49304e 20BuildRequires: QtCore-devel
a2b662ab 21BuildRequires: QtDBus-devel
dbea7b1e
ER
22BuildRequires: QtNetwork-devel
23BuildRequires: QtTest-devel
195f432c 24BuildRequires: autoconf
25BuildRequires: automake
2b1fcc2c 26BuildRequires: clucene-core-devel >= 0.9.16a-2
195f432c 27BuildRequires: cmake
dbea7b1e 28BuildRequires: libraptor-devel
5b9e452e
JB
29BuildRequires: qt4-build >= 4.3.3-3
30BuildRequires: qt4-qmake >= 4.3.3-3
dbea7b1e
ER
31BuildRequires: rasqal-devel
32BuildRequires: redland-devel >= 1.0.6
a234d6d7 33BuildRequires: rpmbuild(macros) >= 1.293
195f432c 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
8667f3ab
JB
37Soprano (formally known as QRDF) is a library which provides a Qt
38wrapper API to different RDF storage solutions. It features named
39graphs (contexts) and has a modular plug-in structure which allows to
40use different RDF storage implementations.
195f432c 41
8667f3ab
JB
42%description -l pl.UTF-8
43Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
44wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
45nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
46pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 47
48%package devel
49Summary: Header files for soprano
50Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55Header files for soprano.
56
57%description devel -l pl.UTF-8
58Pliki nagłówkowe dla soprano.
59
60%prep
c7018ab4 61%setup -q
195f432c 62
63%build
64install -d build
65cd build
66%cmake \
67 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
0b2cd574 68 -DCMAKE_VERBOSE_MAKEFILE=1 \
5b9e452e 69 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 70%if "%{_lib}" == "lib64"
71 -DLIB_SUFFIX=64 \
72%endif
0b2cd574 73 ..
195f432c 74
75%{__make}
76
77%install
78rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
79
80%{__make} -C build install \
195f432c 81 DESTDIR=$RPM_BUILD_ROOT
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
88
89%files
90%defattr(644,root,root,755)
2fc92623
RT
91%attr(755,root,root) %{_bindir}/sopranocmd
92%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 93%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 94%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 95%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 96%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 97%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 98%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 99%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
100%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
101%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 102%dir %{_libdir}/soprano
0b2cd574 103%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
104%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
105%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
106%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
f7130588 107%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so
dbea7b1e 108%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 109%{_datadir}/soprano
2fc92623
RT
110%dir %{_datadir}/dbus-1/interfaces
111%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
112%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
113%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
114%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
115%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
116
195f432c 117%files devel
118%defattr(644,root,root,755)
0b2cd574 119%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
120%attr(755,root,root) %{_libdir}/libsopranoserver.so
121%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 122%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 123%dir %{_includedir}/soprano
124%{_includedir}/soprano/*.h
2fc92623 125%{_includedir}/Soprano
5b9e452e 126%{_pkgconfigdir}/soprano.pc
This page took 0.050905 seconds and 4 git commands to generate.