]> git.pld-linux.org Git - packages/setup.git/blame - setup.spec
- fix multilib build
[packages/setup.git] / setup.spec
CommitLineData
86056b15 1#
bf515c7b
PG
2# TODO:
3# - make some README.PLD with system features description
86056b15 4#
96b2deb2 5%define iana_etc_ver 1.04
33031197 6%undefine with_ccache
0b6becf4 7#
f97bd99d 8Summary: Simple setup files
8551200d
ER
9Summary(de.UTF-8): Einfache Setup-Dateien
10Summary(es.UTF-8): Varios archivos básicos de configuración
11Summary(fr.UTF-8): Fichiers de configuration simples
12Summary(ja.UTF-8): サンプルセットアップファイル
13Summary(pl.UTF-8): Podstawowe pliki systemu Linux
14Summary(pt_BR.UTF-8): Vários arquivos básicos de configuração
15Summary(tr.UTF-8): Basit kurulum dosyaları
f97bd99d 16Name: setup
a2b3dd01 17Version: 2.4.10
51afe82b 18Release: 4
bf515c7b 19License: Public Domain, partially BSD-like
f97bd99d 20Group: Base
a2b3dd01 21Source0: ftp://distfiles.pld-linux.org/src/%{name}-%{version}.tar.bz2
22# Source0-md5: 7f50f1650e961a77b18afa0a4a588fc1
0b6becf4 23Source1: http://www.sethwklein.net/projects/iana-etc/downloads/iana-etc-%{iana_etc_ver}.tar.bz2
96b2deb2 24# Source1-md5: 9f769f7b2d0e519cf62dacb2b3b051d4
7cf4e42c 25Source2: %{name}-update-fstab.c
47f42bc8 26Source3: postshell.c
e73e012d
PG
27# This is source of non-iana changes in services file
28#Patch0: %{name}-services.patch
a6928fbf 29Patch0: %{name}-securetty.patch
33031197 30Patch1: %{name}-profile.env.patch
fe293510 31BuildRequires: dietlibc-static
36832d85 32BuildRequires: gawk
e23f948a 33Conflicts: FHS < 2.3
ee80b4de 34Conflicts: glibc < 6:2.4-4.1
c14440b1 35AutoReqProv: no
50ba189c 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6be1ce2e 37
3d5c2a8f
PG
38%define _sbindir /sbin
39
6be1ce2e 40%description
7a8444bd
SZ
41This package contains a number of very important configuration and
42setup files, including the passwd, group, profile files, etc.
6be1ce2e 43
2f487416
JR
44%description -l de.UTF-8
45Dieses Paket enthält wichtige Konfigurations- und Setup-Dateien, u.a.
a9f190e7 46passwd-, group-, profile-Dateien usw.
6be1ce2e 47
2f487416
JR
48%description -l es.UTF-8
49Este paquete contiene una variedad de archivos de configuración y
05f14211
TP
50setup muy importantes, incluyendo el passwd, group, archivos de
51"perfil", etc.
52
2f487416
JR
53%description -l fr.UTF-8
54Ce paquetage contient un nombre de fichiers de configuration très
6be1ce2e 55importants, comme passwd, group, les fichiers profile, etc.
56
2f487416
JR
57%description -l ja.UTF-8
58このsetupパッケージには、passwd, group, profile などの、
59重要なシステム設定ファイルが含まれてます。
05f14211 60
2f487416
JR
61%description -l pl.UTF-8
62Pakiet ten zawiera wiele bardzo ważnych plików konfiguracyjnych dla
a6f7ca8d 63Twojego systemu.
87946706 64
2f487416
JR
65%description -l pt_BR.UTF-8
66Este pacote contém uma variedade de arquivos de configuração e setup
ea4c6647
JB
67muito importantes, incluindo o passwd, group, arquivos de "perfil",
68etc.
d0944bc6 69
2f487416
JR
70%description -l tr.UTF-8
71Bu paket, passwd, group, profile gibi çok önemli ayar ve kurulum
72dosyalarını içerir.
d0944bc6 73
6be1ce2e 74%prep
0b6becf4 75%setup -q -a1
a6928fbf 76%patch0 -p1
33031197 77%patch1 -p1
7cf4e42c 78install %{SOURCE2} update-fstab.c
47f42bc8 79install %{SOURCE3} postshell.c
bf515c7b
PG
80
81%build
36832d85 82%{__make} -C iana-etc-%{iana_etc_ver}
0b6becf4 83
bf515c7b 84%{__make} \
c1e81666 85 OPT_FLAGS="%{rpmcflags}" \
d3b7c683 86 LDFLAGS="%{rpmcflags} %{rpmldflags}" \
fe293510 87 CC="diet %{__cc}"
47f42bc8 88%{__make} postshell update-fstab \
89 OPT_FLAGS="%{rpmcflags} -Os" \
d3b7c683 90 LDFLAGS="%{rpmcflags} %{rpmldflags}" \
7cf4e42c 91 CC="diet %{__cc}"
6be1ce2e 92
93%install
797d0215 94rm -rf $RPM_BUILD_ROOT
93f8153d 95install -d $RPM_BUILD_ROOT%{_sysconfdir}/shrc.d
0b6becf4 96
bf515c7b
PG
97%{__make} install \
98 DESTDIR=$RPM_BUILD_ROOT
0b6becf4 99
47f42bc8 100install postshell $RPM_BUILD_ROOT%{_sbindir}
7cf4e42c 101install update-fstab $RPM_BUILD_ROOT%{_sbindir}
102
9310ed4f 103install iana-etc-%{iana_etc_ver}/protocols $RPM_BUILD_ROOT%{_sysconfdir}/protocols
e73e012d 104# don't overwrite files from setup tar-ball, fix it in original tar!
9310ed4f 105#install iana-etc-%{iana_etc_ver}/services $RPM_BUILD_ROOT%{_sysconfdir}/services
0b6becf4 106
6be1ce2e 107%clean
797d0215 108rm -rf $RPM_BUILD_ROOT
6be1ce2e 109
50ba189c 110%triggerpostun -p %{_sbindir}/joinpasswd -- %{name} < %{version}-%{release}
81b992a1 111
7cf4e42c 112%triggerin -p %{_sbindir}/update-fstab -- %{name} < 2.4.10-1
a2b3dd01 113
544edbb0
ER
114%post -p /sbin/postshell
115-/sbin/env-update -u
116
117%postun -p /sbin/postshell
118-/sbin/env-update -u
119
6be1ce2e 120%files
f97bd99d 121%defattr(644,root,root,755)
bf515c7b
PG
122%doc ChangeLog
123%attr(755,root,root) %{_sbindir}/joinpasswd
47f42bc8 124%attr(755,root,root) %{_sbindir}/postshell
7cf4e42c 125%attr(755,root,root) %{_sbindir}/update-fstab
c6c53392 126%attr(755,root,root) /etc/profile.d/*.sh
127%attr(755,root,root) /etc/profile.d/*.csh
bf515c7b 128%dir /etc/profile.d
9310ed4f 129%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/*
4db3fb34 130%dir %{_sysconfdir}/env.d
131%dir %{_sysconfdir}/shrc.d
9310ed4f
ER
132%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fstab
133%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/group
134%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/host.conf
135%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hosts
136%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/passwd
137%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/profile
138%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/protocols
9b899961 139%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/secure*
9310ed4f
ER
140%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/services
141%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/filesystems
142%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/motd
143%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/resolv.conf
bf515c7b 144%ghost %{_sysconfdir}/shells
This page took 0.109772 seconds and 4 git commands to generate.