]> git.pld-linux.org Git - packages/ruby-gherkin.git/blame - ruby-gherkin.spec
- x32 rebuild
[packages/ruby-gherkin.git] / ruby-gherkin.spec
CommitLineData
2ae99a3f
ER
1%define pkgname gherkin
2Summary: Fast Gherkin lexer/parser
3Name: ruby-%{pkgname}
4Version: 2.11.6
4fa377c2 5Release: 3
2ae99a3f
ER
6License: MIT
7Group: Development/Languages
8Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9# Source0-md5: 91a79a6a4fe03f51f039f7006581c468
10URL: http://github.com/cucumber/gherkin
11BuildRequires: rpm-rubyprov
12BuildRequires: rpmbuild(macros) >= 1.656
d46fa031 13BuildRequires: ruby-devel
2ae99a3f
ER
14# .gemspec requires 1.7.5, but we have only 1.5.5 with ruby 1.9
15Requires: ruby-json
2ae99a3f
ER
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19A fast Gherkin lexer/parser based on the Ragel State Machine Compiler.
20
21%prep
22%setup -q -n %{pkgname}-%{version}
23
d46fa031
ER
24%build
25for lexer_dir in ext/%{pkgname}_lexer_*; do
26 cd $lexer_dir
27 ruby extconf.rb
28 %{__make} V=1 \
29 CC="%{__cc}" \
30 LDFLAGS="%{rpmldflags}" \
31 CFLAGS="%{rpmcflags} -fPIC"
32 cd -
33done
34
2ae99a3f
ER
35%install
36rm -rf $RPM_BUILD_ROOT
d46fa031 37install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_vendorarchdir}}
2ae99a3f
ER
38cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
39
d46fa031
ER
40find ext -name '*.so' -exec install -p {} $RPM_BUILD_ROOT%{ruby_vendorarchdir} ';'
41
2ae99a3f
ER
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%files
46%defattr(644,root,root,755)
47%{ruby_vendorlibdir}/%{pkgname}.rb
48%{ruby_vendorlibdir}/%{pkgname}
d46fa031
ER
49%lang(ar) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_ar.so
50%lang(bg) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_bg.so
51%lang(bm) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_bm.so
52%lang(ca) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_ca.so
53%lang(cs) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_cs.so
54%lang(cy_GB) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_cy_gb.so
55%lang(da) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_da.so
56%lang(de) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_de.so
57%lang(en) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_en.so
58%lang(en) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_en_lol.so
59%lang(en) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_en_pirate.so
60%lang(en) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_en_scouse.so
61%lang(en) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_en_tx.so
62%lang(en_AU) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_en_au.so
63%lang(eo) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_eo.so
64%lang(es) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_es.so
65%lang(et) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_et.so
66%lang(fa) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_fa.so
67%lang(fi) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_fi.so
68%lang(fr) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_fr.so
69%lang(he) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_he.so
70%lang(hi) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_hi.so
71%lang(hr) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_hr.so
72%lang(hu) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_hu.so
73%lang(id) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_id.so
74%lang(is) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_is.so
75%lang(it) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_it.so
76%lang(ja) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_ja.so
77%lang(ko) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_ko.so
78%lang(lt) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_lt.so
79%lang(lu) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_lu.so
80%lang(lv) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_lv.so
81%lang(nl) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_nl.so
82%lang(no) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_no.so
83%lang(pl) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_pl.so
84%lang(pt) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_pt.so
85%lang(ro) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_ro.so
86%lang(ru) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_ru.so
87%lang(sk) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_sk.so
88%lang(sr@cyrillic) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_sr_cyrl.so
89%lang(sr@latin) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_sr_latn.so
90%lang(sv) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_sv.so
91%lang(tl) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_tl.so
92%lang(tr) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_tr.so
93%lang(tt) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_tt.so
94%lang(uk) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_uk.so
95%lang(uz) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_uz.so
96%lang(vi) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_vi.so
97%lang(zh_CN) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_zh_cn.so
98%lang(zh_TW) %attr(755,root,root) %{ruby_vendorarchdir}/gherkin_lexer_zh_tw.so
This page took 0.05936 seconds and 4 git commands to generate.