]> git.pld-linux.org Git - packages/rubocop.git/blame - rubocop.spec
- release 4 (by relup.sh)
[packages/rubocop.git] / rubocop.spec
CommitLineData
f9adf763
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5Summary: A robust Ruby code analyzer, based on the community Ruby style guide
6Name: rubocop
f441e627
JR
7# NOTE: check chefstyle -> ohai reqs before updating
8Version: 0.55.0
c4d76604 9Release: 4
f9adf763
ER
10License: MIT
11Group: Development/Languages
12Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
f441e627 13# Source0-md5: d6c0d5172db7d5c98ff5959b38e4e55a
f9adf763
ER
14Patch0: rpmpath.patch
15URL: http://github.com/bbatsov/rubocop
16BuildRequires: rpm-rubyprov
17BuildRequires: rpmbuild(macros) >= 1.656
18BuildRequires: sed >= 4.0
19%if %{with tests}
20BuildRequires: ruby-bundler < 2
21BuildRequires: ruby-bundler >= 1.3
22BuildRequires: ruby-rake < 11
23BuildRequires: ruby-rake >= 10.1
24BuildRequires: ruby-rspec < 3
25BuildRequires: ruby-rspec >= 2.14
26BuildRequires: ruby-simplecov < 1
27BuildRequires: ruby-simplecov >= 0.7
28BuildRequires: ruby-yard < 1
29BuildRequires: ruby-yard >= 0.8
30%endif
f441e627
JR
31Requires: ruby-parallel < 2.0
32Requires: ruby-parallel >= 1.10
33Requires: ruby-parser >= 2.5
34Requires: ruby-powerpack < 1
35Requires: ruby-powerpack >= 0.1
36Requires: ruby-progressbar < 2
37Requires: ruby-progressbar >= 1.7
f441e627
JR
38Requires: ruby-rainbow >= 2.2.2
39Requires: ruby-unicode-display_width < 2
40Requires: ruby-unicode-display_width >= 1.0.1
f9adf763
ER
41BuildArch: noarch
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45Automatic Ruby code style checking tool. Aims to enforce the
46community-driven Ruby Style Guide.
47
48%prep
49%setup -q
50%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
51%patch0 -p1
52
53%install
54rm -rf $RPM_BUILD_ROOT
55install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
56cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
57cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
58cp -a config $RPM_BUILD_ROOT%{ruby_vendorlibdir}/%{name}
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(644,root,root,755)
65%attr(755,root,root) %{_bindir}/rubocop
66%{ruby_vendorlibdir}/%{name}.rb
67%{ruby_vendorlibdir}/%{name}
This page took 0.053347 seconds and 4 git commands to generate.