]> git.pld-linux.org Git - packages/rubocop.git/blame - rubocop.spec
- rebuild with ruby 2.4
[packages/rubocop.git] / rubocop.spec
CommitLineData
f9adf763
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5Summary: A robust Ruby code analyzer, based on the community Ruby style guide
6Name: rubocop
7Version: 0.18.1
2c952545 8Release: 3
f9adf763
ER
9License: MIT
10Group: Development/Languages
11Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
12# Source0-md5: a265af5e5e3272e03c854b3c1635770c
13Patch0: rpmpath.patch
14URL: http://github.com/bbatsov/rubocop
15BuildRequires: rpm-rubyprov
16BuildRequires: rpmbuild(macros) >= 1.656
17BuildRequires: sed >= 4.0
18%if %{with tests}
19BuildRequires: ruby-bundler < 2
20BuildRequires: ruby-bundler >= 1.3
21BuildRequires: ruby-rake < 11
22BuildRequires: ruby-rake >= 10.1
23BuildRequires: ruby-rspec < 3
24BuildRequires: ruby-rspec >= 2.14
25BuildRequires: ruby-simplecov < 1
26BuildRequires: ruby-simplecov >= 0.7
27BuildRequires: ruby-yard < 1
28BuildRequires: ruby-yard >= 0.8
29%endif
30Requires: ruby-json < 2
31Requires: ruby-json >= 1.7.7
32Requires: ruby-parser < 2.2
33Requires: ruby-parser >= 2.1.3
34Requires: ruby-powerpack < 0.1
35Requires: ruby-powerpack >= 0.0.6
36Requires: ruby-rainbow < 3.0
37Requires: ruby-rainbow >= 1.99.1
38BuildArch: noarch
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Automatic Ruby code style checking tool. Aims to enforce the
43community-driven Ruby Style Guide.
44
45%prep
46%setup -q
47%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
48%patch0 -p1
49
50%install
51rm -rf $RPM_BUILD_ROOT
52install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
53cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
54cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
55cp -a config $RPM_BUILD_ROOT%{ruby_vendorlibdir}/%{name}
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%attr(755,root,root) %{_bindir}/rubocop
63%{ruby_vendorlibdir}/%{name}.rb
64%{ruby_vendorlibdir}/%{name}
This page took 0.079911 seconds and 4 git commands to generate.