]> git.pld-linux.org Git - packages/rabbitmq-c.git/blame - rabbitmq-c.spec
- updated to 0.8.0
[packages/rabbitmq-c.git] / rabbitmq-c.spec
CommitLineData
9730ef10
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
5Summary: RabbitMQ C AMQP client library
6Summary(pl.UTF-8): Biblioteka kliencka C RabbitMQ AMQP
7Name: rabbitmq-c
8927dd6d 8Version: 0.8.0
9730ef10
JB
9Release: 1
10License: MIT
11Group: Libraries
12#Source0Download: https://github.com/alanxz/rabbitmq-c
8927dd6d
JB
13Source0: https://github.com/alanxz/rabbitmq-c/releases/download/v%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: c15dbcd2dbb8e254c1de0494c1bb8c91
9730ef10
JB
15URL: https://github.com/alanxz/rabbitmq-c
16BuildRequires: autoconf >= 2.59
17BuildRequires: automake >= 1:1.9
18BuildRequires: libtool >= 2:2.2
93aca067
JB
19BuildRequires: openssl-devel >= 0.9.8
20BuildRequires: popt-devel
21BuildRequires: pkgconfig >= 1:0.17
9730ef10 22BuildRequires: xmlto
93aca067 23Requires: openssl >= 0.9.8
9730ef10
JB
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27This is a C-language AMQP client library for use with AMQP servers
28speaking protocol versions 0-9-1.
29
30%description -l pl.UTF-8
31Ten pakiet zawiera bibliotekę kliencką AMQP dla języka C, przeznaczoną
32do użycia z serwerami AMQP obsługującymi protokół w wersjach 0-9-1.
33
34%package devel
35Summary: Header files for rabbitmq-c library
36Summary(pl.UTF-8): Pliki nagłówkowe biblioteki rabbitmq-c
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
93aca067 39Requires: openssl-devel >= 0.9.8
9730ef10
JB
40
41%description devel
42Header files for rabbitmq-c library.
43
44%description devel -l pl.UTF-8
45Pliki nagłówkowe biblioteki rabbitmq-c.
46
47%package static
48Summary: Static rabbitmq-c library
49Summary(pl.UTF-8): Statyczna biblioteka rabbitmq-c
50Group: Development/Libraries
51Requires: %{name}-devel = %{version}-%{release}
52
53%description static
54Static rabbitmq-c library.
55
56%description static -l pl.UTF-8
57Statyczna biblioteka rabbitmq-c.
58
59%package tools
60Summary: Example tools utilizing the rabbitmq-c library
61Summary(pl.UTF-8): Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c
62Group: Applications
63Requires: %{name} = %{version}-%{release}
64
65%description tools
66Example tools utilizing the rabbitmq-c library.
67
68%description tools -l pl.UTF-8
69Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c.
70
71%prep
93aca067 72%setup -q
9730ef10
JB
73
74%build
75%{__libtoolize}
76%{__aclocal} -I m4
77%{__autoconf}
78%{__autoheader}
79%{__automake}
80%configure \
81 --disable-silent-rules \
82 %{?with_static_libs:--enable-static}
83%{__make}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT
90
91# obsoleted by pkg-config
92%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98%postun -p /sbin/ldconfig
99
100%files
101%defattr(644,root,root,755)
102%doc AUTHORS CONTRIBUTING.md LICENSE-MIT README.md THANKS TODO
103%attr(755,root,root) %{_libdir}/librabbitmq.so.*.*.*
93aca067 104%attr(755,root,root) %ghost %{_libdir}/librabbitmq.so.4
9730ef10
JB
105
106%files devel
107%defattr(644,root,root,755)
108%attr(755,root,root) %{_libdir}/librabbitmq.so
109%{_includedir}/amqp.h
110%{_includedir}/amqp_framing.h
93aca067
JB
111%{_includedir}/amqp_ssl_socket.h
112%{_includedir}/amqp_tcp_socket.h
9730ef10
JB
113%{_pkgconfigdir}/librabbitmq.pc
114
115%if %{with static_libs}
116%files static
117%defattr(644,root,root,755)
118%{_libdir}/librabbitmq.a
119%endif
120
121%files tools
122%defattr(644,root,root,755)
123%attr(755,root,root) %{_bindir}/amqp-consume
124%attr(755,root,root) %{_bindir}/amqp-declare-queue
125%attr(755,root,root) %{_bindir}/amqp-delete-queue
126%attr(755,root,root) %{_bindir}/amqp-get
127%attr(755,root,root) %{_bindir}/amqp-publish
128%{_mandir}/man1/amqp-consume.1*
129%{_mandir}/man1/amqp-declare-queue.1*
130%{_mandir}/man1/amqp-delete-queue.1*
131%{_mandir}/man1/amqp-get.1*
132%{_mandir}/man1/amqp-publish.1*
133%{_mandir}/man7/librabbitmq-tools.7*
This page took 0.130124 seconds and 4 git commands to generate.