]> git.pld-linux.org Git - packages/python3-setuptools.git/blame - python3-setuptools.spec
- up to 62.0.0
[packages/python3-setuptools.git] / python3-setuptools.spec
CommitLineData
2f649423
MK
1#
2# Conditional build:
300f73bb 3%bcond_with apidocs # Sphinx based documentation
828f076c 4%bcond_with system_libs # use system modules (appdirs, packaging, pyparsing) # TODO
6502ae9a 5%bcond_with tests # py.test tests (few failures)
744badc2 6%bcond_with bootstrap # convenience alias for without: apidocs,system_libs,tests
25fb9ea9 7
744badc2
JB
8%if %{with bootstrap}
9%undefine with_apidocs
10%undefine with_system_libs
11%undefine with_tests
12%endif
2f649423 13
744badc2 14%define module setuptools
9fded6eb 15%define pypi_name setuptools
b79e62bc 16Summary: A collection of enhancements to the Python distutils
e4a6c4e2 17Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
34676580 18Name: python3-setuptools
a57a3e11
JR
19Version: 62.0.0
20Release: 0.1
67093d8e 21Epoch: 1
744badc2 22License: MIT
b79e62bc 23Group: Development/Languages/Python
744badc2 24#Source0Download: https://pypi.org/simple/setuptools/
a57a3e11
JR
25Source0: https://github.com/pypa/setuptools/archive/v%{version}/%{pypi_name}-%{version}.tar.gz
26# Source0-md5: 7f932b83c8c74751a2f1e60cd569189b
828f076c 27Patch0: setuptools-missing.patch
1ca207b5 28URL: https://github.com/pypa/setuptools
744badc2 29%if %(locale -a | grep -q '^C\.utf8$'; echo $?)
c034c756
JB
30BuildRequires: glibc-localedb-all
31%endif
828f076c 32BuildRequires: python3-modules >= 1:3.6
744badc2
JB
33%if %{with system_libs}
34# versions from pkg_resources/_vendor/vendored.txt
35BuildRequires: python3-appdirs >= 1.4.3
828f076c 36BuildRequires: python3-packaging >= 20.4
744badc2 37BuildRequires: python3-pyparsing >= 2.2.1
744badc2 38%endif
b6cbc91d 39BuildConflicts: python3-distribute < 0.7
e2cd79ed 40%if %{with tests}
828f076c 41BuildRequires: python3-Sphinx
744badc2 42BuildRequires: python3-coverage >= 4.5.1
828f076c
JB
43BuildRequires: python3-flake8-2020
44BuildRequires: python3-jaraco.envs
45BuildRequires: python3-jaraco.path >= 3.2.0
744badc2
JB
46# FIXME: patch to use unittest.mock
47#BuildRequires: python3-mock
744badc2 48BuildRequires: python3-paver
403a922f 49BuildRequires: python3-pip >= 19.1
828f076c
JB
50BuildRequires: python3-pytest >= 4.6
51BuildRequires: python3-pytest-black >= 0.3.7
52BuildRequires: python3-pytest-checkdocs >= 2.4
744badc2 53BuildRequires: python3-pytest-cov >= 2.5.1
828f076c 54BuildRequires: python3-pytest-enabler >= 1.0.1
6502ae9a 55BuildRequires: python3-pytest-flake8
828f076c 56BuildRequires: python3-pytest-mypy
744badc2 57BuildRequires: python3-pytest-virtualenv >= 1.2.7
828f076c 58BuildRequires: python3-pytest-xdist
744badc2
JB
59BuildRequires: python3-virtualenv >= 13.0.0
60BuildRequires: python3-wheel
e2cd79ed 61%endif
5c02125b 62%if %{with apidocs}
828f076c 63BuildRequires: python3-Sphinx
a57a3e11 64BuildRequires: python3-furo
be14e546 65BuildRequires: python3-jaraco
828f076c 66BuildRequires: python3-jaraco.packaging >= 8.2
a57a3e11 67BuildRequires: python3-jaraco.tidelift
744badc2 68BuildRequires: python3-rst.linker >= 1.9
828f076c
JB
69# specified but not required(?)
70#BuildRequires: python3-pygments-github-lexers >= 0.0.5
71BuildRequires: python3-setuptools >= 1:34
a57a3e11 72BuildRequires: python3-sphinx_favicon
828f076c 73BuildRequires: python3-sphinx_inline_tabs
a57a3e11
JR
74BuildRequires: python3-sphinxcontrib-towncrier
75BuildRequires: python3-toml
69c5873f 76BuildRequires: python3-wheel
5c02125b 77%endif
20a0801e 78%{!?with_bootstrap:BuildRequires: rpm-pythonprov}
6502ae9a 79BuildRequires: rpmbuild(macros) >= 1.714
6ef7e1f8 80BuildRequires: unzip
828f076c 81Requires: python3-modules >= 1:3.6
744badc2
JB
82%if %{with system_libs}
83# versions from pkg_resources/_vendor/vendored.txt
828f076c
JB
84Requires: python3-appdirs >= 1.4.3
85Requires: python3-packaging >= 20.4
86Requires: python3-pyparsing >= 2.2.1
744badc2 87%endif
b79e62bc
AM
88BuildArch: noarch
89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91%description
92setuptools is a collection of enhancements to the Python distutils
c034c756
JB
93that allow you to more easily build and distribute Python 2.x
94packages, especially ones that have dependencies on other packages.
b79e62bc 95
1c17442b 96%description -l pl.UTF-8
d539774b 97setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
c034c756
JB
98łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
99szczególnie tych mających zależności od innych pakietów.
d539774b
JB
100
101Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
c034c756
JB
102uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
103Pythona 2.x.
eadb908c 104
2f649423
MK
105%package apidocs
106Summary: %{module} API documentation
107Summary(pl.UTF-8): Dokumentacja API %{module}
108Group: Documentation
109
110%description apidocs
111API documentation for %{module}.
112
113%description apidocs -l pl.UTF-8
114Dokumentacja API %{module}.
115
b79e62bc 116%prep
2f649423 117%setup -q -n %{module}-%{version}
828f076c 118%patch0 -p1
b79e62bc 119
744badc2
JB
120%if %{with system_libs}
121exit 1 # TODO: unvendor modules from pkg_resources/_vendor
122%endif
123
b79e62bc 124%build
6502ae9a
JB
125LC_ALL=C.UTF-8 \
126%py3_build
127
128%{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
b79e62bc 129
c034c756 130%if %{with apidocs}
828f076c
JB
131cd docs
132%{__python3} -m sphinx -W . build/html
c034c756
JB
133%endif
134
b79e62bc
AM
135%install
136rm -rf $RPM_BUILD_ROOT
137
a21b5be7 138%py3_install
991fba2b 139
b79e62bc
AM
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%files
144%defattr(644,root,root,755)
744badc2 145%doc CHANGES.rst LICENSE README.rst
6a8a63ea 146%{py3_sitescriptdir}/_distutils_hack
828f076c 147%{py3_sitescriptdir}/distutils-precedence.pth
5c02125b
JB
148%{py3_sitescriptdir}/pkg_resources
149%{py3_sitescriptdir}/setuptools
a57a3e11 150%{py3_sitescriptdir}/%{module}-%{version}*py*.egg-info
2f649423 151
c034c756 152%if %{with apidocs}
2f649423
MK
153%files apidocs
154%defattr(644,root,root,755)
828f076c 155%doc docs/build/html/{_static,deprecated,development,references,userguide,*.html,*.js}
2f649423 156%endif
This page took 0.350007 seconds and 4 git commands to generate.