]> git.pld-linux.org Git - packages/python-sqlite.git/blame - python-sqlite.spec
- tabs in preamble
[packages/python-sqlite.git] / python-sqlite.spec
CommitLineData
b9bee2d9 1
e57f897e 2%define module sqlite
b9bee2d9 3
4Summary: A DB API v2.0 compatible interface to SQLite
1491eeca 5Summary(pl.UTF-8): Interfejs do SQLite kompatybilny z DB API v2.0
b9bee2d9 6Name: python-%{module}
55e1ebe6 7Version: 2.3.2
35026e59 8Release: 2
162b76a5 9License: zlib/libpng
b344ef05 10Group: Development/Languages/Python
55e1ebe6
PZ
11Source0: http://initd.org/pub/software/pysqlite/releases/2.3/%{version}/pysqlite-%{version}.tar.gz
12# Source0-md5: bb9a67d62ff91cd8c53720bd15c86a30
9ffb9c29 13URL: http://www.pysqlite.org/
b9bee2d9 14%pyrequires_eq python-modules
32c966c7 15BuildRequires: python-devel >= 1:2.3
26f47efa 16BuildRequires: sqlite3-devel
b9bee2d9 17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20This is an extension module for the SQLite embedded relational
21database. It tries to conform to the Python DB-API Spec v2 as far as
22possible. One problem is that SQLite returns everything as text. This
23is a result of SQLite's internal representation of data, however it
24still may be possible to return data in the type specified by the
25table definitions.
26
0437c1a1
JR
27%description -l pl.UTF-8
28Ten pakiet zawiera moduł rozszerzenia dla osadzalnej relacyjnej bazy
29danych SQLite. Próbuje on być w zgodzie ze specyfikacją Python DB-API
30v2 na tyle, na ile to możliwe. Jednym problemem jest to, że SQLite
31zwraca wszystko jako tekst. Jest to wynik wewnętrznej reprezentacji
32danych przez SQLite; mimo to nadal jest możliwe zwracanie danych typu
b344ef05
JB
33podanego w definicji tabeli.
34
b9bee2d9 35%prep
9ffb9c29 36%setup -q -n pysqlite-%{version}
b9bee2d9 37
38%build
39CFLAGS="%{rpmcflags}"
de50f6f9 40export CFLAGS
b9bee2d9 41python setup.py build
42
43%install
44rm -rf $RPM_BUILD_ROOT
e2d7090a 45install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
b9bee2d9 46
ed600f9c 47PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir} \
48 python setup.py install \
55e1ebe6 49 --root=$RPM_BUILD_ROOT --optimize=2
b344ef05 50
ed600f9c 51rm -rf $RPM_BUILD_ROOT%{py_sitedir}/pysqlite2/{,test/}*.py \
52 $RPM_BUILD_ROOT%{_prefix}/pysqlite2-doc
9ffb9c29 53cp -aR doc/code/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
b9bee2d9 54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
ed600f9c 60%doc doc/*.txt
9ffb9c29
AM
61%dir %{py_sitedir}/pysqlite2
62%{py_sitedir}/pysqlite2/*.py[co]
63%attr(755,root,root) %{py_sitedir}/pysqlite2/_%{module}.so
64%dir %{py_sitedir}/pysqlite2/test
65%{py_sitedir}/pysqlite2/test/*.py[co]
e2d7090a 66%dir %{_examplesdir}/%{name}-%{version}
67%{_examplesdir}/%{name}-%{version}/*
This page took 0.07785 seconds and 4 git commands to generate.