]> git.pld-linux.org Git - packages/python3-setuptools.git/blame - python-setuptools.spec
- updated to 34.3.3
[packages/python3-setuptools.git] / python-setuptools.spec
CommitLineData
2f649423
MK
1#
2# Conditional build:
e2cd79ed 3%bcond_without apidocs # Sphinx based documentation
6502ae9a 4%bcond_with tests # py.test tests (few failures)
e2cd79ed
JB
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
25fb9ea9
JK
7%bcond_without python3_default # Use Python 3.x for easy_install executable
8
9%if %{without python3}
10%undefine python3_default
11%endif
2f649423 12
cb552c1a 13%define module setuptools
b79e62bc 14Summary: A collection of enhancements to the Python distutils
e4a6c4e2 15Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
b79e62bc 16Name: python-setuptools
6502ae9a
JB
17Version: 34.3.3
18Release: 1
67093d8e 19Epoch: 1
2f649423 20License: PSF or ZPL
b79e62bc 21Group: Development/Languages/Python
e2cd79ed 22#Source0Download: https://pypi.python.org/simple/setuptools/
6502ae9a
JB
23Source0: https://pypi.python.org/packages/d5/b7/e52b7dccd3f91eec858309dcd931c1387bf70b6d458c86a9bfcb50134fbd/setuptools-%{version}.zip
24# Source0-md5: 696941b10b15f0717be957a4d6cfc12e
1ca207b5 25URL: https://github.com/pypa/setuptools
6502ae9a 26%if %(locale -a | grep -q '^C.UTF-8$'; echo $?)
c034c756
JB
27BuildRequires: glibc-localedb-all
28%endif
2f649423 29%if %{with python2}
c034c756 30BuildRequires: python-modules >= 1:2.6
b6cbc91d 31BuildConflicts: python-distribute < 0.7
e2cd79ed 32%if %{with tests}
6502ae9a
JB
33BuildRequires: python-appdirs >= 1.4.0
34BuildRequires: python-backports.unittest_mock >= 1.2
35BuildRequires: python-packaging >= 16.8
36BuildRequires: python-pytest >= 3.0.2
37BuildRequires: python-pytest-flake8
38BuildRequires: python-six >= 1.6.0
e2cd79ed 39%endif
2f649423
MK
40%endif
41%if %{with python3}
6502ae9a 42BuildRequires: python3-modules >= 1:3.3
b6cbc91d 43BuildConflicts: python3-distribute < 0.7
e2cd79ed 44%if %{with tests}
6502ae9a
JB
45BuildRequires: python3-appdirs >= 1.4.0
46BuildRequires: python3-packaging >= 16.8
47BuildRequires: python3-pytest >= 3.0.2
48BuildRequires: python3-pytest-flake8
49BuildRequires: python3-six >= 1.6.0
e2cd79ed 50%endif
2f649423 51%endif
5c02125b 52%if %{with apidocs}
6502ae9a
JB
53BuildRequires: python3-rst.linker >= 1.6.1
54BuildRequires: sphinx-pdg-3 >= 1.4
5c02125b 55%endif
c034c756 56BuildRequires: rpm-pythonprov
6502ae9a 57BuildRequires: rpmbuild(macros) >= 1.714
c034c756 58Requires: python-modules >= 1:2.6
64c5aa5e 59Obsoletes: python-distribute < 0.7
c034c756 60Obsoletes: python-setuptools-devel
b79e62bc
AM
61BuildArch: noarch
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%description
65setuptools is a collection of enhancements to the Python distutils
c034c756
JB
66that allow you to more easily build and distribute Python 2.x
67packages, especially ones that have dependencies on other packages.
b79e62bc 68
1c17442b 69%description -l pl.UTF-8
d539774b 70setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
c034c756
JB
71łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
72szczególnie tych mających zależności od innych pakietów.
d539774b
JB
73
74Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
c034c756
JB
75uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
76Pythona 2.x.
eadb908c 77
2f649423 78%package -n python3-%{module}
c034c756
JB
79Summary: A collection of enhancements to the Python distutils
80Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
2f649423 81Group: Libraries/Python
6502ae9a 82Requires: python3-modules >= 1:3.3
ff466203 83Obsoletes: python3-distribute < 0.7
2f649423
MK
84
85%description -n python3-%{module}
c034c756
JB
86setuptools is a collection of enhancements to the Python distutils
87that allow you to more easily build and distribute Python 3.x
88packages, especially ones that have dependencies on other packages.
2f649423
MK
89
90%description -n python3-%{module} -l pl.UTF-8
c034c756
JB
91setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
92łatwiejsze budowanie i rozprowadzanie pakietów Pythona 3.x,
93szczególnie tych mających zależności od innych pakietów.
2f649423 94
25fb9ea9
JK
95%package -n easy_install
96Summary: Python software installer
97Summary(pl.UTF-8): Instalator oprogramowania napisanego w Pythonie
98Group: Libraries/Python
99%if %{with python3_default}
100Requires: python3-%{module} = %{epoch}:%{version}-%{release}
101%else
102Requires: python-%{module} = %{epoch}:%{version}-%{release}
103%endif
b6cbc91d 104Conflicts: python-setuptools < 1:18.6.1-2
25fb9ea9
JK
105
106%description -n easy_install
107Python software installer.
108
23dd6491 109%description -n easy_install -l pl.UTF-8
25fb9ea9
JK
110Instalator oprogramowania napisanego w Pythonie.
111
2f649423
MK
112%package apidocs
113Summary: %{module} API documentation
114Summary(pl.UTF-8): Dokumentacja API %{module}
115Group: Documentation
116
117%description apidocs
118API documentation for %{module}.
119
120%description apidocs -l pl.UTF-8
121Dokumentacja API %{module}.
122
b79e62bc 123%prep
2f649423 124%setup -q -n %{module}-%{version}
b79e62bc
AM
125
126%build
2f649423 127%if %{with python2}
6502ae9a
JB
128LC_ALL=C.UTF-8 \
129%py_build
130
131%{?with_tests:%{__python} -m pytest pkg_resources/tests setuptools/tests tests}
2f649423
MK
132%endif
133
134%if %{with python3}
6502ae9a
JB
135LC_ALL=C.UTF-8 \
136%py3_build
137
138%{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
2f649423 139%endif
b79e62bc 140
c034c756 141%if %{with apidocs}
6502ae9a 142%{__make} -C docs html SPHINXBUILD=sphinx-build-3
c034c756
JB
143%endif
144
b79e62bc
AM
145%install
146rm -rf $RPM_BUILD_ROOT
147
c034c756 148%if %{with python3}
a21b5be7 149%py3_install
2f649423 150%endif
991fba2b 151
c034c756 152%if %{with python2}
a21b5be7 153%py_install
c034c756 154
4ba39be8
JB
155# note: setuptools/command/easy_install.py expects setuptools/site-patch.py to exist
156%py_postclean -x site-patch.py
2f649423 157%endif
b79e62bc 158
25fb9ea9 159%if %{with python3_default}
b6cbc91d 160ln -sf easy_install-%{py3_ver} $RPM_BUILD_ROOT%{_bindir}/easy_install
25fb9ea9 161%else
b6cbc91d 162ln -sf easy_install-%{py_ver} $RPM_BUILD_ROOT%{_bindir}/easy_install
25fb9ea9
JK
163%endif
164
b79e62bc
AM
165%clean
166rm -rf $RPM_BUILD_ROOT
167
2f649423 168%if %{with python2}
b79e62bc
AM
169%files
170%defattr(644,root,root,755)
1ca207b5 171%doc CHANGES.rst README.rst
25fb9ea9 172%attr(755,root,root) %{_bindir}/easy_install-%{py_ver}
5c02125b
JB
173%{py_sitescriptdir}/pkg_resources
174%{py_sitescriptdir}/setuptools
2f649423 175%{py_sitescriptdir}/easy_install.py[co]
2f649423
MK
176%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
177%endif
2f649423
MK
178
179%if %{with python3}
180%files -n python3-%{module}
f4841952 181%defattr(644,root,root,755)
1ca207b5 182%doc CHANGES.rst README.rst
25fb9ea9 183%attr(755,root,root) %{_bindir}/easy_install-%{py3_ver}
c034c756 184%{py3_sitescriptdir}/__pycache__/easy_install.*.py[co]
5c02125b
JB
185%{py3_sitescriptdir}/pkg_resources
186%{py3_sitescriptdir}/setuptools
2f649423 187%{py3_sitescriptdir}/easy_install.py
2f649423
MK
188%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
189%endif
190
25fb9ea9
JK
191%files -n easy_install
192%defattr(644,root,root,755)
193%attr(755,root,root) %{_bindir}/easy_install
194
c034c756 195%if %{with apidocs}
2f649423
MK
196%files apidocs
197%defattr(644,root,root,755)
6502ae9a 198%doc docs/build/html/{_static,*.html,*.js}
2f649423 199%endif
This page took 0.069464 seconds and 4 git commands to generate.