]> git.pld-linux.org Git - packages/python3-scipy.git/blame - python-scipy.spec
- new
[packages/python3-scipy.git] / python-scipy.spec
CommitLineData
e2bab32d
AM
1# TODO:
2# - atlas, lapack support
3# - rework files
4%define module scipy
5Summary: A library of scientific tools
6Name: python-%{module}
7Version: 0.3.2
8Release: 1
9License: BSD
10Group: Development/Languages/Python
11Source0: http://www.scipy.org/download/scipy/src/SciPy_complete-%{version}.tar.gz
12# Source0-md5: 5ae2280ab2c4c653cb0ff8479e81284a
13URL: http://www.scipy.org/
14BuildRequires: python
15BuildRequires: f2py
16BuildRequires: python-devel >= 1:2.3
17BuildRequires: python-numpy-devel
18BuildRequires: gcc-g77
19BuildRequires: X11-devel
20%pyrequires_eq python-modules
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24SciPy is an open source library of scientific tools for Python. SciPy
25supplements the popular Numeric module, gathering a variety of high
26level science and engineering modules together as a single package.
27
28%prep
29%setup -q -n SciPy_complete-%{version}
30
31%build
32CFLAGS="%{rpmcflags}"
33export CFLAGS
34python setup.py build
35
36%install
37rm -rf $RPM_BUILD_ROOT
38
39python setup.py install \
40 --root=$RPM_BUILD_ROOT \
41 --optimize=2
42
43find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' | \
44 grep -v examples | \
45 xargs rm
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
52%doc DEVELOPERS.txt THANKS.txt
53%dir %{py_sitedir}/*
54%{py_sitedir}/*/*
This page took 0.068334 seconds and 4 git commands to generate.