]> git.pld-linux.org Git - packages/python-repoze.lru.git/blame - python-repoze.lru.spec
new, version 0.6
[packages/python-repoze.lru.git] / python-repoze.lru.spec
CommitLineData
aced4f00
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define module repoze.lru
6Summary: A tiny LRU cache implementation and decorator
7Name: python-%{module}
8Version: 0.6
9Release: 1
10License: BSD-derived (http://www.repoze.org/LICENSE.txt)
11Group: Libraries/Python
12Source0: http://pypi.python.org/packages/source/r/repoze.lru/repoze.lru-%{version}.tar.gz
13# Source0-md5: 2c3b64b17a8e18b405f55d46173e14dd
14URL: http://pypi.python.org/pypi/repoze.lru
15BuildRequires: python-distribute
16BuildRequires: rpm-pythonprov
17BuildRequires: rpmbuild(macros) >= 1.219
18Requires: python-modules
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23repoze.lru is a LRU (least recently used) cache implementation. Keys
24and values that are not used frequently will be evicted from the cache
25faster than keys and values that are used frequently.
26
27%prep
28%setup -q -n %{module}-%{version}
29
30%build
31%{__python} setup.py build
32
33%{?with_tests:%{__python} setup.py test}
34
35%install
36rm -rf $RPM_BUILD_ROOT
37%{__python} setup.py install \
38 --skip-build \
39 --optimize=2 \
40 --root=$RPM_BUILD_ROOT
41
42%{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/repoze/lru/tests.py*
43
44%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
45%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
46%py_postclean
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(644,root,root,755)
53%doc CHANGES.txt LICENSE.txt README.txt
54%dir %{py_sitescriptdir}/repoze/
55%dir %{py_sitescriptdir}/repoze/lru
56%{py_sitescriptdir}/repoze/lru/*.py[co]
57%{py_sitescriptdir}/%{module}-%{version}-py*-nspkg.pth
58%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.06659 seconds and 4 git commands to generate.