]> git.pld-linux.org Git - packages/python-repoze.lru.git/blame - python-repoze.lru.spec
automatic change: use py_build/py_install macros
[packages/python-repoze.lru.git] / python-repoze.lru.spec
CommitLineData
aced4f00
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define module repoze.lru
6Summary: A tiny LRU cache implementation and decorator
7Name: python-%{module}
8Version: 0.6
9Release: 1
10License: BSD-derived (http://www.repoze.org/LICENSE.txt)
11Group: Libraries/Python
12Source0: http://pypi.python.org/packages/source/r/repoze.lru/repoze.lru-%{version}.tar.gz
13# Source0-md5: 2c3b64b17a8e18b405f55d46173e14dd
14URL: http://pypi.python.org/pypi/repoze.lru
15BuildRequires: python-distribute
16BuildRequires: rpm-pythonprov
17BuildRequires: rpmbuild(macros) >= 1.219
18Requires: python-modules
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23repoze.lru is a LRU (least recently used) cache implementation. Keys
24and values that are not used frequently will be evicted from the cache
25faster than keys and values that are used frequently.
26
27%prep
28%setup -q -n %{module}-%{version}
29
30%build
453ce069 31%py_build
aced4f00
ER
32
33%{?with_tests:%{__python} setup.py test}
34
35%install
36rm -rf $RPM_BUILD_ROOT
453ce069 37%py_install
aced4f00
ER
38
39%{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/repoze/lru/tests.py*
40
41%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
42%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
43%py_postclean
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%files
49%defattr(644,root,root,755)
50%doc CHANGES.txt LICENSE.txt README.txt
51%dir %{py_sitescriptdir}/repoze/
52%dir %{py_sitescriptdir}/repoze/lru
53%{py_sitescriptdir}/repoze/lru/*.py[co]
54%{py_sitescriptdir}/%{module}-%{version}-py*-nspkg.pth
55%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.079217 seconds and 4 git commands to generate.