]> git.pld-linux.org Git - packages/python-psycopg2.git/blame - python-psycopg2.spec
- 2.0.7
[packages/python-psycopg2.git] / python-psycopg2.spec
CommitLineData
fa6eecba 1#
2# todo:
3# - zope adapter
4# - lib64 patch
5#
50248341 6# WARNING! Please note, that mx.DateTime is optional. You can use
7# mx.DateTime with your apps, but other see datetime datatype more
8# suitable for date and time as it is standard in Python.
f93a45b9 9
fa6eecba 10%define module psycopg2
f93a45b9 11
3bacd1f7 12Summary: psycopg is a PostgreSQL database adapter for Python
f4a85503 13Summary(pl.UTF-8): psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
3bacd1f7 14Name: python-%{module}
d9fab9e8 15Version: 2.0.7
5accdc10 16Release: 1
258ebeda 17License: GPL
4b5b5919 18Group: Libraries/Python
dd6f52dd 19Source0: http://initd.org/pub/software/psycopg/%{module}-%{version}.tar.gz
d9fab9e8 20# Source0-md5: 39a2a2ec16f031d2bb1c54de403d4d77
fa6eecba 21#Patch0: %{name}-lib64.patch
258ebeda 22URL: http://www.initd.org/software/psycopg/
dd6f8fe2 23BuildRequires: autoconf
258ebeda 24BuildRequires: postgresql-backend-devel
c72332e3 25BuildRequires: postgresql-devel
258ebeda 26BuildRequires: python-devel
399bddde 27BuildRequires: rpm-pythonprov
50248341 28# see note at the begining of the spec file
84a640a1 29BuildRequires: python-mx-DateTime-devel
30Requires: python-mx-DateTime
258ebeda 31Requires: postgresql-libs
44843cf9 32%pyrequires_eq python-modules
3bacd1f7 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3bacd1f7 34
f1720923 35%define zope_subname ZPsycopgDA
e8c205e6 36
3bacd1f7
MK
37%description
38psycopg is a PostgreSQL database adapter for the Python programming
39language (just like pygresql and popy.) It was written from scratch
40with the aim of being very small and fast, and stable as a rock. The
41main advantages of psycopg are that it supports the full Python
42DBAPI-2.0 and being thread safe at level 2.
43
3a08e339 44%description -l pl.UTF-8
3bacd1f7 45psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
3a08e339
JR
46PostgreSQL (tak jak pygresql i popy). Został zakodowany od początku
47z założeniem że ma być bardzo mały, szybki i stabilny. Główna zaletą
48psycopg jest, że w jest pełni zgodny z standardem DBAPI-2.0 i jest
3bacd1f7
MK
49'thread safe' na poziomie 2.
50
f1720923 51%package -n Zope-%{zope_subname}
e8c205e6 52Summary: Zope PostgreSQL database adapter
f4a85503 53Summary(pl.UTF-8): Interfejs bazy danych PostgreSQL do Zope
e8c205e6 54Group: Development/Languages/Python
ea893739 55Requires: %{name} = %{version}-%{release}
e8c205e6 56Requires: Zope
e8c205e6 57
f1720923 58%description -n Zope-%{zope_subname}
e8c205e6
JK
59Zope PostgreSQL database adapter.
60
3a08e339 61%description -n Zope-%{zope_subname} -l pl.UTF-8
e8c205e6
JK
62Interfejs bazy danych PostgreSQL do Zope.
63
3bacd1f7 64%prep
ad85baa5 65%setup -q -n %{module}-%{version}
fa6eecba 66#%if "%{_lib}" == "lib64"
67#%patch0 -p1
68#%endif
3bacd1f7
MK
69
70%build
fa6eecba 71python setup.py build
3bacd1f7
MK
72
73%install
74rm -rf $RPM_BUILD_ROOT
3bacd1f7 75
fa6eecba 76python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
77
78find $RPM_BUILD_ROOT%{py_libdir} -type f -name "*.py" | xargs rm
79
80#install -d $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
3bacd1f7 81
fa6eecba 82#cp -ar %{zope_subname}/* $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
83#%py_comp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
84#%py_ocomp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
85#rm -f $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}/*.py
e8c205e6 86
3bacd1f7
MK
87%clean
88rm -rf $RPM_BUILD_ROOT
89
fa6eecba 90#%post -n Zope-%{zope_subname}
91#/usr/sbin/installzopeproduct %{_datadir}/Zope-%{zope_subname} %{zope_subname}
92#if [ -f /var/lock/subsys/zope ]; then
93# /etc/rc.d/init.d/zope restart >&2
94#fi
f1720923 95
fa6eecba 96#%postun -n Zope-%{zope_subname}
97#if [ "$1" = "0" ]; then
98# /usr/sbin/installzopeproduct -d %{zope_subname}
99# if [ -f /var/lock/subsys/zope ]; then
100# /etc/rc.d/init.d/zope restart >&2
101# fi
102#fi
f1720923 103
3bacd1f7
MK
104%files
105%defattr(644,root,root,755)
fa6eecba 106%doc ChangeLog AUTHORS README doc/HACKING doc/SUCCESS doc/TODO
107%dir %{py_sitedir}/%{module}
108%attr(755,root,root) %{py_sitedir}/%{module}/*.so
109%{py_sitedir}/%{module}/*.py[co]
110
111#%files -n Zope-%{zope_subname}
112#%defattr(644,root,root,755)
113#%{_datadir}/Zope-%{zope_subname}
This page took 0.04665 seconds and 4 git commands to generate.