]> git.pld-linux.org Git - packages/python-psycopg2.git/blame - python-psycopg2.spec
- release 6 (by relup.sh)
[packages/python-psycopg2.git] / python-psycopg2.spec
CommitLineData
121405c1 1# TODO:
fa6eecba 2# - lib64 patch
df9bb384 3
1ce53046
JK
4# Conditional build:
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
f93a45b9 7
1ce53046 8%define module psycopg2
3bacd1f7 9Summary: psycopg is a PostgreSQL database adapter for Python
f4a85503 10Summary(pl.UTF-8): psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
3bacd1f7 11Name: python-%{module}
121405c1 12Version: 2.5.1
330f6d72 13Release: 6
258ebeda 14License: GPL
4b5b5919 15Group: Libraries/Python
1ce53046 16Source0: http://initd.org/psycopg/tarballs/PSYCOPG-2-5/%{module}-%{version}.tar.gz
121405c1 17# Source0-md5: 1b433f83d50d1bc61e09026e906d84c7
fa6eecba 18#Patch0: %{name}-lib64.patch
258ebeda 19URL: http://www.initd.org/software/psycopg/
dd6f8fe2 20BuildRequires: autoconf
258ebeda 21BuildRequires: postgresql-backend-devel
c72332e3 22BuildRequires: postgresql-devel
62f76467
ER
23%{?with_python2:BuildRequires: python-devel >= 2.5}
24%{?with_python3:BuildRequires: python3-devel}
399bddde 25BuildRequires: rpm-pythonprov
258ebeda 26Requires: postgresql-libs
89ddf330 27Requires: python-modules
62f76467 28Requires: python-pytz
07c88ab6 29%if "%{pld_release}" == "ac"
54964aba 30BuildRequires: python-mx-DateTime-devel
31Requires: python-mx-DateTime
07c88ab6 32%else
4093edd6 33# if somebody really needs mx.DateTime, then one can request mx.Datetime
34# usage on runtime;
35# it is pointless to use 'Requires' or 'Suggest' field because
36# - python provides its own datetime implementation
37# - one can request it on runtime (as said above)
38# - usage of mx.DateTime type is application specific
0e0021ce 39# Sure, but make mx-DateTime conditional build work
62f76467 40BuildConflicts: python-egenix-mx-base
1ce53046 41%endif
3bacd1f7 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3bacd1f7
MK
43
44%description
45psycopg is a PostgreSQL database adapter for the Python programming
46language (just like pygresql and popy.) It was written from scratch
47with the aim of being very small and fast, and stable as a rock. The
48main advantages of psycopg are that it supports the full Python
49DBAPI-2.0 and being thread safe at level 2.
50
3a08e339 51%description -l pl.UTF-8
3bacd1f7 52psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
62f76467
ER
53PostgreSQL (tak jak pygresql i popy). Został zakodowany od początku z
54założeniem że ma być bardzo mały, szybki i stabilny. Główna zaletą
3a08e339 55psycopg jest, że w jest pełni zgodny z standardem DBAPI-2.0 i jest
3bacd1f7
MK
56'thread safe' na poziomie 2.
57
1ce53046
JK
58%package -n python3-%{module}
59Summary: psycopg is a PostgreSQL database adapter for Python
60Summary(pl.UTF-8): psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
61Group: Libraries/Python
121405c1
MK
62Requires: python3-modules
63Requires: python3-pytz
121405c1 64
1ce53046
JK
65%description -n python3-%{module}
66psycopg is a PostgreSQL database adapter for the Python programming
67language (just like pygresql and popy.) It was written from scratch
68with the aim of being very small and fast, and stable as a rock. The
69main advantages of psycopg are that it supports the full Python
70DBAPI-2.0 and being thread safe at level 2.
71
72%description -n python3-%{module} -l pl.UTF-8
73psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
62f76467
ER
74PostgreSQL (tak jak pygresql i popy). Został zakodowany od początku z
75założeniem że ma być bardzo mały, szybki i stabilny. Główna zaletą
1ce53046
JK
76psycopg jest, że w jest pełni zgodny z standardem DBAPI-2.0 i jest
77'thread safe' na poziomie 2.
78
3bacd1f7 79%prep
ad85baa5 80%setup -q -n %{module}-%{version}
fa6eecba 81#%if "%{_lib}" == "lib64"
82#%patch0 -p1
83#%endif
3bacd1f7
MK
84
85%build
1ce53046 86%if %{with python2}
528a4b45 87%py_build
1ce53046
JK
88%endif
89%if %{with python3}
528a4b45 90%py3_build
1ce53046 91%endif
3bacd1f7
MK
92
93%install
94rm -rf $RPM_BUILD_ROOT
1ce53046 95%if %{with python2}
528a4b45 96%py_install
fa6eecba 97
921d82ea 98%py_postclean
1ce53046
JK
99%endif
100%if %{with python3}
528a4b45 101%py3_install
1ce53046 102%endif
fa6eecba 103
3bacd1f7
MK
104%clean
105rm -rf $RPM_BUILD_ROOT
106
1ce53046 107%if %{with python2}
3bacd1f7
MK
108%files
109%defattr(644,root,root,755)
1ce53046 110%doc NEWS AUTHORS README doc/HACKING doc/SUCCESS
fa6eecba 111%dir %{py_sitedir}/%{module}
112%attr(755,root,root) %{py_sitedir}/%{module}/*.so
113%{py_sitedir}/%{module}/*.py[co]
432cab47 114%if "%{pld_release}" != "ac"
f53e9079 115%{py_sitedir}/*.egg-info
df9bb384 116%endif
1ce53046
JK
117%{py_sitedir}/%{module}/tests
118%endif
119
120%if %{with python3}
121%files -n python3-%{module}
122%defattr(644,root,root,755)
123%doc NEWS AUTHORS README doc/HACKING doc/SUCCESS
124%dir %{py3_sitedir}/%{module}
125%dir %{py3_sitedir}/%{module}/__pycache__
126%attr(755,root,root) %{py3_sitedir}/%{module}/*.so
127%{py3_sitedir}/%{module}/*.py
128%{py3_sitedir}/%{module}/__pycache__/*.py*
129%{py3_sitedir}/*.egg-info
130%{py3_sitedir}/%{module}/tests
131%endif
This page took 0.097576 seconds and 4 git commands to generate.