]> git.pld-linux.org Git - packages/python-flask-babel.git/blame - python-flask-babel.spec
Release 8 (by relup.sh)
[packages/python-flask-babel.git] / python-flask-babel.spec
CommitLineData
76ebd225
MK
1#
2# Conditional build:
3%bcond_with doc # don't build doc
4%bcond_with tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module flask-babel
9Summary: Extension to Flask that adds i18n and l10n support to any Flask application with the help of babel, pytz and speaklater
10Summary(pl.UTF-8): Rozszerzenie Flask dodające wsparcie dla i18n i l10n przy użyciu babel, pytz i speklater.
11# Name must match the python module/package name (as in 'import' statement)
12Name: python-%{module}
13Version: 0.9
7f7efcac 14Release: 8
76ebd225
MK
15License: BSD
16Group: Libraries/Python
17# https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-0.9.tar.gz
18Source0: https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-%{version}.tar.gz
19# Source0-md5: 4762e0392303f464d53cbebedfb87ded
20URL: http://github.com/mitsuhiko/flask-babel
21BuildRequires: rpm-pythonprov
fe64f9ff 22BuildRequires: rpmbuild(macros) >= 1.710
76ebd225
MK
23%if %{with python2}
24BuildRequires: python-distribute
25BuildRequires: python-speaklater
26%endif
27%if %{with python3}
76ebd225
MK
28BuildRequires: python3-modules
29BuildRequires: python3-speaklater
30%endif
31Requires: python-jinja2 >= 2.5
32Requires: python-modules
33Requires: python-speaklater
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Adds i18n/l10n support to Flask applications with the help of the
39Babel library.
40
41# %description -l pl.UTF-8
42
43%package -n python3-%{module}
44Summary: -
45Summary(pl.UTF-8): -
46Group: Libraries/Python
47Requires: python3-jinja2 >= 2.5
48Requires: python3-modules
49Requires: python3-speaklater
50
51%description -n python3-%{module}
52Adds i18n/l10n support to Flask applications with the help of the
53Babel library.
54
55# %description -n python3-%{module} -l pl.UTF-8
56
57%package apidocs
58Summary: %{module} API documentation
59Summary(pl.UTF-8): Dokumentacja API %{module}
60Group: Documentation
61
62%description apidocs
63API documentation for %{module}.
64
65%description apidocs -l pl.UTF-8
66Dokumentacja API %{module}.
67
68%prep
69%setup -q -n Flask-Babel-%{version}
70
71%build
72%if %{with python2}
13f1dcb6 73%py_build %{?with_tests:test}
76ebd225
MK
74%endif
75
76%if %{with python3}
13f1dcb6 77%py3_build %{?with_tests:test}
76ebd225
MK
78%endif
79
80%if %{with doc}
81cd docs
82%{__make} -j1 html
83rm -rf _build/html/_sources
84%endif
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89%if %{with python2}
13f1dcb6 90%py_install
76ebd225
MK
91
92%py_postclean
93%endif
94
95%if %{with python3}
13f1dcb6 96%py3_install
76ebd225
MK
97%endif
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%if %{with python2}
103%files
104%defattr(644,root,root,755)
105%doc LICENSE README
106%{py_sitescriptdir}/flask_babel
107%if "%{py_ver}" > "2.4"
108%{py_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
109%endif
110%endif
111
112%if %{with python3}
113%files -n python3-%{module}
114%defattr(644,root,root,755)
115%doc LICENSE README
116%{py3_sitescriptdir}/flask_babel
117%{py3_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
118%endif
119
120%if %{with doc}
121%files apidocs
122%defattr(644,root,root,755)
123%doc docs/_build/html/*
124%endif
This page took 0.129689 seconds and 5 git commands to generate.