]> git.pld-linux.org Git - packages/python-cryptography.git/blame - python-cryptography.spec
- disable python3 module build
[packages/python-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
049a803f 3%bcond_without python2 # CPython 2.x module
c9ed3111 4%bcond_with python3 # CPython 3.x module
f63b1331 5%bcond_without doc # Sphinx documentation
163a4ef8 6%bcond_without tests # unit test
06232684
JB
7
8Summary: Crypthography library for Python 2
9Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
10Name: python-cryptography
0f792d56 11Version: 3.3.1
54c52544 12Release: 3
d6e7edf5 13License: Apache v2.0 or BSD
06232684 14Group: Libraries/Python
29d4b67b 15#Source0Download: https://pypi.org/simple/cryptography/
7df50b22 16Source0: https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
0f792d56 17# Source0-md5: 6faa1a7125c500c0e1586ad342ba3b30
163a4ef8
JB
18#Source1Download: https://pypi.org/simple/cryptography_vectors/
19Source1: https://files.pythonhosted.org/packages/source/c/cryptography-vectors/cryptography_vectors-%{version}.tar.gz
0f792d56 20# Source1-md5: 2a23fd073fc1f95a697ee96fc991e419
ff0d2aa0 21Patch0: openssl3.patch
06232684 22URL: https://cryptography.io/
0f792d56 23BuildRequires: openssl-devel >= 1.1.0
d331861d 24BuildRequires: rpm-pythonprov >= 5.4.15-48
049a803f 25BuildRequires: rpmbuild(macros) >= 1.714
06232684 26%if %{with python2}
0f792d56 27BuildRequires: python-cffi >= 1.12
29d4b67b 28BuildRequires: python-devel >= 1:2.7
b2fc4ef3 29BuildRequires: python-enum34
29d4b67b
JB
30BuildRequires: python-pytz
31BuildRequires: python-setuptools >= 18.5
06232684 32BuildRequires: python-six >= 1.4.1
049a803f 33%if %{with tests}
049a803f
JB
34%if "%{py_ver}" >= "2.7"
35BuildRequires: python-hypothesis >= 1.11.4
36%endif
049a803f
JB
37BuildRequires: python-ipaddress
38BuildRequires: python-iso8601
39BuildRequires: python-pretend
29d4b67b 40BuildRequires: python-pytest >= 3.6.0
f63b1331 41BuildRequires: python-pytz
049a803f 42%endif
06232684
JB
43%endif
44%if %{with python3}
0f792d56
JB
45BuildRequires: python3-cffi >= 1.12
46BuildRequires: python3-devel >= 1:3.6
29d4b67b 47BuildRequires: python3-setuptools >= 18.5
06232684 48BuildRequires: python3-six >= 1.4.1
049a803f 49%if %{with tests}
049a803f 50BuildRequires: python3-hypothesis >= 1.11.4
049a803f
JB
51BuildRequires: python3-iso8601
52BuildRequires: python3-pretend
29d4b67b 53BuildRequires: python3-pytest >= 3.6.0
f63b1331
JB
54BuildRequires: python3-pytz
55%endif
049a803f 56%endif
f63b1331
JB
57%if %{with doc}
58BuildRequires: python3-sphinx_rtd_theme
59BuildRequires: sphinx-pdg-3 >= 1.6.5
06232684 60%endif
0f792d56 61Requires: openssl >= 1.1.0
06232684
JB
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%description
65cryptography is a package designed to expose cryptographic recipes and
66primitives to Python developers. Our goal is for it to be your
163a4ef8
JB
67"cryptographic standard library". It supports Python 2.7, Python 3.4+,
68and PyPy.
06232684
JB
69
70cryptography includes both high level recipes, and low level
71interfaces to common cryptographic algorithms such as symmetric
72ciphers, message digests and key derivation functions.
73
74This package contains Python 2 modules.
75
76%description -l pl.UTF-8
77cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
78obiektów kryptograficznych programistom Pythona. Celem jest
79dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
163a4ef8 80Pythona 2.7, Pythona 3.4+ oraz PyPy.
06232684
JB
81
82cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
83niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 84takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
85wyprowadzające klucze.
86
87Ten pakiet zawiera moduły Pythona 2.
88
89%package -n python3-cryptography
90Summary: Crypthography library for Python 3
91Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
92Group: Libraries/Python
0f792d56 93Requires: openssl >= 1.1.0
06232684
JB
94
95%description -n python3-cryptography
96cryptography is a package designed to expose cryptographic recipes and
97primitives to Python developers. Our goal is for it to be your
163a4ef8
JB
98"cryptographic standard library". It supports Python 2.7, Python 3.4+,
99and PyPy.
06232684
JB
100
101cryptography includes both high level recipes, and low level
102interfaces to common cryptographic algorithms such as symmetric
103ciphers, message digests and key derivation functions.
104
105This package contains Python 3 modules.
106
107%description -n python3-cryptography -l pl.UTF-8
108cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
109obiektów kryptograficznych programistom Pythona. Celem jest
110dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
163a4ef8 111Pythona 2.7, Pythona 3.4+ oraz PyPy.
06232684
JB
112
113cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
114niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 115takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
116wyprowadzające klucze.
117
118Ten pakiet zawiera moduły Pythona 3.
119
f63b1331
JB
120%package apidocs
121Summary: API documentation for cryptography module
122Summary(pl.UTF-8): Dokumentacja API modułu cryptography
123Group: Documentation
094f23d7 124BuildArch: noarch
f63b1331
JB
125
126%description apidocs
127API documentation for cryptography module.
128
129%description apidocs -l pl.UTF-8
130Dokumentacja API modułu cryptography.
131
06232684 132%prep
163a4ef8 133%setup -q -n cryptography-%{version} %{?with_tests:-a1}
ff0d2aa0 134%patch0 -p1
163a4ef8 135
c9ed3111
JR
136# Do not tests legacy, disabled by default algorithms
137# See man OSSL_PROVIDER-legacy(7)
138%{__rm} tests/hazmat/primitives/test_{arc4,blowfish,cast5,idea,seed}.py
139
163a4ef8
JB
140%if %{with tests}
141%{__mv} cryptography_vectors-%{version}/cryptography_vectors .
142%endif
06232684
JB
143
144%build
145export CFLAGS="%{rpmcflags}"
146
147%if %{with python2}
503cd915
JB
148%py_build
149
150%if %{with tests}
151PYTHONPATH=$(echo $(pwd)/build-2/lib.*) \
152%{__python} -m pytest tests
153%endif
163a4ef8 154%endif
163a4ef8 155
cddf28e5 156%if %{with python3}
503cd915
JB
157%py3_build
158
159%if %{with tests}
160PYTHONPATH=$(echo $(pwd)/build-3/lib.*) \
161%{__python3} -m pytest tests
162%endif
06232684
JB
163%endif
164
f63b1331
JB
165%if %{with doc}
166%{__make} -C docs html \
167 SPHINXBUILD=sphinx-build-3
168%endif
169
06232684
JB
170%install
171rm -rf $RPM_BUILD_ROOT
172
173%if %{with python2}
6d1f8f74 174%py_install
06232684
JB
175
176%py_postclean
177%endif
178
179%if %{with python3}
6d1f8f74 180%py3_install
06232684
JB
181%endif
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186%if %{with python2}
187%files
188%defattr(644,root,root,755)
049a803f 189%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 190%dir %{py_sitedir}/cryptography
06232684
JB
191%{py_sitedir}/cryptography/*.py[co]
192%dir %{py_sitedir}/cryptography/hazmat
193%{py_sitedir}/cryptography/hazmat/*.py[co]
194%dir %{py_sitedir}/cryptography/hazmat/backends
195%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
06232684
JB
196%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
197%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
198%dir %{py_sitedir}/cryptography/hazmat/bindings
199%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
d198b5a4 200%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
201%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
202%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
203%dir %{py_sitedir}/cryptography/hazmat/primitives
204%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
205%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
206%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
207%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
208%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
209%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
210%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f63b1331
JB
211%dir %{py_sitedir}/cryptography/hazmat/primitives/serialization
212%{py_sitedir}/cryptography/hazmat/primitives/serialization/*.py[co]
f7d88309
AM
213%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
214%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
d198b5a4
AM
215%dir %{py_sitedir}/cryptography/x509
216%{py_sitedir}/cryptography/x509/*.py[co]
06232684
JB
217%{py_sitedir}/cryptography-%{version}-py*.egg-info
218%endif
219
220%if %{with python3}
221%files -n python3-cryptography
222%defattr(644,root,root,755)
049a803f 223%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 224%dir %{py3_sitedir}/cryptography
06232684
JB
225%{py3_sitedir}/cryptography/*.py
226%{py3_sitedir}/cryptography/__pycache__
227%dir %{py3_sitedir}/cryptography/hazmat
228%{py3_sitedir}/cryptography/hazmat/*.py
229%{py3_sitedir}/cryptography/hazmat/__pycache__
230%dir %{py3_sitedir}/cryptography/hazmat/backends
231%{py3_sitedir}/cryptography/hazmat/backends/*.py
232%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
06232684
JB
233%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
234%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
235%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
236%dir %{py3_sitedir}/cryptography/hazmat/bindings
237%{py3_sitedir}/cryptography/hazmat/bindings/*.py
238%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
d198b5a4 239%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
240%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
241%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
242%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
243%dir %{py3_sitedir}/cryptography/hazmat/primitives
244%{py3_sitedir}/cryptography/hazmat/primitives/*.py
245%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
246%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
247%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
248%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
249%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
250%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
251%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
252%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
253%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
254%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f63b1331
JB
255%dir %{py3_sitedir}/cryptography/hazmat/primitives/serialization
256%{py3_sitedir}/cryptography/hazmat/primitives/serialization/*.py
257%{py3_sitedir}/cryptography/hazmat/primitives/serialization/__pycache__
f7d88309
AM
258%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
259%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
260%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
d198b5a4
AM
261%dir %{py3_sitedir}/cryptography/x509
262%{py3_sitedir}/cryptography/x509/*.py
263%{py3_sitedir}/cryptography/x509/__pycache__
06232684
JB
264%{py3_sitedir}/cryptography-%{version}-py*.egg-info
265%endif
f63b1331
JB
266
267%if %{with doc}
268%files apidocs
269%defattr(644,root,root,755)
503cd915 270%doc docs/_build/html/{_downloads,_static,development,hazmat,x509,*.html,*.js}
f63b1331 271%endif
This page took 0.089433 seconds and 4 git commands to generate.