]> git.pld-linux.org Git - packages/python-coverage.git/blame - python-coverage.spec
*** empty log message ***
[packages/python-coverage.git] / python-coverage.spec
CommitLineData
d1b18853 1%define module coverage
2Summary: Tool for measuring code coverage of Python programs
3Name: python-%{module}
111ad2f5 4Version: 3.5
34386890 5Release: 1
d1b18853 6License: BSD
7Group: Development/Languages/Python
8Source0: http://pypi.python.org/packages/source/c/coverage/%{module}-%{version}.tar.gz
111ad2f5 9# Source0-md5: dee158cf20b17f54e644fba25c2ebfc2
d1b18853 10URL: http://nedbatchelder.com/code/coverage
11BuildRequires: python-devel
61734f13 12BuildRequires: python-setuptools
d1b18853 13BuildRequires: rpm-pythonprov
d1b18853 14BuildRequires: rpmbuild(macros) >= 1.219
61734f13 15Requires: python-modules
d1b18853 16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
61734f13 19Coverage.py is a tool for measuring code coverage of Python programs.
20It monitors your program, noting which parts of the code have been
21executed, then analyzes the source to identify code that could have
22been executed but was not.
d1b18853 23
24%prep
25%setup -q -n %{module}-%{version}
26
27%build
28export CFLAGS="%{rpmcflags}"
29%{__python} setup.py build
30
31%install
32rm -rf $RPM_BUILD_ROOT
33%{__python} setup.py install \
34 --optimize=2 \
35 --root=$RPM_BUILD_ROOT
36
d1b18853 37%py_postclean
38
39%clean
40rm -rf $RPM_BUILD_ROOT
41
42%files
43%defattr(644,root,root,755)
44%doc CHANGES.txt README.txt
34386890
ER
45%attr(755,root,root) %{_bindir}/coverage
46%dir %{py_sitedir}/%{module}
d1b18853 47%{py_sitedir}/%{module}/*.py[co]
48%attr(755,root,root) %{py_sitedir}/%{module}/*.so
34386890 49%{py_sitedir}/%{module}/htmlfiles
d1b18853 50%if "%{py_ver}" > "2.4"
34386890 51%{py_sitedir}/coverage-%{version}*.egg-info
d1b18853 52%endif
This page took 0.046731 seconds and 4 git commands to generate.